2 Replies Latest reply on Jan 28, 2011 2:01 PM by AspenSkier

    Unable to enter Win 7 AUDIT MODE

    Specialist

      So I have a basic Windows 7 image that I have prepared and sysprep'd on one machine and I've used Landesk Provisioning to send it over to a different machine.  I have validated that my provisioning process works so I'm ready to continue working on my image so that I can get it more polished.  To do this I understand that I need to be in AUDIT MODE in order for me to continue working and to be able to create a customized default user profile.  My problem is that I can't get into Audit mode on the image that I pushed down.

       

      I launch sysprep and select AUDIT MODE, then reboot.  What comes up is bit disturbing.  I see what appears to be a sysprep'd flavor of windows loading and once the GUI loads I see the following in the upper left hand corner of the screen:

       

       

      "<in bold font type>  C:\windows\system32\sysprep\sysprep.exe /oobe /generalize /reboot

      LANDesk Provisioning Install"

       

      I also have the little sysprep circulating progress bar in the middle of the screen, which shows:

       

      "Sysprep is working, Processing generalize phase Sysprep plugins"

       

      This goes on and on for a while then the system reboots and I see that windows is once again configuring the computer.

       

      The computer reboots yet again and my computer is being setup for first time use.

       

      <remember that I've already been through this with my provisioning process and I'm just ready to enter the audit mode>

       

      after the last reboot I get greated with SETUP WINDOWS, where I have to choose the country, time and keyboard layout.  I hit next and have to create a user account...this is just like my initial install process and its all wrong because I've already been through it.

       

      I then hit CTRL-SHIFT-F3 to get into audit mode and the damn computer restarts again only to prepare my computer for first use, again!

       

      after the last reboot I am unable to login to the computer as the password for the local admin account won't work.

       

       

       

       

      I suspect that something is left over from my provisioning template which is screwing with my sysprep process but I don't know what to do about it.

       

       

      How can I get back into AUDIT MODE on a Windows 7 system that was sysprep'd and deployed with provisioning?

        • 1. Re: Unable to enter Win 7 AUDIT MODE
          Apprentice

          I would guess that during your initial provisioning job you've copied your unattend.xml file onto the c: drive - probably into c:\unattend.xml or c:\windows\panther\unattend.xml.  Chances are that file is still there so when Windows boots into audit it looks for an answer file to automate the install - and it finds one!  Find the unattend.xml file and delete it, then put it back into audit mode and you should be good to go.

           

          For subsequent installs you might want to add an action to your template that deletes the unattend.xml file - it will likely have stuff like the local admin password in it that you wouldn't want your average user to stumble upon!

           

          Steve

          • 2. Re: Unable to enter Win 7 AUDIT MODE
            Specialist

            I've already thought about that and one of the final actions in our templates is to remove the unattend.xml file and I can confirm that we have done this.

             

            during the provisioning process, the unattend file is placed in c:\, then at the end of the process it is removed.  This is the only copy of the file that I was aware of and I know it is gone before I try to re-enter audit mode.

             

            That being said I looked in c:\windows\panther, whatever that is, and found a copy of the unattend file there.  I nuked it and tried to get back into audit mode.

             

            guess what?  it worked!

             

             

            -now what the heck is this panther stuff and how did my unattend file get in there?  How can I be sure which unattend file sysprep is using when I launch it?

             

             

             

             

            -in any event I will add a line to remove this file as well.