4 Replies Latest reply on Feb 7, 2011 11:01 AM by AspenSkier

    VBOOT fails on Win7

    Specialist

      Several weeks ago we were running LDMS 9.0 SP1 and successfully using a VBOOT provision in our templates which allowed us to take a windows XP client from the XP OS into WinPE where it would pull down a Win7 Image.  Those machines participated just fine and we made a number of Win7 deployments using our VBOOT-enabled template.

       

      What happened next was that we were unable to take those, now Win7 clients, and use the same template to reimage them.  Well we did the SP2 thing and applied a separate patch called "PRV-5265890" which was supposed to take care of this.

       

      Anyway, now we have a problem whereby a machine that is running windows 7 will reboot with the VBOOT-enabled template and it will get into WinPE and clear the VBoot partition, but then it will stop participating in the task.  The window goes away right after it successfully establishes contact with the console...if we manually reboot the client and log back into windows it will reboot again and right back into WinPE.

       

      it pretty much loops again with the last statement in the CMD.EXE window showing that the WinPE session successfully contacted the landesk core....something something "success", but the window goes away and we're stuck in WinPE.

       

      Another reboot takes us to the login screen but then the damn thing will reboot back into WinPE again if we log in.

       

       

      The provisioning status for the machine shows that it is still RUNNING and that the final step in the first phase of the template, execute bootfile.exe, has not yet completed.  Watching the progress in WinPE contradicts this because we know that the Vboot image was removed, otherwise the reboots would take us right back into WinPE rather than Win7.

       

       

      Personally I think that the Vboot.WIM file, or whatever it may be called, is somehow hosed because it doesn't seem to permit a connection state with the provisioning template as soon as it gets into WinPE.  Still, I have no direct evidence that this is the case as the correct device drivers are loaded with this .WIM and I know that I have not gone in and changed the .WIM nor the vboot instructions.

       

      -anyone with a fix?

        • 1. Re: VBOOT fails on Win7 + XP
          Specialist

          The last thing that I see in WinPE is something like 'the landesk remote control service has started successfully"

           

          the message goes away so quickly that I can't read it all and I don't seem to be able to pause it.

           

          I've just tested this on an XP box and get the same results.

           

          Vboot worked until SP2 and now it is broken.  Please help.

          • 2. Re: VBOOT fails on Win7 + XP
            Specialist

            I can confirm that the client behaves as if it were PXE booted into MANAGED WINPE.  The last thing that flashes across the WINPE screen relates to the Landesk Remote Control Service starting successfully.  After that the window closes and my client is left with an empty LANDesk AN AVOCENT COMPANY-branded desktop.

             

            In looking at the provisioning history for the win7 machine I can see that I have green checks all the way down to EXECUTE BOOTFILE.EXE, where I have a blue circle with a question mark in it.  No steps afterward report as running yet.  And the machine is definitely hung up waiting on further commands.

             

            If I manually reboot the client and get back into the Win7 OS, the template will continue at the EXECUTE BOOTFILE.EXE step of the template and my machine will reboot into WinPE before hanging at the same point as before.

             

            If I delete the machine instance from the scheduled task and reboot intow Win7, the template continues and I am forced back into WinPE again.  Basically my machine is stuck in a loop and since Landesk does not provide us with a way to cancel scheduled tasks, I guess I'm hosed.  But that is another post.

             

             

            The client can communicate with the landesk core; I can remote into the client from a console...it has simply lost touch with the provisioning template and doesn't know what command to execute next.  How do I restore the chain of custody for my provisioning commands?

             

            ***I have attached the vboot template that is included with my provisioning templates in the vent a review is necessary***

            • 3. Re: VBOOT fails on Win7 + XP
              Specialist

              If I make use of the REBOOT action within provisioning and select "Boot to Managed WinPE (Virtual Boot), in lieu of using the VBoot template that I have been using, I get the exact same result.

               

              The machine gets into WinPE, launches the Landesk Remote Control Sesssion successfully, and then hangs.  The little icon for the scheduled task changes from ACTIVE to one that isn't documented...a little green arrow in the upper right with a little clock in the upper left.  The machine still shows as being ACTIVE within the scheduled task.

               

              I am beginning to think that there is a problem with my MANAGED WinPE component.  Whenever I manually PXE-boot my clients to this option I see the same result and I'm never able to run any tasks against them while they are in MANAGED WinPE.

               

              My feeling at this point is that MANAGED WINPE does NOT support provisioning and is simply an old carrry-over from previous versions of LDMS which only supported OSD Scripts.

               

              MANAGED WINPE, does it not support PROVISIONING?

              • 4. Re: VBOOT fails on Win7 + XP
                Specialist

                I found this thread:

                 

                http://kb.landesk.com/support/message/54394#54394

                 

                 

                It basically confirms that 9.0 SP2 broke the VBOOT piece.

                 

                Checking the original document I referenced when creating my VBOOT stuff I found these lines:

                 

                http://community.landesk.com/support/docs/DOC-9980

                 

                "UPDATE: 9.0 SP2 will contain a Vboot option on the reboot action.  These templates will no longer be needed or useful.  The Disclaimer and Warning section below still applies and should be reviewed before the decision is made to use Vboot."

                 

                 

                 

                 

                So now SP2+ users are supposed to skip the old VBOOT template and simply use the REBOOT command with the MANAGED WINPE option.  I gather that it implies the use of VBOOT.

                 

                 

                -guess what, that still doesn't work.