11 Replies Latest reply on Feb 27, 2009 12:04 AM by CIAD_support

    Scripted (unattended) XP Install Stuck - LD8.8



      Hi there,

      I'm attempting to provision a machine with Windows XP using the scripted installation method descriped in this LD8.8 Best Known Method document.

      I've followed the document to the letter with only substituting usernames/passwords/directory locations with my own, but the provisioning task gets stuck at the scripted install part of the OS Installation task. (See attached screenshot)

      In the results tab, the execution status says "Might Reboot"




      In terms of where it gets stuck in relation to the entire provisioning procedure, this is just after the first boot into the newly provisioned operating system.

      I tried rebooting the machine manually, but to no avail.

      I assume LANDesk is waiting for a command to say that the xp install completed successfully?




      Any help would be greatly appreciated.



        • 1. Re: Scripted (unattended) XP Install Stuck - LD8.8

          When you do a scripted install, ldprovision.exe (and its accompanying files) are inserted into the installation along with a simple copy of the LANDesk agent. This ensures the provisioning template continues once you boot into the target operating system.


          Check the root of C: for a folder called ldprovision. There should be a log file in there called ldprovision.log. It may tell you why it's failing. If the ldprovision folder is there, then something went wrong, as it deletes itself after the provisioning template finishes.


          Are you sure that there is a valid network driver in the target OS? It has to be there and loaded or the provisioning agent can't talk to the core.

          • 2. Re: Scripted (unattended) XP Install Stuck - LD8.8


            Thanks for the quick response IronMike.



            The c:\ldprovision directory does exist on the newly provisioned machine, however there is no ldprovison.log therein.



            Although i havent specified exact network drivers for the machine using  OemPnPDriversPath value in the unattended.txt, Windows appears to have a match close enough, as i'm able to get an IP, and browse network resources etc.



            • 3. Re: Scripted (unattended) XP Install Stuck - LD8.8

              Hmmm...interesting. Check if you have the LANDesk Management Agent service installed. It has to be there also, and it has to be started.


              You can also check the ldprovision.log file in the ldmain\log directory. Check that file as well.

              • 4. Re: Scripted (unattended) XP Install Stuck - LD8.8

                The LANDesk Management Agent service is installed, and started.


                There is no ldprovision.log file in the ldmain\log directory, however there is one located at  ldmain\log\provisioning so i assume you're reffering to that one ...

                There are reports of errors, but they are uselessly undescriptive:



                STARTUP    DHCPServerInterface    ERROR    20/02/2008 2:41:17 PM    Logging started

                STARTUP    ProvisioningService    ERROR    20/02/2008 2:41:20 PM    Logging started

                STARTUP    DHCPServerInterface    ERROR    20/02/2008 2:41:20 PM    Logging started





                I have a feeling that those log entries are old also, and not referring to the most current attempted provisioning task.





                I just changed the defaut logging level to DEBUG (in LogLevel.ini) and ill run the provisioning task again, and hopefully it'll produce more helpful logging.

                • 5. Re: Scripted (unattended) XP Install Stuck - LD8.8


                  Unforunatly debug level logging doesnt help.

                  Running the provisioning task again with this log level enabled, didnt produce any errors at all.



                  Any other suggestions?



                  • 6. Re: Scripted (unattended) XP Install Stuck - LD8.8
                    bnelson Employee

                    I am having the same issue only I use 8.7 SP 4. The OS installs without issue but the agent doesn't install at all even though it says successful.

                    • 7. Re: Scripted (unattended) XP Install Stuck - LD8.8

                      @ bnelson: I'm not sure we're having the same problem. My scripted install gets stuck waiting for the scripted install to complete, even though all the actions of that script have finished. As i said in an earlier post, the c:\ldprovision directory gets created and populated, and the LANDesk Management Agent service is installed an running.





                      This brings me to something interesting i discovered in the wee hours of the early morning.

                      After i let the provisioning task run, and the destination machine has booted into windows (and the problem has occured where the provisioning task is stuck), i tried to manually execute c:\ldprovision\ldprovision.exe which crashes. (see attached).




                      When this error occurs, it then generates a ldprovision.log file, with the following contents:




                      2008-02-20 07:06:31(360-548) ldProvision.exe:ldProvision started

                      2008-02-20 07:06:31(360-548) ldProvision.exe:Unable to load action configuration file; using default action configuration

                      2008-02-20 07:06:31(360-548) ldProvision.exe:waiting for ProvisionGUI.exe to start. timeout is 10 minutes.

                      2008-02-20 07:06:31(360-548) ldProvision.exe:ProvisionGUI.exe not found. Can not show GUI.

                      2008-02-20 07:06:31(360-548) ldProvision.exe:Caught exception in main: code=80001301H, file=.\TaskInfo.cpp, line=355




                      So from that, i gather that not all the required provioning files are being copied to the c:\ldprovision directory correctly, more specifically, the ProvisionGUI.exe.

                      Can anyone think of a reason why that might be occuring? Or more importantly, how to resolve it?

                      • 8. Re: Scripted (unattended) XP Install Stuck - LD8.8

                        I don't think it will ever work if run manually, so don't start troubleshooting that.


                        When you boot into the target OS, does the ldprovision.log (in c:\ldprovision\ldprovision.log) log anything? If not, then it's like the scripted install is not finishing somehow. If this is what's happening, you may just want to open a case with LANDesk. This issue seems fairly complex and difficult to troubleshoot via forum posts.

                        • 9. Re: Scripted (unattended) XP Install Stuck - LD8.8

                          There is one thing that shouldn't matter at all, but I'll mention it anyway. I noticed in your scripted install action you are pointing to the I386 directory. I've always pointed to \I386\winnt32.exe and it's always worked for me. I can't imagine this is related to the problem, but I figure any difference is worth mentioning...

                          • 10. Re: Scripted (unattended) XP Install Stuck - LD8.8


                            I tried adding winnt32.exe to the scripted install script, but as you correctly stated, it didnt change anything.


                            When i boot into the target OS, there is no ldprovision.log file. Running ldprovision.exe manually generates the log file with the contents i posted above.




                            I guess ill have to  log a support case with LANDesk as you suggested.


                            Ill keep this post updated with any information the LANDesk team provides.







                            • 11. Re: Scripted (unattended) XP Install Stuck - LD8.8



                              I have the same problem with an image deployement... Did you already obtain some information from the LanDesk support ?