2 Replies Latest reply on Apr 7, 2011 1:51 AM by WINZ-Backoffice

    Slow imaging - sometimes...


      I have a strange problem.


      We have an image for our Dell T7400 and T7500 systems.   (Dual Xeon COU, onboard RAID 1)   Using the Windows PXE system we have a provisioning template that waits for 5 minutes after the template is started, then we map drives to the image tool and the image itself, then we use imagew 2.x to depliy an image.

      When we originally deployed the systems it took about 20 minutes to lay down the image.  Now it takes over an hour and then fails to finish the Provisioning template.  Sometimes (we dont know why) the same machine, same network connection, same eveything, will suddenly work and succesfully deploy in 20 minutes!

      When the image template fails the error in the provisioning log is Caught exception in main: code=80001500H, file=.\ProvisioningWebSvc.cpp, line=888"

      One this message appears you can not even restart the ldprovision tool (x:\ldprovision\ldprovision.exe) as it returns the  error error:[80001500H]WebServiceCall at: [888]ProvisioningWebSvc.cpp Execute result: return:0.  It is almost as if the management connection to the LDMS server has been dropped. The Drive mapping connections are fine including the one to the LDMS ldmain share.


      Using the same PXE image and the same provisioning template on a Dell Optiplex  takes 20 minutes but of course fails due to the incorrect hardware.

      Using the same PXE image but cancelling the provisioning template (after it says its going to take 1 hour) then mounting the local disk and copying the image file from the source to the local disk takes less than 3 minutes (4Gig image over Gigabit LAN).

      Moving the image source to a different host has no effect on the imaging speed, reducing the network connection to 100Mb has no effect, Restarting the server has no effect, Deleting the machine in Landesk has no effect.

      PXE image was not changed since the original deployment but sice the problems started we have updated the image with new SCSI controller drivers, Network drivers, and Intel chipset drivers all with no effect.  Reverting to the PXE image from our original deployment has no effect. The Original PXE image does not have all the drivers in it so not tested


      So, I have two questions.


      1)  Does anybody have any suggestions on how to find out why the image process takes so long?


      2) Does anybody know how to fix the apparent connection (timeout?) issue for the connection to the LDMS server?

      We are running LDMS 8.8 SP3 with 2 hotfixes - LD88-Rollup-07-09 - PatchBiz.dll ( and LD88-Rollup-07-09 -LANDesk.Provisioning.Data.dll (

      Moving to SP4 is not an option at this time.

        • 1. Re: Slow imaging - sometimes...

          You may be having a different issue but just to ask...have you tried making another machine a PXE rep? Another thing to look for is the startrom file could be outdated on the PXE reps. I had this problem about a year or so ago where the imaging would be 2 minutes and then the next time I would image it would shoot to 2 hours and hang infinitely at the TFTP screen; same PXE rep, same image location...etc.... as soon as I updated the startrom, I had no issues and it zipped right along. I had to copy to all my PXE reps and overright the existing.




          I would suggest seeing if you have the same problem booting into PXE being hosted by a different PXE rep. If that doesn't work, give the startrom change a try. I have a copy of files that work here if you want to attempt. As far as the timeout setting, can you paste the entire log?

          • 2. Re: Slow imaging - sometimes...

            Thanks for the suggestion, but we have already tried a new PXE rep on a separate machine.

            We had also made the startrom changes. Our startrom was dated 16/Feb/2007 which is the one from W2k3 SP2/W2k3 R2.  Using the one from W2k3 Sp1 really slows down the loading of the actual PXE boot file but has no effect on the time take to lay down the image.


            Question 1)

            Further investigation bring us to believe it is partially a problem with the Windows XP 64 OS image. 

            If we provision a 32 bit image it take 8 minutes to lay down the image on the T7500.  On a standard Dell 780 it takes 3 minutes.

            If we provision a 64 bit image it takes 1-2 hours on the T7500 and 20-25 minutes on the 780.


            Question 2)

            We have confirmed that there IS a timeout issue with the Web Services.  By placing a 1 hour wait in the 32 bit provisioning task on a 780 we can cause the Provisioning task to fail with the exact same error.

            Retrieving the image from the LANDesk server has no effect.