4 Replies Latest reply on Jun 29, 2011 7:01 AM by gwsmith

    Console login fails with HTTP status 401: unauthorized

    Apprentice

      When I try to log in to Console, either with or without integrated login, I get the error, "Response from Services.  The request failed with HTTP status 401: Unauthorized."

       

      1-Login.jpg

      I created a web page with instructions on how to use prompted queries in Self Service (a whole other subject).  At first I tried to create a sub-directory under wwwroot, but I couldn't access it from a browser.  I tried making it a virtual directory and an application, but it still gave me an error about the authentication.  Finally I deleted the folder and created a new folder under Web Access.  The Console login problem started after this.

       

      I looked at the settings at different levels of the web sites, but I didn't mean to change anything.  A similar issue in the forum involved a server that had been renamed:

       

      http://community.landesk.com/support/message/57151

       

      The advice there was to uninstall IIS and Service Desk and reinstall.  I really don't want to do that, since Service Desk probably won't uninstall (a whole other subject).  If it's just a permissions problem, on which folder do I need to look?  Web Access still works.

       

      Touchpaper.Framework.Web has Anonymous Authentication set to Enabled and Windows Authentication disabled.  The settings are the same at the Default Web Site level.

        • 1. Re: Console login fails with HTTP status 401: unauthorized
          Apprentice

          I fixed the problem, but I hope I didn't break something else in the process.  I selected Default Web Site in IIS and clicked  on Authentication.  Then I right-clicked on Anonymous Authentication  and selected Edit.  Then I changed it from Specific User (IUSR) to  Application Pool Identity.

          • 2. Re: Console login fails with HTTP status 401: unauthorized
            Apprentice

            I had the same problem so I solve it as you, And nothing goes wrong after

            • 3. Re: Console login fails with HTTP status 401: unauthorized
              Rookie

              Hi,

               

              Few weeks ago I got this issue, then I was tried to solve as you mentioned by change the Specific User (IUSR) to Application Pool Identity.

              and after that the system could run normally.

               

              Recently I did IISRESET on this LD web server because there's some changes on my landesk configuration (process, window, query, dashboard, etc), But after IISRESET I was facing same error message again which is "The request failed with HTTP status 401: Unauthorized.", and all users could not login by using Console, but webdesk was still able to accessed and working properly with no error.

               

              For the time being to solve the issue, I did restarted on LD web server and everything OK all user could be able to login LANDesk by using Console.

               

              Did you facing recurrent issue like this after change the Specific User (IUSR) to Application Pool Identity? Do you know what is the root cause of this issue?

              so that in future we know how to prevent it.

               

              Thanks for any comments,

               

              Regards

              • 4. Re: Console login fails with HTTP status 401: unauthorized
                Apprentice

                I never had any more trouble with this.  It only happened the one time.  I don't know exactly what caused the problem in the first place.