5 Replies Latest reply on Mar 6, 2013 8:23 AM by praveen.tiwari

    Problem: Software distribution of Adobe CS3 Mac Package in DMG format

    Rookie

      Hi everyone,

       

      I am currently using Landesk LDMS v9.0 Sp2 product running on Windows 2008 R2 server.

       

      I have created an Adobe CS3 Mac package using first converting the setup disk into a read-writetable DMG file and then injecting the install.xml, uninstall.xml and application.xml.override files into it (per instruction from Adobe CS3 deployment documentation).  Through the Landesk software deployment, I have defined the new mac packge to push this DMG file out to my mac client (one is mac osx 10.6, one is mac osx 10.4). I could see that the DMG file (file name: Adobe CS3 Design Standard.dmg) was successfully pushed to the /Library/Application Support/LANDesk/sdcache location of both mac clients. However, the dmg file just got mounted and dismounted almost immediately after that, which I found out by reading through the LANDesk.log file in the upper folder.

       

      Tue Mar  8 14:38:12 2011 [04393] sdclient : execute: 'echo "Y" | /usr/bin/hdiutil attach -mount required -noidme -nobrowse -plist '/Library/Application Support/LANDesk/sdcache/Adobe CS3 Design Standard.dmg''

       

      Tue Mar  8 14:38:15 2011 [04393] sdclient : execute: 'hdiutil eject '/dev/disk1s2''

       

      However, I could manually mount the dmg file by using the mac command hdiutil attach <filename of dmg file in sdcache folder> command with succuss. My dmg file was about 2.5GB.

       

      To ensure the mac package deployment method based on dmg file is correct, I have downloaded the firefox install dmg and chrome install dmg source and pushed out to two mac computers via my Landesk server based on the same procedure I used to deploy CS3. Both dmg packages were successfully mounted and installed without any problem.  The only difference is the size of the CS3 dmg file.

       

      I have no idea how to fix the CS dmg issue. Has anyone come across this kind of problem before and suggest me a way out?

       

      Thanks again!

      Kenneth

        • 1. Re: Problem: Software distribution of Adobe CS3 Mac Package in DMG format
          Apprentice

          Just a quicky question

           

          Did you edit the xml files on a pc at anytime?

           

          The only thing i can think of that may be causing this, from what i remember you need to make sure the xml's are properly formatted, I had to use the notepad++ and set it to correct format. After that CS3 and CS4 all worked fine. I understand its the "quaotation marks" that was screwing things up...

           

          hope this helps...

           

           

          Steve

          • 2. Re: Problem: Software distribution of Adobe CS3 Mac Package in DMG format
            Rookie

            Were you ever able to find a fix? I am expierencing the same issue and have tried the following in the install/uninstall options of the deployment package:

             

            -exec “/Volumes/Adobe\ CS3\ Design\ Standard/Adobe\ CS3\ Design\ Standard/install.sh”

             

            -exec “/Volumes/Adobe\ CS3\ Design\ Standard/Adobe\ CS3\ Design\ Standard/Setup.app/Contents/MacOS/Setup” –mode=silent –deploymentFile= /Volumes/Adobe\ CS3\ Design\ Standard/Adobe\ CS3\ Design\ Standard/deployment/install.xml

             

            -exec “/Adobe\ CS3\ Design\ Standard/Adobe\ CS3\ Design\ Standard/Setup.app/Contents/MacOS/Setup” –mode=silent –deploymentFile= /Volumes/Adobe\ CS3\ Design\ Standard/Adobe\ CS3\ Design\ Standard/deployment/install.xml

             

             

            The install.sh script basically calls

             

            “/Adobe\ CS3\ Design\ Standard/Adobe\ CS3\ Design\ Standard/Setup.app/Contents/MacOS/Setup” –mode=silent –deploymentFile= “/Volumes/Adobe\ CS3\ Design\ Standard/Adobe\ CS3\ Design\ Standard/deployment/install.xml”

             

             

             

            I have verified the install.sh script runs. I can mount the dmg and call the install.sh and the silent install begins.

            • 3. Re: Problem: Software distribution of Adobe CS3 Mac Package in DMG format
              Apprentice

              Hi Ray

               

              Reading from your post, it sounds like the Landesk side is failing on the deployment- am i correct?

              Did you inspect the logs from the core? they can give you a hint what is going wrong.

               

              The first thing that jumps to mind is the share where the DMG files- can you run the DMG from the mac and install?

               

              The other thing is to try the full http server name and share..

               

              so http://server.domain.com/share/folder

               

              steveperks

              • 4. Re: Problem: Software distribution of Adobe CS3 Mac Package in DMG format
                Rookie

                Thanks for the reply:

                 

                I believe I got the issue resolved.

                I had to use the install.sh script.

                In the install/uninstall line, i used:

                 

                -exec Adobe\ CS3\ Design\ Standard/install.sh

                 

                Seems the -exec is called within the root of the DMG, so my previsous command lines were calling the script from the full path.

                Even though I modified the -exec to call the Adobe\ CS3\ Design\ Standard\Setup.app\Common\MacOSX\Setup --mode=silent --deploymentFile="/Volumes/Adobe\ CS3\ Design\ Standard/deployment/install.xml"

                 

                That still failed. Only calling the install.sh that I had to create and inject into the DMG seemed to work.

                • 5. Re: Problem: Software distribution of Adobe CS3 Mac Package in DMG format
                  Rookie

                  I am facing incopy CS5 package deployement issue.

                   

                  Installed Adobe Application Manager and created Adobe incopy CS5 package. then there were below file created

                   

                  Adobe Application Manager

                  Build

                  Exceptions

                  Adobe InCopy CS5_5.aame

                   

                  We have deployed Adobe InCopy CS5_5.aame package and it got failed (fatal error during installation error code 1603)

                  again tried to deploy package

                   

                  InCopy CS5_5\Build\Adobe InCopy CS5_5.msi but same error.

                   

                  Will you please assist me. if possible please provide all the step so that i can deploye this package on urgent package.