6 Replies Latest reply on Mar 2, 2008 7:10 PM by jrrbrown

    Office 2007 Deployment

    Rookie

       

      Hi to all

       

       

      I am having a bit of a strange issue with deploying Office 2007 Professional Plus using LANDesk 8.8 to an environment, the package completely copies to the client with no issues, however the installation will not run silently or automatically. I have created the appropriate .MSP file and have selected the options for no cancel and for supress model.

       

       

      I have tried placing the .msp file in the updates directory and I have tried placing it at the root of the distribution share along with teh setup.exe and specifying the /adminfile file.msp in the additional install/unistall options in my package.

       

       

      I have deleted and recreated my package and tried several different distribution methods with the same result, the packages successfully goes to teh client then the dialog opens asking for interaction.

       

       

      BTW all clients have the agent upgraded to the most recent 8.8 client agent version

       

       

      Any ideas would be appreciated

       

       

       

       

       

        • 1. Re: Office 2007 Deployment
          phoffmann SupportEmployee

          There's more than just creating the MSP file. I'm assuming you've made sure that the "source" is an actual admin-install?

           

          It's something I stumble over myself in my lab now and then, running a "vanilla" copy of Office against an MSP - the results are very different :). It very much needs to have an administrative install to use the MSP file to run properly.

           

          Paul Hoffmann

          LANDesk EMEA Technical Lead.

          • 2. Re: Office 2007 Deployment
            Rookie

             

            Yes the source was configured as an administrative deployment point using the deploying Office 2007 best practices document from LANDesk and also using methodologies described in the Office 2007 Resource kit and other sources of information on Microsoft Technet. As stated earlier the actual copying of the files to the local cache on the test machine id flawless, it just does not install without intervention regardless of how the .MSP file is configured.

             

             

            Cheers

             

             

            • 3. Re: Office 2007 Deployment
              phoffmann SupportEmployee

              Interesting.

               

              Well - you can turn on MSI logging and try to figure out what's going on (the most likely way to shine a light on this)...

               

               

              Set the following reg key to get MSI log on %temp% directory.

               

              HKML\SOFTWARE\Policies\Microsoft\Windows\Installer

              string: voicewarmup

               

              I'll assume that you don't have anything unusual in the SDCLIENT logs themselves, so maybe figuring out what MSIEXEC is doing might help...

               

              Be aware that the MSI-log reader is different for each version of MSIEXEC - so there's one for version 2.x and one for version 3.x

               

              ... the only thing i can guess at the moment to be caused here, is that there's some kind of local (or domain?) policy that's causing MSIEXEC to misbehave ... since the LANDesk-command line switches should be the same, if you use the same options...

               

              Paul Hoffmann

              LANDesk EMEA Technical Lead.

              • 4. Re: Office 2007 Deployment
                phoffmann SupportEmployee

                Addendum.

                 

                You might want to try to get an MSIEXEC-based install silently from command-line. if that works for you, then you can use a batch-file based distribution as a workaround while you're figuring out what's going on here that "normal" methods don't behave consistently for you.

                 

                Paul Hoffmann

                LANDesk EMEA Technical Lead.

                • 5. Re: Office 2007 Deployment
                  zman Master

                   

                  It will help us if you post:

                   

                  1. Actual command line your a running

                  2. log files - Turn on verbose logging in your config.xml

                  3. Your config.xml

                  4. How you are deploying in LANDesk (Distro Package, Delivery method, properties)

                  5. Your sdclient log file from the deployment.

                  Thanks

                  • 6. Re: Office 2007 Deployment
                    Rookie

                     

                    Hello to all

                     

                     

                     

                     

                     

                    Thank you all, all very helpful answers, the actual problem turned out to be in the msp file created using the OCT. I was trying to be smarter than the program and in the section where you select to remove previous programs I had selected to not do anything with Outlook because Outlook 2007 had already been installed. Once this setting was changed the package behaved as it should.

                     

                     

                     

                     

                     

                    Once again thank you all.