3 Replies Latest reply on Apr 4, 2011 12:12 AM by samir.gammal

    Installation with additional files fails

    Rookie

      Hi,

      I am having very odd problems to distribute a software using LDMS 8.8 SP4.

      It is basically a batch file that should run an .exe with additional files. Every time I deploy it, it takes forever and after it fails, there are entries in the log saying "ERROR: Additional files in packages are not supported for pre 8.5 clients" and "client version LDMS8_5 does not support deferral options" - but the client has at least v. 8.8 installed. At least, I can see this line in the log:

      Mon, 14 Mar 2011 16:44:53 sdclient file version characterized as LDMS8_8_1

      which I think should be prove that the client has an actual version installed.

      I am doing a Push installation. In the sdmcache directory, I can see the corresponding taskmanifest....ini file (!), but the other files for the distribution will not be written there. Share and File Permissions should be OK for the server (I guess, as it is able to write the taskmanifest...ini file there...). Tried to deploy to several servers (w2k8 R2 and w2k3), with no success. I checked also proxyhost.log on the client machine, but connections do have status 200 - as far as I understood, this should be the case when OK.

      Cannot see what I am doing wrong right now, any help appreciated.

      Thanks,

       

      Sam

        • 1. Re: Installation with additional files fails
          Specialist

          Have you check the scheduler log on the client machine and on the core and see if there is any error in the download process.  It see if it is downloading from peer, core, or mdr.  If you have make changes in your packages have you re-hash it.

           

          %programfiles%\LANDesk\LDClient\Data\sdclient_task(your task id).log

           

          \\servername\ldlog\ScheduledTaskHandler_(task id).log

          • 2. Re: Installation with additional files fails
            Tracy Expert

            Sam,

             

            If we cannot verify the agent version, we will default to legacy... Since we can't tell what specific fetures the client actually supports. Usually, this is caused by an incomplete inventory for the targeted machine. Try running a full inventory scan and try again.

             

            If we cannot determine the version in inventory, we should also check the version of SDClient.exe on the client to verify version. You should see something like this in the \ManagementSuite\log\scheduledtaskhandler_xx.log file

             

             

            Fri, 25 Mar 2011 13:54:34 Machine type is 14
            Fri, 25 Mar 2011 13:54:34 Windows machine targeted
            Fri, 25 Mar 2011 13:54:34 Remote execute of application 'C:\Program Files (x86)\LANDesk\LDClient\fileversion.exe', params '"C:\Program Files (x86)\LANDesk\LDClient\sdclient.exe"' on THVMW (2805a8c0)
            Fri, 25 Mar 2011 13:54:35 Remote execute of application 'C:\Program Files\LANDesk\LDClient\fileversion.exe', params '"C:\Program Files\LANDesk\LDClient\sdclient.exe"' on THWINXP (6b05a8c0)
            Fri, 25 Mar 2011 13:54:35 sdclient file version characterized as LDMS9
            Fri, 25 Mar 2011 13:54:35 THVMW, executing C:\Program Files (x86)\LANDesk\LDClient\sdclient.exe /p="http://THLD90/ldlogon/Packages/Virtual/ScreenHunter.exe" /levels=4 /Hash=aEqmPhK1jwyemOOj3ofRYg== /FileListName="taskmanifest.THLD90.36.16.ini" /FileListHash="Y8dzoW3VF9SCVB25hWNQ3Q==" /N /An /wan=50 /lan=75 /taskid=36 /core="THLD90:192.168.5.122" /EnableVirtualAppShortcuts "/shortcut=Screenhunter" /desktoplink "/startlink=Screenhunter" /vapp
            • 3. Re: Installation with additional files fails
              Rookie

              Hi,

              Thanks a lot for your response.

              I had it re-hashed several times with no avail.

              It was indeed the download method that was wrong, I had set "from peer" which does not work in our environment. Changing it to "from core" solved the problem.

              Again, thanks and best regards,

               

              Sam