7 Replies Latest reply on Oct 6, 2009 12:17 PM by jan.buelens

    LD8.8 WinPE boot fails with TXTSETUP.OEM error

    JSMCPN Expert

      This a virgin copy of the 8.8 LDVPE.IMG - I get the error as soon as the "F6" prompt goes away:




      File TXTSETUP.OEM caused an unexpected error (18) at line 1896 in d:\srvrtm\base\boot\setup\oemdisk.c.

      This happens on EVERY model of PC we own, regardless of IDE/SATA storage controller.

        • 1. Re: LD8.8 WinPE boot fails with TXTSETUP.OEM error
          bnelson Employee


          Have you tried to ensure that the drivers are in the image? Add the drivers for the storage controllers using the  LANDesk console and test it again.



          You can also check to see if your drivers are already added to the PE image in LANDesk while you are there, prior to adding them in.



          If that fails let me know what the controller version is and we will start from there.



          • 2. Re: LD8.8 WinPE boot fails with TXTSETUP.OEM error
            JSMCPN Expert

            The problem has something to do with the infamous Intel IASTOR.SYS driver located in \I386\system32\driver.0 . It's strange, the TXTSETUP.OEM file is identical to the one I injected into 8.7.


            I just extracted the SP3 and 8.8 images and Windiff'ed them, merged the desirable changes from 8.8 into SP3 and now it works properly again.


            If anyone is interested, the computer models that failed with the TXTSETUP.OEM error are:


            HP dc5000, HP dc5100, HP dx5150, HP dc5750, HP TC4200 TabletPC, HP TC4400 TabletPC, HP XW4400 Workstation.


            My 8.7 PE image works perfectly with all those models, using the same IASTOR.SYS and TXTSETUP.OEM


            The only difference I can see is the \I386\TXTSETUP.SIF file, where in 8.7 I added these lines to the HardwareIDsDatabase section...



            PCI\VEN_8086&DEV_2652&CC_0106 = iastor
            PCI\VEN_8086&DEV_2653&CC_0106 = iastor
            PCI\VEN_8086&DEV_27C1&CC_0106 = iastor
            PCI\VEN_8086&DEV_27C5&CC_0106 = iastor
            PCI\VEN_8086&DEV_2681&CC_0106 = iastor
            PCI\VEN_8086&DEV_2821&CC_0106 = iastor
            PCI\VEN_8086&DEV_2652&CC_0104 = iastor
            PCI\VEN_8086&DEV_27C3&CC_0104 = iastor
            PCI\VEN_8086&DEV_2682&CC_0104 = iastor
            PCI\VEN_8086&DEV_27C6&CC_0104 = iastor
            PCI\VEN_8086&DEV_2822&CC_0104 = iastor 



            ...and this line to the SCSI.Load section

            Iastor = iastor.sys,4


            • 3. Re: LD8.8 WinPE boot fails with TXTSETUP.OEM error

              We're having this issue also at the Univ. of Maryland and our HP DS5750's. We're using ATI/AMD driver chipsets instead of intel so I'm not sure how this would apply or where we should start digging but what we've tried is starting fresh with no additional drivers in our WinPE image except the NIC and SATA drivers for the HP DS5750.



              The machine will boot up and then we get the error





              "File \i386\system32\driver.0\x86\ahcix86.sys caused an unexpected error (18) at line 2335 in d:\srvtm\base\boot\setup\oemdisk.c"





              We've never really messed injected or changing drivers other than using the OSD segment of the LanDesk package.








              Also, what SATA drivers are you using for your HP

              5750? We’re having issues getting WinPE working with our HP DS5750’s but using

              AMD/ATI chipset drivers, not intel drivers.

              • 4. Re: LD8.8 WinPE boot fails with TXTSETUP.OEM error

                I found the solution to your problem with:


                "File \i386\system32\driver.0\x86\ahcix86.sys caused an unexpected error (18) at line 2335 in d:\srvtm\base\boot\setup\oemdisk.c"


                seems to be a problem with the way OSD is managing the drivers on the PE disk. When you go through the console and add your mass storage drivers it lays all the files in a flat directory, it will not retain the folder structure.


                So what i did is opened up the ldvpe1.img with winimage and go to i386\system32\


                in there you will see your driver folders, in your example it would be driver.0


                create a folder on your desktop called x86 and then drop the .inf,.sys,.cat file in that folder and then drag that folder into your driver.0


                close the image and copy it back out to your pxe rep


                now you should boot up fine and load the drivers.

                • 5. Re: LD8.8 WinPE boot fails with TXTSETUP.OEM error

                  Forgive my sceptcism but the above doesn't quite sound right. I think you got lucky because of a side effect, but what you describe is neither the real cause nor the real solution. I wouldn't advise any innocent visitors of this forum to try this at home...


                  The attached document (part of this posting on my blog) describes various ways in which an 8.7 / 8.8 WinPE image can go bad and how to clean up when it does. The error message that is the subject of this thread is one of the symptoms that it describes and for which it gives an explanation.


                  Have you seen this article? This is what many people have been using recently to import drivers. General feedback is that it makes things a lot easier...

                  • 6. Re: LD8.8 WinPE boot fails with TXTSETUP.OEM error

                    Unfortunately, the latest winpe driver pack does not support the AMD SATA AHCI Controller Driver. It works wonders on all my Intel Laptops, but our new laptops are all coming with this SATA driver.  I can boot up into PE with the latest driver pack, however diskpart or any functions related to the hard drive won't function because the hard drive doesn't show up.


                    That was kind of the same reason I didn't check out the wpeaddmsd tool, because it seems like it was aimed towards Intel and my above posting worked just fine.  I'll test out the tool and see if it indeed works on this chipset, these AMD's have been giving me nothing but headaches...

                    • 7. Re: LD8.8 WinPE boot fails with TXTSETUP.OEM error

                      It is true that the driver pack includes the Intel SATA drivers but not the AMD SATA drivers. This is because what is possible in the case of intel (go to the intel web site and download a generic, vendor-independent driver) is not possible in the case of AMD. To the best of my knowledge, you can't get the driver directly from AMD, you can only get it from the PC vendor.


                      Although the driver pack tool doesn't download the AMD SATA driver for you, you can manually add it. Create a subfolder called amd.msd and put the driver files (ahcix86.inf and ahcix86.sys) in it. The wpedrivers tool will import it like the other drivers. At least, it should as of today (I just posted a new verion). It turns out wpedrivers didn't like the AMD SATA because of a subtle difference with "more typical" drivers.