4 Replies Latest reply on Jun 1, 2011 4:15 PM by Sean.Nowels

    Provisioning shows Success Post-OS install, but action incomplete


      I'm currently running on LD 8.8 SP4 and trying to create a Provisioning template for Windows 7 x64.


      My image is loading fine, but in my Post-OS installation action, I'm creating a folder to copy my drivers into.


      I've weeded the template down to just the creation of the folder, mapping a drive, and copying the contents of that folder to the target machine.


      All of these actions show success, but when I boot up the machine, the folders and files do not appear.


      If I run the same tasks in the System configuration of the template, all the actions run normally and my file is created.


      I know I'm missing something with this Post-OS intallation area, but I'm stumped.


      Should I try and create these folders with the unattend.xml command?



        • 1. Re: Provisioning shows Success Post-OS install, but action incomplete

          For anybody keeping score, I also tried to do this same action in Windows 7 32bit.


          The same issue happens. The driver file shows that it was successfully created, and the files start to copy down, but the copy driver file errors out. When the machine is then booted, there is no driver file in the root of C.

          • 2. Re: Provisioning shows Success Post-OS install, but action incomplete
            Cedric GRENON Apprentice

            Show process of Unattend install of windows 7


            Check the files on your disk before reboot, to see if are there.



            In windows xp, the sysprep clean the c:\sysprep folder. It would be the same with unattend of windows 7 with other parameters and files..


            Check out this way.

            • 3. Re: Provisioning shows Success Post-OS install, but action incomplete

              Thanks Cedric.


              When I sysprep the image, the file c:\driver (where the drivers will be loaded into) is not present.


              During the build process using the template, after the OS has come down, I tell the template to create this file, then load drivers into it. The action does show success, but the copydriver action will fail in Post-OS. If I boot up the machine and look for c:\drivers (because it showed it was successful in creating this folder) the folder is not there.


              I tried this on Windows 7 64 and 32bit systems.


              Yesterday, I tried to create the folder before sysprep so it would already be present when it came back down, thinking that maybe there was some kind of permisisions issue with the C root. I then tried to make a new folder in that one to populate the necessary drivers, but it behaved the same way.


              The Post-OS action showed it was successful in creating the folders, but nothing was present when I booted up. My driver folder was empty still.

              • 4. Re: Provisioning shows Success Post-OS install, but action incomplete

                Hey, I found a solution to this issue. Or at least I'm on the right path.


                When Win 7 is installed, it creates a separate 100mb partition on the front end of the drive. You can find out more here:




                Because this is present, when the system boots to install the driver folder and copy the files down, it's not pointing to the C drive like it should, but trying to install on this hidden partition.


                The above article shows how it can be removed and then you can have the C drive as the primary active partion, then delete the partition not in use.


                I also used a partition disk that almost did the same thing, but I had to use a repair disk to get the MBR fixed.


                Once this was done, I was able to capture my image, then use my typical process to copy and inject drivers. The C\drivers folder finally created and drivers did install to it.


                Good luck to everyone and thanks for all the suggestions.