5 Replies Latest reply on Mar 14, 2008 9:28 AM by Ty

    LD 8.80.0.249 sw deployment and Vista

    Rookie

      Hi

       

      We have been waiting for some time on LD 8.8 , finally it appeared and it's installed so now i should have support for sw distribution for Vista clients.

       

       

      When trying to deploy packages i have used on XP all fails when trying to install on a Vista based client.

       

       

      Are there something i have missed ?

       

       

      /freddy

        • 1. Re: LD 8.80.0.249 sw deployment and Vista
          zman Master

          Are there something i have missed

           

           

           

          1. What is the actual error displayed in the console?

          2. Can you post the sdclient logs from the client?

          3. How are you deploying - push - pull - tmc - etc? Some more information about your delivery methods.

          4. Are the packages snapshots, msi, etc...?

           

          • 2. Re: LD 8.80.0.249 sw deployment and Vista
            Employee

             

            A strong recomendation would be for you to disable UAC on your client machines.  I can deploy software all day to Vista machines.  What errors are you seeing.

             

             

             

             

             

            • 3. Re: LD 8.80.0.249 sw deployment and Vista
              Jared Barneck SupportEmployee

              You cannot use a delivery method with Feedback enabled and deploy to Vista unless you check to run as the current user in the distribution package, due to Vista security and the session 0 isolation on Windows Vista systems.

               

              If you try you will get this error:

              Install aborted, unable to display package UI due to session 0 isolation on Windows Vista systems.

               

              • 4. Re: LD 8.80.0.249 sw deployment and Vista
                Rookie

                 

                Hi.

                 

                 

                I found out what i needed when looking in some of the logfiles at the client. It stated "we cannot distribute software when using UI ". So i had to change the packages that was using UI on XP !!

                 

                 

                Why don't they use the console to display such errors, going thru a lot of logfiles on the client ???

                 

                 

                 

                 

                 

                /freddy

                 

                 

                 

                 

                 

                • 5. Re: LD 8.80.0.249 sw deployment and Vista
                  Employee

                  Vista actually blocks the application from running when showing UI.  It has nothing to do with Software Distribution, it has to do with all the crazy security that has been implimented into Vista.  Recomendation:  "DO NOT" show UI when deploying software to Vista machines.