6 Replies Latest reply on May 18, 2011 6:58 AM by billyc

    PXE Representative Deploy alway failed??

    Rookie

      Hi everyone,

           I'm setup the LDMS 9.0.2.3 and I'm trying to deploy PXE Representative to the server that i want it to be. But when i start schedule task it alway failed with "the system cannot find the file specified" and return code "2"

           any idea for this problem ??

           Notice: i've installed Landesk to Drive:D , may because of this that why it's alway failed?

        • 1. Re: PXE Representative Deploy alway failed??
          MarXtar ITSMMVPGroup

          Go into your management suite server installation directory and then the log directory. You should find a log file similar to:

           

          CJ-PXE Representative Deployment-8-05092011-112656

           

          This should record everything that happened during your installation and if you post the details here we should be able to see which lines were causing the problems.

           

          Mark McGinn

          MarXtar Ltd

          http://www.marxtar.com

          Register for our upcoming LANDesk Enhancements Webinar Series

          • 2. Re: PXE Representative Deploy alway failed??
            Rookie

            Hi MarXtar

             

            Thank you for your advice, i choose 1 of them  and the log show..

            "Machine","CbaStatus","ExitCode","Duration","Begin","End","Command"
            "NEO","OK",1605,0:00:01,5/9/2011 2:25:28 PM,5/9/2011 2:25:29 PM,"MsiExec.exe /q /X{F238CE99-6614-4072-9D20-1D2FA7ED951A}"
            "NEO","OK",0,0:00:01,5/9/2011 2:25:29 PM,5/9/2011 2:25:30 PM,"D:\LANDesk\ManagementSuite\landesk\vboot\ldlinux.img, c:\ldclient\ldlinux.img, TOREMOTE"
            "NEO","OK",0,0:00:00,5/9/2011 2:25:30 PM,5/9/2011 2:25:30 PM,"D:\LANDesk\ManagementSuite\landesk\files\bootmenu.1, c:\ldclient\bootmenu.1, TOREMOTE"
            "NEO","OK",0,0:00:01,5/9/2011 2:25:30 PM,5/9/2011 2:25:31 PM,"D:\LANDesk\ManagementSuite\landesk\files\bstrap.0, c:\ldclient\bstrap.0, TOREMOTE"
            "NEO","OK",0,0:00:00,5/9/2011 2:25:31 PM,5/9/2011 2:25:31 PM,"D:\LANDesk\ManagementSuite\landesk\files\dosundi.1, c:\ldclient\dosundi.1, TOREMOTE"
            "NEO","OK",0,0:00:00,5/9/2011 2:25:31 PM,5/9/2011 2:25:31 PM,"D:\LANDesk\ManagementSuite\landesk\vboot\bootmenu.0, c:\ldclient\bootmenu.0, TOREMOTE"
            "NEO","OK",0,0:00:01,5/9/2011 2:25:31 PM,5/9/2011 2:25:32 PM,"D:\LANDesk\ManagementSuite\landesk\vboot\dosundi.0, c:\ldclient\dosundi.0, TOREMOTE"
            "NEO","OK",0,0:00:00,5/9/2011 2:25:32 PM,5/9/2011 2:25:32 PM,"D:\LANDesk\ManagementSuite\landesk\vboot\bzImage, c:\ldclient\bzImage, TOREMOTE"
            "NEO","OK",0,0:00:00,5/9/2011 2:25:32 PM,5/9/2011 2:25:32 PM,"D:\LANDesk\ManagementSuite\landesk\vboot\pxelinux.0, c:\ldclient\pxelinux.0, TOREMOTE"
            "NEO","OK",0,0:00:01,5/9/2011 2:25:32 PM,5/9/2011 2:25:33 PM,"D:\LANDesk\ManagementSuite\landesk\vboot\default.boot, c:\ldclient\default.boot, TOREMOTE"
            "NEO","OK",0,0:00:00,5/9/2011 2:25:33 PM,5/9/2011 2:25:33 PM,"D:\LANDesk\ManagementSuite\landesk\vboot\default.menu, c:\ldclient\default.menu, TOREMOTE"
            "NEO","OK",0,0:00:00,5/9/2011 2:25:33 PM,5/9/2011 2:25:33 PM,"\\10.1.100.11\ldlogon\provisioning\linux\linuxpe.default.cfg, c:\ldclient\linuxpe.default.cfg, TOREMOTE"
            "NEO","OK",0,0:00:01,5/9/2011 2:25:33 PM,5/9/2011 2:25:34 PM,"D:\LANDesk\ManagementSuite\landesk\vboot\bcd, c:\ldclient\bcd, TOREMOTE"
            "NEO","OK",0,0:00:00,5/9/2011 2:25:34 PM,5/9/2011 2:25:34 PM,"D:\LANDesk\ManagementSuite\landesk\vboot\boot.sdi, c:\ldclient\boot.sdi, TOREMOTE"
            "NEO","OK",0,0:00:01,5/9/2011 2:25:34 PM,5/9/2011 2:25:35 PM,"D:\LANDesk\ManagementSuite\landesk\vboot\boot.wim, c:\ldclient\boot.wim, TOREMOTE"
            "NEO","OK",0,0:00:01,5/9/2011 2:25:35 PM,5/9/2011 2:25:36 PM,"D:\LANDesk\ManagementSuite\landesk\vboot\bootmgr.exe, c:\ldclient\bootmgr.exe, TOREMOTE"
            "NEO","OK",0,0:00:00,5/9/2011 2:25:36 PM,5/9/2011 2:25:36 PM,"D:\LANDesk\ManagementSuite\landesk\vboot\pxeboot.0, c:\ldclient\startrom.0, TOREMOTE"
            "NEO","OK",-2147483646,0:00:00,5/9/2011 2:25:36 PM,5/9/2011 2:25:36 PM,"<qt/>c:\ldclient\sdclient.exe<qt/> /p="http://10.1.100.11/landesk/files/osdrep.msi" /msi /N /An /Ac /g="{F238CE99-6614-4072-9D20-1D2FA7ED951A}""
            "NEO","OK",-2147483646,0:00:01,5/9/2011 2:25:36 PM,5/9/2011 2:25:37 PM,"<qt/>c:\ldclient\LDISCN32.EXE<qt/> /NTT=10.1.100.11:5007 /S="10.1.100.11" /F /SYNC /NOUI"
            ; "Job Complete","0 Done","1 Failed","0 Off","0 Unknown"

             

             

            • 3. Re: PXE Representative Deploy alway failed??
              Apprentice

              Ahh - welcome to my world

               

              I am having the same problem and am dealing with support on this. If you look at your log, you will see two lines that look like this...

               

              "NEO","OK",-2147483646,0:00:00,5/9/2011 2:25:36 PM,5/9/2011 2:25:36

               

              That funny -2147483646 is (as far as I can tell), the status of a file copy operation. I believe this is a failure, but PXE deployment deems it to be success and caries on. Of course, when the PXE install process runs, those files that did not copy successfully don't work and the whole thing fails.

               

              I'd like to offer you some advise on how to fix the root cause of the problem, but apart from finding out why the file copies fail, I don't have a solution yet. I've taken to deploying my PXE using a batch file I run on the PXE rep. It works for me, but it's not how things should work.

               

              Good luck,

               

              Paul

              • 4. Re: PXE Representative Deploy alway failed??
                Rookie

                Thank you Paul,

                i want to tell you the truth,i did not feel good about your world

                 

                if what you done is work ,Could you please show me how to deploy PXE rep. by batch file ?

                 

                BR

                 

                Mahunnop

                • 5. Re: PXE Representative Deploy alway failed??
                  Rookie

                  Ok Guys

                  After i try to do everything and it didnt work, so i copied the 2 files that is "sdclient.exe" and "LDISCN32.EXE" which show in last 5 lines in the log directly to "ldclient" path and it's work!. The PXE rep. deploy is successful

                  Thank you for all your attention

                  BR

                  Mahunnop

                  • 6. Re: PXE Representative Deploy alway failed??
                    Specialist

                    Based on what I can see from your log, you modified the script to copy the file to the destination on the c drive, eventhough your LANDesk agent installation is on the d drive.  The last two line when the script tried to execute sdclient and ldiscn32 to run manual inventory it failed because it couldn't find the two files on the c location.  You can either change it to have it execute from %LDMS_CLIENT_DIR% or copy the two files to the c, which is what you did.