3 Replies Latest reply on Mar 5, 2008 9:09 AM by puercomal

    LANDesk agent has problems with the WMI service starting and stopping?

    Rookie

       

      Hi all.

       

       

       

      I have heard an unconfirmed rumour that the LANDesk agent has a major issue

      with the Windows WMI performance adapter service continuously starting and

      stopping. We use a server monitoring solution which starts the remote WMI

      service when it queries the remote host for performance data etc, and stops the

      WMI service again when the query is complete. The interval at which this

      happens can be as frequent as every 5 minutes. Apparently the LANDesk agent

      does not like this at all and goes into a hanging state. In many cases this can

      cause an entire server to hang.

       

       

       

       

       

      Has anybody ever heard of this issue?

       

       

       

       

       

      I am currently planning a deployment of LANDesk, and 50 Windows servers are

      within the scope of the deployment.  This rumour is causing me great

      concern.

       

       

      I do not know which version the problem existed on. My deployment will be

      for LDMS 8.7 SP5.

       

       

       

       

       

      Perhaps one of the LANDesk gurus on this forum can re-assure me or confirm

      this issue for me?

       

       

       

       

       

      Many thanks.

       

       

       

       

       

      Daniel

       

       

        • 1. Re: LANDesk agent has problems with the WMI service starting and stopping?
          leffrt SupportEmployee

          I haven't heard of that and I've done quite a bit of Server Manager deployments.  Maybe that was something that was quickly patched.

          • 2. Re: LANDesk agent has problems with the WMI service starting and stopping?
            Rookie

            When you say "Server Manager" you mean LANDesk Server manager though right? I'm using a server monitoring application called Argent Guardian. I'm not sure if it is safe to assume that all server monitoring suites behave the same with regards to the WMI service. I am having to hold back on my deployment now due to fears of resulting server downtime. Nobody seems to have heard of this problem, but I heard it from a credible source.

            • 3. Re: LANDesk agent has problems with the WMI service starting and stopping?
              Employee

               

              There's nothing like testing it to get to the truth. I'd use Process Explorer for a high level picture of which processes to get concerned about, then Filemon and Regmon to find out what's happening down deep.

               

               

               

               

               

              Architecturally speaking, I'd be a little surprised if there was something fundamental here, but I can imagine a configuration that might produce interesting times. If you've got LDSM alerting on service stop/start, which I believe is a default config, then you'll be producing a fairly rapid stream of alerts. Add in some network connectivity issues and we start buffering the alerts to disk, producing more load. All the same, in order to produce concerning load, I'd think the alert configuration would have to be modified to test very frequently.

               

               

                 

               

               

              1 of 1 people found this helpful