12 Replies Latest reply on Jun 25, 2008 5:01 AM by RonKirkland

    OSD failing since 8.8

    Apprentice

       

      OSD was working fine in 8.7 but since moving to 8.8 we have been having some intermittent problems which seem to be getting worse. 90% of the failures are as follows;

       

       

      "Machine","CbaStatus","ExitCode","Duration","Begin","End","Command"

      "WELLINGTON","OK",0,0:00:00,04/03/2008 16:44:03,04/03/2008 16:44:03,"WINPE, TIMEOUT=1800"

      "WELLINGTON","OK",5,0:02:11,04/03/2008 16:44:03,04/03/2008 16:46:14,"diskpart /s X:\LDClient\rmvol.txt"

      "WELLINGTON","OK",230227968,0:00:01,04/03/2008 16:46:14,04/03/2008 16:46:15,"drvmap.exe gifford\pcadmin 20A8B14158507115D3D477F18712314753E15322537 I: <qt/>
      swift.gifford-consulting.co.uk\osd<qt/>, STATUS FACILITY=3513"

      "WELLINGTON","OK",230227968,0:00:01,04/03/2008 16:46:15,04/03/2008 16:46:16,"drvmap.exe gifford\pcadmin 20A8B14158507115D3D477F18712314753E15322537 H: <qt/>
      swift.gifford-consulting.co.uk\osd<qt/>, STATUS FACILITY=3513"

      "WELLINGTON","OK",4,0:00:02,04/03/2008 16:46:16,04/03/2008 16:46:18,"diskpart /s X:\LDClient\wipeDisk0.txt"

      "WELLINGTON","OK",1,0:00:07,04/03/2008 16:46:18,04/03/2008 16:46:25,"cmd /c format /Y /FS:NTFS /Q /V:C-DRIVE c:"

      "WELLINGTON","OK",230227968,0:00:13,04/03/2008 16:46:25,04/03/2008 16:46:38,"cmd /c RunBatch -1 h:\ImageX imagex.exe /apply i:\Images\LOMBAR~1.WIM 1 C:, STATUS FACILITY=3513, SYNC"

      "WELLINGTON","OK",0,0:00:09,04/03/2008 16:46:38,04/03/2008 16:46:47,"sdclient /f /o /dest="X:\LDClient\diskinfo.exe" /p="http://191.37.16.30/landesk/files/diskinfo.exe", STATUS"

      "WELLINGTON","OK",0,0:00:11,04/03/2008 16:46:47,04/03/2008 16:46:58,"sdclient /f /o /dest="X:\LDClient\assvol.txt" /p="http://191.37.16.30/landesk/files/assvol.txt", STATUS"

      "WELLINGTON","OK",0,0:00:05,04/03/2008 16:46:58,04/03/2008 16:47:03,"tokreplw X:\LDClient\assvol.txt partition=1"

      "WELLINGTON","OK",0,0:00:16,04/03/2008 16:47:03,04/03/2008 16:47:19,"diskpart /s X:\LDClient\assvol.txt"

      "WELLINGTON","ERR_Fail",-2147023891,0:00:01,04/03/2008 16:47:19,04/03/2008 16:47:20,"sdclient /f /o /dest="C:\sysprep\sysprep.inf" /p="http://191.37.16.30/landesk/files/Chester%207100%20Returns.inf", STATUS" ; "Job Complete","0 Done","1 Failed","0 Off","0 Unknown"

       

       

      I have researched the error and the basic problem is that the sysprep.inf cannot be copied to the c: drive as it has not been formatted correctly and the image has not been deployed to it. i have also highlighted the times above as this whole process seems to have taken just over 3 minutes and in successful tasks this process takes around 10 minutes.

       

       

      Therefore the log is showing a success for tasks that have failed.

       

       

      Does anyone have any ideas as to why this is happening?

       

       

      Thanks

       

       

      Steve

       

       

        • 1. Re: OSD failing since 8.8
          Employee

          You probably can't download the file at all. Test that first. It may be that you need to set the MIME type in IIS on your core server to allow the download of .inf files.

           

          If that's not it, can you see the C: drive in WinPE? I see you are using Imagex.exe. I imagine the C: drive should be mounted before you get to the sdclient command to copy down the sysprep file, but check to be sure.

          • 2. Re: OSD failing since 8.8
            Apprentice

             

            Thanks for the quick response IronMike. I don't think its the mime types as it is not happening on all machines.

             

             

            The problem seems to be with the diskpart or format command because if you try to change the directory to c: you get the message

             

             

            "The volume does not contain a recognised file system" etc so there is no way that imagex can copy to the drive.

             

             

            This problem is now only affecting a remote site but it was happening here in the same subnet as the core with some machines connected to a slow switch. i moved them to a faster switch and the machines then worked. I thought this was a coincidence at the time but now i'm thinking it may be a comms problem between the target pc and the core. I already had to add an extra ldsleep command to the startnet.cmd in the peboot.img  as the miniscan wasn't populating an IP address in time.

             

             

             

             

             

            • 3. Re: OSD failing since 8.8
              Employee

              Is this only happening on specific machine models?

               

              Try these commands on a machine in WinPE:

              diskpart

              list disk

               

              If you don't see a disk listed, it's a driver issue, and you need to get the right driver in the machine. The diskpart commands are returning non-zero results (5 and 4) on  the diskpart commands in the script. Although it gives an "OK," those commands appear to be failing.

              • 4. Re: OSD failing since 8.8
                Employee

                It could also be multiple PXE reps. If one has the right drivers, and another doesn't, you can get mixed results. Make sure your PXE reps have the right drivers.

                • 5. Re: OSD failing since 8.8
                  Apprentice

                   

                  This is a strange one because it happens on all PC types but randomly (from the same pxe rep). The disk is shown and when the commands from the script are run manually they work.

                   

                   

                  diskpart /s X:\LDClient\wipeDisk0.txt

                   

                   

                  cmd /c format /Y /FS:NTFS /Q /V:C-DRIVE c:

                   

                   

                  If i then run pxemenustart and choose the image again it will work.

                   

                   

                   

                   

                   

                  • 6. Re: OSD failing since 8.8
                    Rookie

                    Provided that:

                     

                    a. While Imagew restores the image, your processor is not pinned at 100% (run taskmgr from a new console in winPE to verify)

                     

                    b. Single partition images are being restored to the C-Drive and NOT MBR 0

                     

                    c. Server connectivity issues have been ruled out

                     

                    Try this

                     

                     

                    edit the assvol.txt file in the winpe image and include the rescan command as the first and last line of the script. Remeber to redeploy your PXE reps after changing the PE image

                     

                     

                    WARNING: The rescan command will update all the volume and disk information in the Disk Management Services (DMS) module of WINPE. While the possiblilty is remote, an unintended volume may be mounted as drive C. (The work of rmvol.txt may be partially undone)

                     

                     

                    Cause: Imagew may have changed the volume information on the disk and DMS is not aware of the change

                     

                    Message was edited by: Rulmann

                     

                    Correction. Add the rescan command as suggested in the assvol.txt file on the PE image and the CORE. I noticed that the script downloads an updated version of the file (unicast images)

                     

                    Also the issue is probably not imagew, but diskpart not updating its own changes in DMS

                    • 7. Re: OSD failing since 8.8
                      Apprentice

                      I think I have the same problem. I used to be able to image without a problem, and now it just doesnt work on 90% of my machines (the same machines it did work on). After I select the job (from the PXE Menu) the imaging doesn't run at all. Machine just sits at a blank screen (the LANDesk winPE background forever), no diskpart, or imaging...

                       

                      My Log File is empty. It's like the job never starts.

                       

                       

                      "Machine","CbaStatus","ExitCode","Duration","Begin","End","Command"

                       

                       

                      Thanks

                      • 8. Re: OSD failing since 8.8
                        Rookie

                        Honestly I haven't quite seen that before but it seems like it could be an access or inventory database issue. Try

                         

                        a. Run an sdclient command manually (from the PE console) that copies a file from the scripts folder, the files folder, and the vboot folder (via http) to the x: drive, see if it works. (IIS anon access)

                         

                         

                        b. Delete all previous references of that machine from landesk (including its old device name, or its mac address as the device name). Remember the all devices group may not show them in inventory, you may have to run a query where (device name = exists) to see it.

                         

                         

                        c. Import machine device name with mac address into the database using csvimport

                         

                         

                        d. Verify Inventory Server Service is running on the core

                         

                         

                        c. recreate your pxe boot menu and hit the update button

                         

                         

                        e. Retry

                        • 9. Re: OSD failing since 8.8
                          Rookie

                          Add the rescan command in the wipedisk0.txt file between create partition primary and assign letter=c. Also add it at the end of the script to be safe

                          • 10. Re: OSD failing since 8.8
                            Rookie

                             

                            Just a thought, but could the script be moving forward before the initial diskpart operations are complete? Maybe add some sleep timeouts in-between the diskpart routine and the latter format... 

                             

                             

                            The C drive cant be formatted unless the diskpart has completed successfully.

                             

                             

                            • 11. Re: OSD failing since 8.8
                              Rookie

                               

                              Yes it can. If imagew does not find a valid C drive, It will default to restoring MBR0 as opposed to C-Drive for single partition images. Restore to MBR0 is meant to be used when restoring multi partition images. Generally when this happens, you can also see processor usage jump to 100% when restoring an image, thereby increasing your restore time up to 3x. Finally, the image may not boot until the primary partition is set active. I have mostly seen this in computers with no CD-ROM drives, that is, no valid volumes other than the Hard Drive 

                               

                               

                              Here is how you can test if you have the issue. From the WinPE console:

                               

                               

                              diskpart

                               

                               

                              select disk 0

                               

                               

                              clean

                               

                               

                              rescan

                               

                               

                              exit

                               

                               

                              diskpart /s x:\ldclient\wipedisk0.txt

                               

                               

                              you should get an error message stating that it could not assign a valid mount point or drive letter when running the script. The only fix that I found so far is to add the rescan in the script after create partition primary

                               

                               

                              another example would be as follows, same error message:

                               

                               

                              diskpart

                               

                               

                              select disk 0

                               

                               

                              clean

                               

                               

                              rescan

                               

                               

                              exit

                               

                               

                              diskinfo new_temp_partition (used for multicasting) - diskpart scripts hardcoded in the exe

                               

                               

                              I think when diskpart commands are run manually DMS is updated, but if a script is run, this is not always the case

                               

                               

                              Alternative workarounds (no rescan command):

                               

                               

                              I found that if you add a cmd /c in front of every diskpart command, a SYNC at the end, and an Ldsleep 15 as the next command, it almost works, however you may still have issues copying the sysprep file over without the rescan in the assvol.txt file. 20% failure rate for me.

                               

                               

                               

                               

                               

                               

                               

                               

                               

                               

                               

                              • 12. Re: OSD failing since 8.8
                                Rookie

                                Thanks- Good to know about the Imagex MBR0... However, We have a zero % failure rate (Also using 8.8);

                                arranging our script to allow operations to have time to complete successfully and

                                add short sleeps in between the disk operations. Additionally, for another script we hand over the diskpart operation to a vbs script that resizes the partition to whatever percentage we want, so that also gives time before we return to the script to format C: & D:... This method also has no failures at all for us.

                                 

                                So our steps would be (for the vbs method):

                                 

                                 

                                REMEXEC39=cmd /c wscript.exe "i:\partition\size.vbs"

                                REMEXEC40=cmd /c format /Y /FS:NTFS /Q /V:Backup d:

                                REMEXEC41=diskpart /s i:\partition\rem.txt

                                 

                                 

                                At any rate: Good luck!