8 Replies Latest reply on Jul 15, 2011 11:39 AM by smittman

    Can't Capture Image using Template Provisioning


      Hello Community,


      My problem is maybe simple but I can’t figure out what’s going on.


      I can capture images using OSD without any issues, but when I try to use template provisioning it fails.


      This is what I’ve done:


      1-   Create an Image capture process using Template Provisioning.

      2-   Boot into WinPE (I’ve tried using Vboot and PXE booting)


      Once into WinPE, the Landesk agent finds the capture job but it fails with error 80001803h.


      The imaging tool I’m using is ImageX.


      I don’t know what’s wrong. It works with OSD but fails with Template Provisioning.


      I really need your help with this.




      NOTE: I’m using LanDesk Management Suite 9.0 SP2 and the image I'm trying to capture is Windows 7 32 bits.

        • 1. Re: Can't Capture Image using Template Provisioning
          dwagner1 Apprentice

          Here is my template that I'm using that works without the error you mentioned:


          Using LD9 SP2 and Windows 7 32 bit.  One of the things we ran into was if it is a default install of Window 7, there are two partitions, windows will be loaded to the D: partition by default. If this setting is not changed your capture will be less than 100mb.


          Hope that helps!

          • 2. Re: Can't Capture Image using Template Provisioning


            Could you post your template maybe (open it, go to the XML option bottom left and export) ?



            • 3. Re: Can't Capture Image using Template Provisioning
              dwagner1 Apprentice

              I added it to the original post.




              • 4. Re: Can't Capture Image using Template Provisioning

                "Darin and Ian, thanks for your replies. Actually, i should have updated this discussion a couple of weeks ago because i already managed to get the capture process working.


                What i was trying to achieve was to create an automated capture process that would do the following:


                - Delete Landesk Agent's registry keys

                - run Sysprep in audit mode

                - Vboot the computer


                - Capture the image

                - Reboot the computer


                - Eliminate Sysprep Audit mode (set some registry keys to put the computer back to normal)

                - Activate the admin account

                - Reboot


                This is my template 1.png


                The entire process works great, but there's a problem when we deploy the image. The problem is described in another discussion i opened (Click Here).


                I quote:


                "I was deploying windows 7 on 10 computers using OSD. Once the job  was completed, i tried to use template provisioning to install a  program, but it inmediatly failed. The message was "Busy with an  existing provisioning job (197)".


                There  weren't previous jobs running on the computers. I don't know why this  is happening. Last week we deployed 2 computers and ran the same process  without any issues.


                The  way we got template provisioning to work on those 10 computers was  removing them from the LanDesk Database and adding them again."


                I think that this problem came because once a template provisioning job is done, the provisioning agent will contact the Core Server looking for the step in the job. If there aren't more steps to run then the process is completed. In my case, I was capturing an image with a template provisioning job that had more steps left, and that's why the new deployed images were having some issues when trying to run template provisioning on them.

                • 5. Re: Can't Capture Image using Template Provisioning


                  thanks for that... actually I was posting at the original poster "reinerct" .. but it will be helpful to others to have a working template .. so thanks again.



                  • 6. Re: Can't Capture Image using Template Provisioning


                    You said your script should "- Delete Landesk Agent's registry keys". Please consider an alternative approach :-) Image an OS that has never had the agent installed and then install the agent at the end using a provisioning action. Unless there is a really good reason for doing it the way you are... such as images located on Prefered Server a long way from the core - and even then I would suggest building a single exe agent confiig and installing it towards the end of the provisioning task.



                    • 7. Re: Can't Capture Image using Template Provisioning

                      Thanks for pointing this out but in our case, for administrative purposes, we need the Landesk agent installed on the Master computer. That's why we are deleting the registry keys everytime we capture the image.


                      The keys we delete are:


                      HKLM\Software\Intel\LANDesk\Common API
                      HKLM\Software\LANDesk\Common API

                      • 8. Re: Can't Capture Image using Template Provisioning
                        smittman Apprentice

                        Darin, does your template assume that there is not a System Partition, and that there is a single partition on the drive?