10 Replies Latest reply on Mar 11, 2008 12:37 PM by technobabble

    OSD failing on 8.8 server



      Just testing LANDesk OSD 8.8 and keep getting the same message, then the job fails






      "000AE4C9216B","ERR_Fail",-1917827967,0:00:06,3/7/2008 9:45:51 AM,3/7/2008 9:45:57 AM,"sdclient /f /o /dest="X:\LDClient\diskinfo.exe" /p="", STATUS"



      ; "Job Complete","0 Done","1 Failed","0 Off","0 Unknown"



        • 1. Re: OSD failing on 8.8 server


          The error code translates to 3504:17537, the 3504 part is just a ESWD General Failure



          Facility Description

          0 Schedule plug in facility, the error codes will be loaded from the resources within the scheduler application

          3500 General software distribution failure

          3501 Failure at the SDCLIENT.EXE level

          3502 Failure in the code that installs MSI packages

          3503 Failure when installing an LSWD/generic executable

          3504 ESWD package failure

          3505 Facility code for core tech ping (CBA Ping) used in Custjob.

          3506 Facility code for DOS

          3507 Vulscan

          3510 Exit codes with this facility code originate from IMAGE.EXE

          3511 Exit codes with this facility code originate from Symantec* Ghost*

          3512 Exit codes with this facility code originate from PowerQuest* ImageCenter*

          4095 Facility code for ESWD package custom error codes.

          8191 Facility code for ESWD custom error codes where a reboot is required.



          Is this a Vboot Job or PXE? It is failing on a simple file copy using sdclient do any of the other files get copied?



          • 2. Re: OSD failing on 8.8 server
            Jared Barneck SupportEmployee

            That error makes no sense for what you are doing. 



            Facility: 3504

            Error: 17537


            IDS_SDCD_AI_LOAD_LIBRARY_FAILED ( 0x4481)


            Ignore it and just manually try to download and see what you are getting.


            Check permissions on the file.

            Can a normal browser download it (map a drive in WinPE to the c$ share of a workstation with firefox installed and run firefox from the workstation, it works).

            Check Mime types

            Check IIS for anonymous access on the files folder.

            • 3. Re: OSD failing on 8.8 server

              We tested this new server with a different model laptop, no problem at all. I'm thinking it has something to do with the sata driver, but we've tried different versions with the same result. The old server works just fine with the same sata drivers for this particular laptop model.

              • 4. Re: OSD failing on 8.8 server
                Leon SupportEmployee

                Could this be something with the network adapter driver? Does this happen constantly? If so you might try to add the latest NIC driver to WinPE image and see how it works.

                • 5. Re: OSD failing on 8.8 server

                  If the two machines (the one that works and the one that doesn't) are in the same VLAN, then you know that your core server is not the problem.


                  Even though two machines may be the same "model," the vendor device ID on the hardware may actually have incremented. This happens all the time. Make sure you have the latest SATA drivers from your vendor, including the txtsetup.oem. Who is the vendor? What model of machine are we talking about?


                  You might want to post the entire log to this thread. There is likely an error (or a non-zero result) that was marked as "OK" in the log. I'm thinking you might have a "5" or a "4" result on your diskinfo commands.

                  • 6. Re: OSD failing on 8.8 server


                    The one that works is a Lenovo R51, the one that doesn't work is a Lenovo R60e. The sata controller is a Intel 82801GBM and I've downloaded the driver from Lenovo, Intel, and took them out of the old landesk server's ldvpe1.img. The full log is below.






                    "000AE4C9216B","OK",0,0:00:00,3/10/2008 8:52:22 AM,3/10/2008 8:52:22 AM,"WINPE, TIMEOUT=1800"



                    "000AE4C9216B","OK",5,0:00:49,3/10/2008 8:52:22 AM,3/10/2008 8:53:11 AM,"diskpart /s X:\LDClient\rmvol.txt"



                    "000AE4C9216B","OK",230227968,0:00:01,3/10/2008 8:53:11 AM,3/10/2008 8:53:12 AM,"drvmap.exe domain\user 20AFA1F2E6F7C5816166BFD242F7BD66E856B3E782D I: <qt/>
                    coreserver.domain.com\Images<qt/>, STATUS FACILITY=3513"



                    "000AE4C9216B","OK",230227968,0:00:00,3/10/2008 8:53:12 AM,3/10/2008 8:53:12 AM,"drvmap.exe domain\user 20AFA1F2E6F7C5816166BFD242F7BD66E856B3E782D H: <qt/>
                    coreserver.domain.com\ldmain<qt/>, STATUS FACILITY=3513"



                    "000AE4C9216B","OK",0,0:00:01,3/10/2008 8:53:12 AM,3/10/2008 8:53:13 AM,"diskpart /s X:\LDClient\wipeDisk0.txt"



                    "000AE4C9216B","OK",0,0:00:03,3/10/2008 8:53:13 AM,3/10/2008 8:53:16 AM,"cmd /c format /Y /FS:NTFS /Q /V:C-DRIVE c:"



                    "000AE4C9216B","OK",230031360,0:27:39,3/10/2008 8:53:16 AM,3/10/2008 9:20:55 AM,"RunBatch -1 h:\osd\imaging restall.bat 0 i:\Laptop\R60E\LDR60E\LDXP8A, STATUS FACILITY=3510, SYNC"



                    "000AE4C9216B","ERR_Fail",-1917827967,0:00:06,3/10/2008 9:20:55 AM,3/10/2008 9:21:01 AM,"sdclient /f /o /dest="X:\LDClient\diskinfo.exe" /p="http://coreipaddress/landesk/files/diskinfo.exe", STATUS"



                    ; "Job Complete","0 Done","1 Failed","0 Off","0 Unknown"



                    • 7. Re: OSD failing on 8.8 server

                      OK, it looks like it is the SATA driver. The first diskpart command finishes with "OK" but a result of "5" right after the OK. That command looks like it failed. Run these commands at a command prompt in WinPE:



                      list disk


                      If you don't see a disk, then the proper SATA driver is definitely not loaded.


                      Did you go to Lenovo's web site and download the specific SATA driver for your model or service tag? Did you then inject the driver in the ldvpe1.img?

                      When you inject the driver, which files are you injecting? After specifying the txtsetup.oem file, you should then add all of the driver files as additional files. The only file you don't need is the readme.txt (if there is one).


                      Did you remove any old drivers you had previously injected for that SATA controller?

                      If you are using PXE, remember that any PXE representative in the same broadcast domain (as the machine you are PXE booting) can respond with a boot image. Have you updated all PXE reps?

                      • 8. Re: OSD failing on 8.8 server

                        BTW, one quick workaround is the set the driver controller to IDE compatibility in the BIOS. It's a workaround, and not a good solution on a large scale. But if you're in a time crunch to get a particular machine done it's worth trying.

                        • 9. Re: OSD failing on 8.8 server


                          Yes, I did for a test set the sata mode in the bios to compatibility because my drivers weren't detecting the disk at first. I then modified the txtsetup.oem file so that it only referenced the "correct" controller at set the bios back to AHCI, PE then detected the disk properly, but still the same problem with diskinfo. Silly, thing, support had me increase the PE image free space and that fixed the diskinfo error. I guess I ran out of free space on the client, and it couldn't copy diskinfo. Would be nice if it echoed that in the log files or when run manually.



                          Thanks for all your input guys.



                          • 10. Re: OSD failing on 8.8 server
                            technobabble Apprentice


                            Also, remember that you will probaly need to edit the txtxsetup.oem file that is included with the driver before you add it to the WinPE image. The default specified in the txtsetup.oem file may not be correct for the particular chipset for the SATA controller of your target machine.