7 Replies Latest reply on Mar 6, 2012 8:51 AM by mrjoolz

    Sysprep Error


      Hello community,


      I have a base windows image that i always update and capture. Sometimes i have to deploy it again to the same computer because it gets corrupted. The issue is that since last week when i deploy the image, while running sysprep i get this error: "A fatal error occured while trying to sysprep the machine".


      According to microsoft, we can rearm windows no more than 3 times; however, we have captured and deployed this image to the same computer more than 5.


      I don't know what's wrong so far.


      Has anyone had the same problem?


      I'm using LDMS 9. The windows image is Windows 7 Enterprise Edition with a KMS license key

        • 1. Re: Sysprep Error

          Don't suppose you resolved this?


          I've now inherited the same problem!

          • 2. Re: Sysprep Error
            EMiranda Expert

            unfortunately you have reached your grace period and you will not be able to sysprep again. gotta love Microsoft on that one.  I ran into that as well. What I did to remedy the problem for the future is:


            Redid my source image (make sure you are in audit mode when creating your image)

            Make all your changes to exactly how you want but do not sysprep the image, instead create an image at that point or a snapshot if you are using VM.

            once you have your "non-syspreped" image. then you can go head and sysprep it and create another image, your "syspreped image."


            Deploy the syspreped imaged.


            If you need to make changes, go back to your source image ("non-syspreped") and make your changes, create a backup again before you sysprep and repeat the cycle.


            This way you never have to worry about grace period because you will always be on your first rearm.

            • 3. Re: Sysprep Error

              Grrrr, why isn't this mentioned in the BKM document.


              A lost day now, followed by another lost day to rebuild from scratch!


              Thanks for your help and suggestion to avoid EMiranda (again)

              • 4. Re: Sysprep Error
                EMiranda Expert



                I went and did some research because at the time I had this issue, Windows 7 was just new and that was the workaround to get by, but since then I have read that there may be two additional fixes that could help out before trying to rebuild the image.


                One fix was to stop "Windows Media Player Network Sharing" from running which on some cases was causing that fatal error in sysprep.

                Another fix was changing the registry key on the Rearm to a "1" before running your sysprep.  The key is here:



                HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\Cu rrentVersion\SoftwareProtectionPlatform\SkipRearm


                I havn't tried this, but just did some research on others with similiar issues and maybe this could help out or someoone in the future looking for this.

                • 5. Re: Sysprep Error

                  Cheers, I've already tried both of those, and still get the same problem. I think MS probably closed that hole.


                  I've managed to get the image I had working on my new hardware, just means the image is not as up to date as I'd like it to be, but it buys me some time to create the new image thankfully.


                  I'm going to attempt to do a new image with VMware, this way I can just make copies of the VM Discs before they get generalised by landesk and do it that way I think.


                  Thanks for your help thou.

                  • 6. Re: Sysprep Error
                    EMiranda Expert

                    well crap, i was hoping to catch you before you started, but that sucks.  I do my imaging in VM and from my experience vs doing it on physical hardware, VM is much easier route on making changes and keeping everything organized.  I setup a small ESXi box (which is free) and have all my gold images managed in there.

                    • 7. Re: Sysprep Error

                      I have discovered if you set the rearm value to 7 it seems to work for some reason !