5 Replies Latest reply on Aug 22, 2011 8:43 AM by ahe

    PXE without F8 menu


      Hi, we have some 1 year old Dell's that cannot handle the pre-boot PXE menu after F8. How can we eliminate this menu altogether and just automatically start in the option to go to the Windows PXE menu?

        • 1. Re: PXE without F8 menu

          We have that problem with some new HPs. There are a few approaches you can take, but We resolved by reducing the number of options listed in the menu. Information on how to do this is contained in How to hide PXE Boot Options on the F8 Menu


          Alternatively, if you use OSD scripts (rather than Provisioning) for your deployments, and always want your clients to enter the Managed WinPE mode, you could set all of your PXE representatives to be holding queue proxies. Information on how to do this is in the LANDesk Help file, under OS Deployment > Using the PXE holding queue. There may be a way of using this with Provisioning, but I'm not sure how.

          • 2. Re: PXE without F8 menu

            To remove the F8 altogether, you can edit DHCP options to allow a specific image to downloaded without prompt.

            Please be aware that this will make all hosts booting from LAN go directly into the preboot environment (e.g. WinPE).


                 Option 43     01 04 00 00 00 00 ff                    (tells client to download image and boot on it at once)

                 Option 60     PXEClient                                  (tells client to read PXE information from DHCP)

                 Option 66                                       (ip to the TFTP server)

                 Option 67     startrom.0                                  (image to download from the TFTP server)


            To add the option 60 to a Windows DHCP, you will also have to add it to the definition and restart the console.

            This can be done by using netsh where should be the ip to the DHCP server


                 netsh dhcp server add optiondef 60 PXEClient String 0 comment="PXE support" PXEClient

            • 3. Re: PXE without F8 menu
              ahe Expert



              which hardware do have this problem? Do you get a PXE error message?


              Do you use LANDesk 8.x or 9.x?


              In the past we've such a problem with HP clients with no floppy drive, we changed the bootloader files, but it depends of the LD version you use, the BIOS version, etc...


              Additionally you can configure your PXE settings on PXE Server:

              • Open the PXE Configuration Utility (C:\program files\LANDesk\PXE\System\PxeConfig.exe),
              • Move in the structure to PXE Servers - Your PXE Server name - proxyDHCP Server (or
              • Right click to open "Configure proxyDHCP Server"
              • Open tab "Client Options"
              • Change value of "Global Bootserver Menu Prompt to "0" (standard value is 255 I think)
              • Restart the LANDesk PXE Service


              Now the first menu entry of your menu will be choosen automatic, no longer F8 menu will appear.


              Disadvantage: You can't use other menu entries, now...




              • 4. Re: PXE without F8 menu
                1EarEngineer Specialist

                I've noticed this with some of the newer HP's as well. We were able to resolve it by updating the bios. Typically we had to cheat and load the HD into a pc that F8 would work, and before it got to the LD client install, would pull the network cable to prevent it, copy the bios upgrade and then put the HD back into the original pc, run bios update and f8 now worked.


                Bit of a pain, but in case the removing of the options didn't work, something we were able to find as a fix.

                • 5. Re: PXE without F8 menu
                  ahe Expert

                  A other working workaround, we found, was to connect a external floppy from DELL ... LOL