4 Replies Latest reply on Sep 19, 2011 1:48 PM by ahe

    PXE Rep deployment false positive success


      I have two sites, one site houses the core server running LD 9.0 SP2 on a Windows 2003 R2 server.  The new server is running Windows Server 2008 R2.  According to the scheduled tasks dialogue, I have "successfully" made the 2k8 server a PXE Representative, however, I cannot add it to the PXE Representatives group folder, and no machines on this subnet will PXE boot.


      I can ping back and forth by name and IP, Landesk agent is installed, and the new server auto-popped in my inventory.  We've recently cleared up licensing issues, reactivated, and validated, but all before making this server a PXE Rep.



        • 1. Re: PXE Rep deployment false positive success
          irizarisan Apprentice



          We might be having the same issue:




          I had also logged a discussion board for this one and AHE is helping me a lot. I will test to deploy the script he had provided.

          • 2. Re: PXE Rep deployment false positive success
            ahe Expert



            you can't add a client/server to the "group" PXE Representatives, they will appear, if PXE is installed and a inventory scan was running after.


            Network View - Corename - Configuration - PXE Representative it's a inventory view only!


            Which PXE error message do you got? Take a look here: http://community.landesk.com/support/docs/DOC-8358

            Do you use VLAN's?


            As I understand right, W2K8 R2 is a 64 bit OS, in the past I've had several problems if PXE is installed on 64 bit, because of different pathes...



            What you can check:

            • Are the PXE services running on your PXE?

                      LANDesk(R) PXE MTFTP Service:        PXEMTFTP.exe

                      LANDesk(R) PXE Service:                   PXESvc.exe

            • Are the boot files copied to "C:\Program Files\LANDesk\PXE\System\images\boot"?

                           BCD, boot.sdi, boot.wim

                    On 64 bit OS, they've to be below "C:\Program Files (x86)", but it could happen that they are stored below "C:\Program Files", so copy them...


            • Did you check, if the DHCP helper adress is set in your network environment?




            1 of 1 people found this helpful
            • 3. Re: PXE Rep deployment false positive success



              The PXE error we're getting is PXE-M0F.  However, upon checking the other items in your list, I found that the PXE services aren't running, nor are they installed.  They do not appear in the Services console, either.  The image directories do not exist either.  Evidently deploying the PXE Rep did absolutely nothing.  I even attempted using the method Watticus posted here: http://community.landesk.com/support/docs/DOC-3096, to no avail.


              I do not have access to the switches, but I am using DHCP option 66 to point clients to the PXE server by hostname- if necessary.


              Is there a manual installer that I can install locally, or can I copy certain directories or files from the core to the new server?

              • 4. Re: PXE Rep deployment false positive success
                ahe Expert

                You can find the PXE MSI on the core ...\landesk\files\osdrep.msi


                But before, check if the MS Installer made a eventlog entry. Perhaps the installer has had a problem and need a repair. (install the newest version repair it).


                If there is no entry in eventlog, try the msi... (as I said, I don't know it it will work on W2K8 64bit).


                If the installation was successful, you've to configure your PXE manually... here you can find a document from HP which described the usage of the intel tool too:



                Perhaps LANDesk will document the configuration of the (very old) intel tool and their changes in the original MSI, if the tool get his twenties anniversary


                Or you try a other free PXE...