9 Replies Latest reply on Sep 23, 2011 7:05 AM by MarcRBT


    MarcRBT Rookie



      Apologies for what might be a very simple question...


      I am having issues with a number of devices not updating in the inventory. I have tried running a manual run of of LDISCN32.exe with the switches /F /L /V (i a have also tried various other swithces) but i can see no evidence of a log file or error report? also I can see no evidence of the scan file being passed back to the server. I am sure I'm just not looking in the right plave for error logging?


      On a seperate note these devices do not apply policy, when process runs it identifies a policy is required but does not execute its application. See attached image.






      Thanks in advance

        • 1. Re: LDISCN32.exe



          Set Store Scans to 1 in Configure - Services - Inventory - Advanced Settings

          Then check the Files under C:\Program Files\LANDesk\ManagementSuite\ldscan


          If you will receive no scan there (also not in ErrorScan) then check, if your Clients

          can reach your Core Server with IP and/or DNS Name, or if some other things

          for example Security Software, will block the Scans from reaching the Core.


          Best Regards


          • 2. Re: LDISCN32.exe
            zman Master

            Moved this thread to Inventory.

            • 3. Re: LDISCN32.exe
              MarcRBT Rookie

              Hi Troga

              Thanks for that, I have made the change and ran another scan and there is nothing coming back to the server. DNS/ Connectivity is in place and there are no firewall issues. Any other suggestions?



              • 4. Re: LDISCN32.exe

                But you see other Scans coming inside or nothing? (Did you restarted Inventory Service, for the changes?)

                Any AV Software installed? Shares checked?


                You may also set "Do Delta" and set the value to 0 to turn off delta scanning and only get full scans. (Make sure to click on the set button!)

                Best Regards


                • 5. Re: LDISCN32.exe
                  MarcRBT Rookie


                  Yes I see other scans coming in. All devices in the estate have the same build/ config / AV definitions using an automated build. There are also other devices in the same physical location on the same subnet. I think both of these rule out networking/ connectivity AV / general configuration.


                  Is there any way to debug LDISCN32.exe ? where does it log to?



                  • 6. Re: LDISCN32.exe
                    MarcRBT Rookie

                    Any comments anyone? I'm stuck on this one now :-(


                    • 7. Re: LDISCN32.exe

                      You might try adding a "/debug" to the shortcut that starts inventory  and manually start an inventory scan on an affected device.This will not  solve your issue, but it will produce a second ldiscn32.log file with  more detailed information.


                      Other Logs can be found here:

                      C:\Program Files\LANDesk\ManagementSuite\log


                      Best Regards


                      • 8. Re: LDISCN32.exe
                        mrspike SSMMVPGroup

                        You can have the client creat a local file and then copy this to the scna folder to see if the file is being made and then to see if the core can accept it.


                        That command is:


                        "%program%\LANDesk\LDClient\LDISCN32.EXE" /V /F /SYNC /O=%temp%\inv_servername.scn


                        Or if 64 bit, it is

                        "%programfiles(x86)%\LANDesk\LDClient\LDISCN32.EXE" /V /F /SYNC /O=%temp%\inv_servername.scn


                        Replace “servername” with the name of the server or system


                        The go to Start > Run, type in %temp%, the file should be there. Now copy that file to the ldscan folder on the core, it should process.  If not, look in the erroscan folder.  if it is there, it means there is something the core does not like about it.



                        Another thing to check is... on the client, go to:


                        \ldclient\data and sort by name, delete ALL files that have ldappl3. in the name, then do another invenotry scan, this will ensure you have the correct files

                        1 of 1 people found this helpful
                        • 9. Re: LDISCN32.exe
                          MarcRBT Rookie

                          Hi thanks for that pointed me in the write direction. The actual issue was that LDISCN32.EXE was still running on some machines (in task manager, an overhang from a previous automation I think). Killing this and runing it again updated the inventory.