10 Replies Latest reply on Jan 28, 2015 10:56 AM by THogland

    The feared CTOS..




      I am trying to setup provisioning within LANDesk and have hit a stumbling block CTOS! ..


      I have read almost all forums posts regarding this action and I just cant work it out..


      CTOS seems to not get passed the "Running" stage (because it hasn't received a inventory scan from the system)


      I can confirm the following:


      - The ldprovisioning folder is in the C:\

      - The  ldprovisioning.cmd is in the ldprovisioning folder on the C:\

      - The unattend.xml file has been populated with <Path>cmd /c %%systemdrive%%\ldprovisioning\ldprovisioning.cmd</Path>

      - The location %systemdrive%\ldprovisioning\ldprovisioning.cmd is valid

      - Running the ldprovisioning.cmd manually installs the LANDesk agent to continue


      What seems to not be working is the running of the ldprovisoning.cmd script automatically which I don't understand as its in the unattend.xml


      Can anyone suggest any steps to resolve? I know its not "strictly" LANDesk but its still a LANDesk process that's failing.


      Thanks for any help - I am running LANDesk Ver 9.0 SP2 and I am deploying Windows 7 - The properties are set to "Windows 7" also.



        • 1. Re: The feared CTOS..

          So the device you're imaging completes sysprep and boots into Windows 7 but the provisioning agent doesn't kick back in at this point right?  Is the device on the network?  Even if it is are you sure its running the correct NIC drivers?  By default the provisioning agent must be able to connect to the short name of the core server, do you have full netbios name resolution?



          • 2. Re: The feared CTOS..

            I just ran into this last week while creating our Windows 7 Image.  My comptuer would just hang at the CTOS part of the Post-OS Installation.  The thing that fixed my computer was inserting the Fix Windows.bat and Fix Unattend.bat.


            If you do a search for those two programs in the community, it will show you how to install them in your provisioning task.


            Again, that is what fixed my issue when I was hanging at CTOS

            1 of 1 people found this helpful
            • 3. Re: The feared CTOS..



              You are correct, the device images and boots into Windows7 and the provisioning agent doesn't kick back in. The device is on the network and it is running to correct drivers


              I can also confirm that full name resolution is in place, infact all of my actions for copying files within provisioning have netbios names and work correctly!!


              Sedejong - Had a look at those batch files and exe's, inserted them into my provisioning template and they worked correctly, unfortunatly however still a no go on the CTOS action!


              Any other suggestions? - I'm not sure where to go on this one!!



              • 4. Re: The feared CTOS..
                EMiranda Expert

                is the target OS on your provisioning template set to the correct OS?  I ran into that issue before in the past.

                • 5. Re: The feared CTOS..



                  Yes unfortunatly they are.. I say unfortunatly as this was one of my "quick fixes" but It turns out I had already set it correctly.


                  Anyone else?


                  Should I log this as a support ticket to our support? I'm stumped, other than this forum there are no other resources to hunt!



                  • 6. Re: The feared CTOS..
                    EMiranda Expert

                    When the CTOS is hanging. Is it in WinPE or in Sysprep.


                    If WinPE, there is a log file that you can check while in WinPE that might show some valuable info.


                    Open up a command prompt and browse to X:\ldprovisioning\configuretargetoshandler.log and see if there is any info you can find out about why it is failing.



                    Also, do you have any items in %WINDIR%\Setup\Scripts\SetupComplete.cmd, I believe that is where LANDesk injects the commands to launch the setup of the provisioning agent and I read on here that if that file was previously edited, it could cause some issues as well.

                    • 7. Re: The feared CTOS..



                      CTOS hang's after the machine comes out of Windows PE, once the audit / generalize sysprep options have completed and its booted into Windows 7 sucessfully.


                      The ldprovision.cmd should "run once" however it does not..


                      The system is no longer in WinPE so the log file does not exist. I have also checked the %WINDIR%\Setup\Scripts\SetupComplete.cmd and the only entry in here is %systemdrive%\ldprovisioning\ldprovisioning.cmd


                      pain in the butt!!..

                      • 8. Re: The feared CTOS..

                        Also, the below has been added to the Unattend.xml file automaticly;

                        <RunSynchronousCommand wcm:action="add">
                        <Description>LANDesk Provisioning Install</Description>
                        <Path>cmd /c %%systemdrive%%\ldprovisioning\ldprovisioning.cmd</Path>


                        Does this look correct?



                        • 9. Re: The feared CTOS..

                          Workaround adopted.


                          LANDesk and all its flaws! Typical!

                          • 10. Re: The feared CTOS..
                            THogland Apprentice

                            Could you share your workaround? I've got a system that's exhibiting this same behavior...