1 2 Previous Next 15 Replies Latest reply on May 6, 2010 4:04 AM by scottunify

    PXE-E74 error



      Recently when attempting to use the PXE boot menu to capture a new image this error came up when booting to the network:



      "PXE-E74: Bad or missing PXE menu and/or prompt info"



      We hadn't used this in a while because our image was so out of date that it was just quicker to do an unattended install by hand.  Now our image is up to date and we want to  capture it to LANDesk.  The only thing we've done to the core server recently was run Microsoft Update and upgrade LANDesk from 8.7 to 8.8.  We attempted to redeploy PXE representatives but that didn't change anything.



      Worst case is we rebuild the core server from scratch as Windows itself is having some issues.  If anyone has any ideas in the meantime it would be appreciated.



        • 1. Re: PXE-E74 error
          leffrt SupportEmployee

          Did you drag any scripts to the PXE tool in the Management Console and click the Update button?

          • 2. Re: PXE-E74 error

            Yes, we removed the scripts that were there, added one to the root and another to the Capture folder and clicked update, didn't change anything.

            • 3. Re: PXE-E74 error
              leffrt SupportEmployee

              You can try recreating the DOSMENU.CFG file on the Core Server.  I forget the exact folder it is in, LDMAIN\LANDesk\Files maybe, but just delete that file and then go back to the PXE tool and click update again.  This should recreate the file.

              • 4. Re: PXE-E74 error


                Can you get into WinPE, or are you not even getting any network boot options from your pxe rep?






                If you get into WinPE, and it cant pull up the boot menu, that is a problem between the client and the core server. The boot menu file is on the core server, you don't get that from your local pxe rep. It is under C:\Program Files\Landesk\Managementsuite\landesk\files the file name is dosmenu.cfg Check your IIS logs to see if this file is being downloaded.



                1 of 1 people found this helpful
                • 5. Re: PXE-E74 error

                  If you are getting this error at the PXE Network Boot then it has nothing to do with the core server. It cannot find a PXE proxy on the subnet. Verify that the proxy on this subnet is resolvable/pingable and services are started.

                  • 6. Re: PXE-E74 error

                    I renamed dosmenu.cfg to dosmenu.cfg.bak and clicked Update in the PXE Boot Menu configuration and it recreated the dosmenu.cfg file with the appropriate scripts in it.


                    The IIS log displays four lines exactly like this whenever I try to boot to the PXE menu:


                    2008-03-24 19:28:27 W3SVC1 POST /LANDesk/ManagementSuite/Core/Core.WebServices/Pxe.asmx - 80 - Microsoft-ATL-Native/7.00 500 0 0

                    2008-03-24 19:28:29 W3SVC1 POST /LANDesk/ManagementSuite/Core/Core.WebServices/Pxe.asmx - 80 - Microsoft-ATL-Native/7.00 500 0 0

                    2008-03-24 19:28:30 W3SVC1 POST /LANDesk/ManagementSuite/Core/Core.WebServices/Pxe.asmx - 80 - Microsoft-ATL-Native/7.00 500 0 0

                    2008-03-24 19:28:31 W3SVC1 POST /LANDesk/ManagementSuite/Core/Core.WebServices/Pxe.asmx - 80 - Microsoft-ATL-Native/7.00 500 0 0


                    The HTTP 500 code tells me that there is a problem, but that would be because the computer at has never had the PXE proxy installed on it, although it does have the LANDesk client.  There are currently three available PXE proxies listed in Configure > Services... > OS Deployment, I can ping two of them just fine, unsure why I can't ping the third though that doesn't seem to be the problem at the moment.

                    • 7. Re: PXE-E74 error
                      SuperMan SupportEmployee

                      After upgraded from 8.7 to 8.8 have you redeployed the PXE rep? There is some changes in 8.8. So you may remove the 8.7 PXE rep firstly then redeploy a 8.8 one.

                      • 8. Re: PXE-E74 error

                        To get real ASP errors, go to IE's Tools/Internet Options menu, and on the advanced tab, uncheck "Show friendly HTTP error messages."


                        • 9. Re: PXE-E74 error
                          Jason SupportEmployee


                          A few things to try



                          1. Enable traffic on port 69(tftp) to the PXE Representative



                          2. DHCP Options 43 and 60 should not be used when using LANDesk to PXE boot.



                          Steps for Server 2003

                          1) Open DHCP on Windows 2003 Server

                          2) Go to --> Scope --> Scope Options

                          3) Right click and choose Scope Options and choose Configure Options

                          4) Uncheck either option 060 and option 043 (they are not be needed)



                          • 10. Re: PXE-E74 error


                            I made this change on the scope that I'm using and it was the only scope among all of them that had either of them enabled.



                            After looking at the IIS log and figuring out what computer it was booting to I removed and reinstalled the PXE representative to that computer and rebooted it.  I am now able to boot to the PXE menu and get into WinPE.  Just a matter now of getting the network driver to work.



                            Thanks for the help.



                            • 11. Re: PXE-E74 error

                              Hi all


                              Apologies if I should have started a new thread instead.  PXE Booting works fine in our 8.5 SP2 environment but not in our new, soon-to-be-live 8.8 SP2 environment.  We have tried different machines and different PXE Reps (XP SP2 and W2K3 server) but get the PXE-E74 error each time.  We have followed the advice in the LANDesk article http://community.landesk.com/support/docs/DOC-2916;jsessionid=EAB89682E984C6733BBDA24619111FD3 to no avail.


                              1) LANDesk Support supplied a working OSDREP.msi which we are using but we're still getting the PXE-E74 error.
                              2) "Enable traffic on port 69 to the PXE Representative" - not sure how to check this?
                              3) We have checked that DHCP Options 43 and 60 are not in use on our DHCP servers.


                              We have also checked the IIS logfiles and can see the following entry:-


                              2009-04-19 07:32:25 W3SVC1 <PXE_Rep_IP> POST /LANDesk/ManagementSuite/Core/Core.WebServices/Pxe.asmx - 80 - <PXE_Rep_IP> Microsoft-ATL-Native/8.00 200 0 0


                              HTTP 200 = OK (http://en.wikipedia.org/wiki/List_of_HTTP_status_codes) so I assume the PXE Boot request was sucessful but why are we getting the PXE-E74 error.


                              Can anyone offer any help please?




                              • 12. Re: PXE-E74 error

                                We even created a new PXE Boot Menu from scratch with just one image for now and re-deployed the PXE Rep but we're still getting the dreaded PXE-E74 error.  Any ideas for a solution please?




                                • 13. Re: PXE-E74 error

                                  We managed to resolve the PXE-E74 error by uninstalling then reinstalling LDMS 8.8 SP2 on the same core server (FYI Repair did not work).



                                  • 14. Re: PXE-E74 error

                                    Does anyone have any other ideas?


                                    We have 8.8 sp3, and it works on all computers except our newest laptops Lenovo T410's.  I have tried injecting new drivers and that hasn't worked either.

                                    1 2 Previous Next