10 Replies Latest reply on Jul 11, 2008 9:18 AM by TFBA

    http status 503: service unavailable e

    Apprentice

      Getting error message when initiating inventory scan from 32bit console.

        • 1. Re: http status 503: service unavailable e
          beau.gordon Employee

          Did this ever work properly?

           

          This is usually a .net or IIS problem on the core server.  You can reregister .net with IIS, which may help.

           

          You should check to see if there is a more widespread problem with the webservices.  For example, go to http://localhost/wsvulnerabilitycore/vulcore.asmx in a browser on the core server and see if there is any error.

           

          What version is this, and was it a fresh install or an upgrade?

          • 2. Re: http status 503: service unavailable e
            Apprentice

            I was working last week. I have 8.7 service pack 4. I get a vulcore page with a lot hyperlinks. I don't see any errors.

            • 3. Re: http status 503: service unavailable e
              Employee

              If you're doing an inventory scan, and not a vulnerability scan, I would suspect that the error is happening trying to download the LDAPPL3 file. I would check the IIS log file, which is generally found in C:\WINDOWS\SYSTEM32\LOGFILES\W3SVC1. The log files are spaced delimited and can be easily imported into Excel. Search for the IP address of the workstation that is having the problem and see if you can find out what URL is returning the 503 error.

              • 4. Re: http status 503: service unavailable e
                Apprentice

                 

                I also gives me the same error message if I try to start a security scan. It is happening on all machines. Only thorugh the 32bit console.

                 

                 

                • 5. Re: http status 503: service unavailable e
                  SupportEmployee

                   

                  This seems to be an issue with IIS on the core server. Do you get the same error when trying to  initiate a security scan from the core server. I am also assuming in both the case of the inventory scan and the security scan that you are attempting to do this by right clicking the device from all devices.

                   

                   

                  You can verify that this is a web issue by attempting to get to the following URL's from the core server:

                   

                   

                  http://localhost/landesk/managementsuite/core/core secure/corerequest.asmx

                   

                   

                  If the above fails you can also try:

                   

                   

                   

                  Going to (where x.x.x.x = ip address):http://x.x.x.x/landesk/managementsuite/core/core secure/corerequest.asmx

                   

                   

                   

                   

                   

                   

                   

                   

                  • 6. Re: http status 503: service unavailable e
                    beau.gordon Employee

                    In general you should look at what changed that could have affected IIS and .net on the core.  Did you install a newer .net framework?  Move the server to a different OU with a different security policy?  Make any changes involving the LANDesk core certificate?

                     

                    I'd check the web service gashby suggested to make srue it exists and that you can browse it.  If you can, reregister .net with IIS.  (c:\program files\microsoft.net\framework\v1.1.4322\aspnet_regiis -i)

                    • 7. Re: http status 503: service unavailable e
                      Expert

                      I am with Beau on this one... A couple of thoughts turn off the friendly HTTP errors in IIS and also have a look at the Console.exe.log. Does the inventory scan run ok from the program group? This could be just the HTML for the Right click GUI.

                      • 8. Re: http status 503: service unavailable e
                        LANDave SupportEmployee

                         

                        Do you have a proxy server in your environment?  If so, double check the settings, or see if you can bypass it to see if makes a difference.

                         

                         

                        Sometimes this can also be caused by missing or incorrect certificates on the client.  

                         

                         

                        Does this happen when doing it to all clients, or just to select clients?

                         

                         

                        Some other steps to try:

                         

                         

                        1. Log into the Core Server with a user that has both Local Admin rights on this server and Local admin rights on the remote client machine (Domain Admin).

                        2. Open the Core Win32 Console.

                        3. Rename the console.exe.log to something else.

                        4. From IIS go to IIS\Web Sites\Default Web Site\landesk\ManagementSuite\Core\

                        5. Right click on core.secure and go to properties. Under the Directory Security, click Edit under Auth and access control. Enable anonymous access? should be unchecked and the only thing that should be checked is Integrated Windows Authentication?.

                        6. With core.secure highlighted, right click on corerequest.asmx and select browse. The window should come up with multiple CoreRequest in the Title and multipler Service items.

                        7. Go to C:\Program Files\LANDesk\Management suite and right click on ShutdownReboot.dll and select properties. The Security tab should contain several users, make sure that ASP.NET and Network Service accounts are listed and have full control.

                        8. Is there a proxy server used to access the web? If so then make sure that the core server IP address is listed in the exceptions to bybass local addresses.

                        9. Go to the following URL: http://CORENAME/landesk/ManagementSuite/Core/core.secure/corerequest.asmx

                        10. Select ShutdownWithInfo and input the IP Address of the machine to be rebooted and click Invoke.

                        11. A window should pop up and have a 0 which indicates successful.

                        If something else is listed here, let me know.

                        12. If the above steps do not help then I will need the newly created console.exe.log file from \CORENAME\LDMain and the exXXXXXX.log file from C:\WINDOWS\system32\LogFiles\W3SVC1.

                        13. Obtain and run RegMon.exe and FileMon.exe from Sysinternals and capture a log of the action of right clicking on a device and selecting shutdown and send it to me. These utilities can be obtained for free from http://www.sysinternals.com/.

                         

                         

                        • 9. Re: http status 503: service unavailable e
                          Apprentice

                           

                          I just notice that this is only happening on my Vista machine. All the other users that have the console they are working fine. Only mine is not working properly.

                           

                           

                          • 10. Re: http status 503: service unavailable e
                            Apprentice

                            My proxy settings were incorrect. As soon as I changed them the problem stopped.