1 2 Previous Next 18 Replies Latest reply on Oct 11, 2012 2:16 PM by cgodden

    Date in Web Access 7.4

    Apprentice

      Is there any way to change the date in Web Access to appear as mm/dd/yy instead of dd/mm/yy. I tried using the suggestion from this article: http://community.landesk.com/support/docs/DOC-22918   but it doesn't seem to help. We are using 7.4. Any help is appreciated.

        • 1. Re: Date in Web Access 7.4
          Expert

          If you are using Report Templates, then the following article may help - http://community.landesk.com/support/docs/DOC-23331

          • 2. Re: Date in Web Access 7.4
            Apprentice

            Thank you, but this does not seem to apply to our situation.

            • 3. Re: Date in Web Access 7.4
              Apprentice

              This is driving us crazy! Not sure if this helps to jog any ideas, but the format seems to appear this way in queries we're using on dashboards as well as the histroy within a incident. In the full console (outside of Web Access), all seems fine and the dates show with the correct format of mm/dd/yy. Not sure why this is different between the two.

               

              Something else I've noticed is its not just with the creation date attribute. Its also effecting other date attributes. I've noticed on some of them, the date is listed as dd/January/yy in web access. In the console, these will show as mm/dd/yy.

               

              Here's what were seeing:

               

              WA1.png

               

              WA2.png

              • 4. Re: Date in Web Access 7.4
                Apprentice

                We worked with support to get this figured out. Making the change to the web.config file really made a difference. For other date fields, we are using either long or short format depending on the situation. Hope this helps others.Here's the deatils from the support ticket:

                 

                 

                Problem 5315 - Cannot use DateTime fields in Web Access if culture is set to en-US (or other with mm/dd/yyyy dates)
                **********This has a high priority and there is no patch available in 7.5 at this time***************

                 

                Problem 5047 - Dates in long date format do not correctly display the correct regional format in Web Desk
                The date time format of long dates such as ‘9 November 2010’ always in this format and do not pick up the regional settings. Using a short date format on an US system will pick up 11/28/2010 using this regional setting in Web Desk.
                **********This has a low wish list priority and there is no patch available in 7.5 at this time***********

                 


                **************************************************************************************
                For dates to show up properly in 7.4 and 7.5 you would need to us long date format with no time.

                 

                If so the steps to do this are as follows:
                1. Create a DateTime attribute on an object (say Incident) and add it to the window design. Or modify the existing date fields you would like to use.
                2. Modify the Globalization setting in the WebAccess web.config file (or if using IIS 7 use the .NET Globalization panel under the WebAccess directory). By default this value is "en-GB", change it to "en-US".
                3. Log in to Web Access and the dates will now be in US format mm/dd/yyyy.

                 

                For fields that would need a time and a date, then you would need to do short date format.

                 

                So if problem 5315 where fixed with a patch it would allow for short date time fields in the correct US Format.

                • 5. Re: Date in Web Access 7.4
                  Rookie

                  Following the above steps I was able to get the date displaying properly in the windows, but not in query displays.  No matter what I try they always come up in DD/MM/YYYY format.  Where you able to get queries displaying properly?

                  • 6. Re: Date in Web Access 7.4
                    Apprentice

                    The dates on our queries have always seemed to be ok. Can you provide some more details (In webdesk/full console? Screenshot of what you're seeing)

                    • 7. Re: Date in Web Access 7.4
                      Rookie

                      I am only seeing the date field in that format now in the webdesk Queires.  Here is a screen shot of what I am seeing.

                       

                      Servicedesk scrrenshot.bmp

                       

                      Sorry for the dely in responding, I have been out for while.

                      • 8. Re: Date in Web Access 7.4
                        Apprentice

                        We are using 7.5 and are having the same issue with queries. Anybody know of a solution?

                        • 9. Re: Date in Web Access 7.4
                          karenpeacock SupportEmployee

                          Hi

                           

                          You should be able to after applying SP1.  Here is an article about how:

                          Changing Web Access from UK date format to US format in 7.5 SP1 onwards

                           

                          Regards

                          Karen

                          • 10. Re: Date in Web Access 7.4
                            Apprentice

                            Karen,

                             

                            I have upgraded from 7.5 to 7.5 sp1 and then did the procedure you mention for changing the system culture to <add key="SystemCulture" value="en-US" />. I recycled the ServiceDesk; however, I still have the same issue. Any other suggestions?

                             

                            Thanks,

                            Kathi

                            • 11. Re: Date in Web Access 7.4
                              karenpeacock SupportEmployee

                              Hi Kathi

                               

                              On your Web Server in IIS for your Web Access virtual directory there are some settings under .Net Globalisation.  What is the Culture and UI Culture set to please?

                               

                              Regards

                              Karen

                              • 12. Re: Date in Web Access 7.4
                                Apprentice

                                Good Morning Karen,

                                 

                                The Culture is set to "English (United States) (en-US) and the UI Culture is set to "Invariant Language (Invariant Country). Should the UI Culture match Culture?

                                 

                                Thanks,

                                Kathi

                                • 13. Re: Date in Web Access 7.4
                                  karenpeacock SupportEmployee

                                  Hi Kathi

                                   

                                  It should be en-GB for both.  Even when you are in another country it should be the config file setting (system culture) which governs this.  I would recommend making this change out of usual working hours or within your test environment to see what the results are first.

                                   

                                  Regards

                                  Karen

                                  • 14. Re: Date in Web Access 7.4
                                    Apprentice

                                    Hi Karen,

                                     

                                    I changed both Culture and UI Culture to en-GB; however, I still get the date showing improperly in webdesk and self service as dd/mm/yyyy hh:mm:ss when I have specified to only show the date. It shows properly from the console as mm/dd/yyyy hh:mm:ss am. I did an iisreset and I recycled the application pool just in case. Am I missing something else?

                                     

                                    Thanks,

                                    Kathi

                                    1 2 Previous Next