1 2 Previous Next 15 Replies Latest reply on Feb 7, 2012 6:24 AM by Frank Wils

    loading template 40/40 retry attempt

    Rookie

      Hi,

       

      I am a (external) ICT project engineer for Mammoet.

      I am currently working on the Windows XP to Windows 7 x64 migration project

      Worldwide sites, <2000 workplaces, laptops and desktops

       

      Main building blocks for deployment:

      Windows 7 SP1 Enterprise x64 TBI image

      Landesk Management Suite 9.0.3.1(deployment template, script template, app templates)

      DFS

      Siteboxes, local (PXE) servers

      MPLS WAN network

      Gigabit+ internal networks

       

      I frequently got errors with loading template 40/40 retry attempt, for now loading template does not work at all anymore

      The template did work correctly and there were no changes implemented

      My laptop in PXE mode points to the correct PXE server on site

       

      It seems that our main application script causes this error in the template

      Loading template and a succesful OS deployment runs fine without the application script

      The application script includes all our default apps like adobe reader, ms office, flash, etc

       

      The landesk PXE software runs on a 2003 x86 Server, i tried to deploy it on Server 2008 R2 x64 but it seems not to work (laptop does not get PXE information)

       

      This issue is a show stopper in the Win7 project devolopment and testing, i need to escalate it

      How can we fix this, whats the best way to start troubleshooting?

      Can you guys help me or do we need to do something with a ticket service request / remote support

      We have a support contract

       

      Regards

       

      Wesley Schrik

      Mammoet Netherlands, Schiedam

      ICT Infrastructure projects

        • 1. Re: loading template 40/40 retry attempt
          Specialist

          I'm a little unclear about your "templates" and hoping you can clarify a bit.

           

          Are you going to use PROVISIONING or OSD for this migration.  It makes a huge difference around here because you'll get advice applicable to one and not the other.  I am new to LDMS and simply skipped OSD entirely in favor of PROVISIONING.

           

          So please answer that question first.  I think you'll answer with PROVISIONING only.

           

           

          I'll point out that whenever I have experienced the 40/40 errors with provisioning it was because the SCHEDULER service on the landesk core was not running.  We have a problem where by it refuses to start automatically, so whenever we reboot the core we have to remember to start that service manually or else we see 40/40 attempts as errors.

           

           

          Now, can you tell us more about what is in the three templates you listed and whether or not they are tied together in your tasks? This might clarify some details about the cause.

           

          For provisioning I know that when you initiate a provisioning task the first thing that is done is the selected provisioning template will get copied and locked so that the client has a fixed set of instructions to follow throughout the task.  At different times and for different reasons there may be problems getting this template locked.  Again, I'm not clear on what your application script does, but if you are saying that it breaks an otherwise functioning provisioning template then we should look at how you have that app script integrated with the OS script.

          • 2. Re: loading template 40/40 retry attempt
            Frank Wils ITSMMVPGroup

            Wesley,

             

            What can also happen is that the template tries to resolve all software distribution actions and the hash from one of the distribution packages doesnt match, or the packge cant be found on the share. Look in the prov*.* templates on \\coreserver\LDLOG

             

            PXE on Win2008R2 should work, but it might be best to disable IPv6 completely, also in the registry.

             

            Frank

            Axle-IT

            ESP for the Netherlands

            • 3. Re: loading template 40/40 retry attempt
              Apprentice

              Possible causes:

              1- Scheduler Service Stopped

              2- Task Handler Exception (tipically a script/package/file used by the provisioning template is missing). Check log file in \\CORESERVER\LOG\prov_schedule.exe.log

               

              HTH

               

              Regards,

               

              Jary

              • 4. Re: loading template 40/40 retry attempt
                Rookie

                Hi Aspenskier,

                 

                I use the 'Provisioning Policy' in PXE environment before i choose to deploy my Win7 + Apps template

                The scheduler service is started on the core server, i tried to restart is without a result, i have to note that i can deploy Win 7 without app script succesfully

                 

                Here you can find my entire script mechanism:

                http://speedy.sh/4DEah/Landesk-loading-template-40-40.zip

                 

                 

                 

                 

                Frank,

                 

                i reset all the win7 app package hashes without a positive result

                 

                @ Frank and Jary, i uploaded the log files here

                http://speedy.sh/R4sBj/provisioning.zip

                 

                The prov_schedule.exe seems not up to date? below it errors on a adobe has, i reset this after i saw this error

                • 5. Re: loading template 40/40 retry attempt
                  Specialist

                  You do have quite a bit of software disrtibution happening in the final phases of your provisioning steps.

                   

                  As the others have pointed out you probably have a problem with one of the packages.  While it was a good thing to try and rebuild your hashes, you stated that didn't help.

                   

                  So how about this, lets have you take a bracket approach to see if you can narrow the source of the conflict.

                   

                  Take your provisioning template that has all of the distributions in it, "1_APPL-Default Applications All Systems Win7x64", and clone it twice.  Rename one of those clones *-PART1 and then rename the other *-PART2.  From here open up part1 and strip out the latter half of your software distributions then repeat for part2 and elminate the 1st half.  With me so far?

                   

                  Next run two computers through provisioning at the same time each with different parts.  See if one goes through and the other fails. Hopefully you'll get one of them to run okay.  In this case you have issolated the problem distribution package to half of your collection and you can then rebracket that half to further issolate it.

                   

                  If both parts fail then you either have multiple distributions that are causing problems or you have some other problem with software distribution.  In the latter case mabye you can just try a single distribution with your template to see if you can get it to work.

                   

                  If you are able to run through all of this and you still have problems then I think you have plenty of data to pass onto a landesk support guy and would suggest that you call in for additional support.

                   

                  good luck

                  • 6. Re: loading template 40/40 retry attempt
                    Frank Wils ITSMMVPGroup

                    I see in your logfile the following error:

                    ERROR PROV_SCHEDULE  2/2/2012 2:37:37 PM  : Exception encountered trying to get snippet (LANDesk.ManagementSuite.SoftwareDistribution.Business.HashFailedForFileException): Failed to get the hash for \\group.wan\landesk\ldms$\package\Adobe_Acrobat_Reader_10-1-1_ML_1\MSI\Acroread.msi : Could not find file '\\group.wan\landesk\ldms$\package\Adobe_Acrobat_Reader_10-1-1_ML_1\MSI\Acroread.msi'..
                    ERROR PROV_SCHEDULE  2/2/2012 2:37:37 PM  : GetSoftwareSnippet failed

                     

                    Can you check this package? I mean the actual package, not just to reset the hash...

                     

                    Frank

                    Axle-IT

                    • 7. Re: loading template 40/40 retry attempt
                      Rookie

                      Hi Wesley,

                       

                      We' ve seen this error here in our environment.

                      For us it was caused by using multiple account during provisioning. If you are using multiple accounts I would suggest to try to use just 1 account for all provisioning task. For some reason Landesk is not able to handle more than 1 account correctly for provisioning tasks.

                      Since we are using just 1 dedicated account for provisioning, our IT community is not complaining anymore about this 40/40 error.

                      • 8. Re: loading template 40/40 retry attempt
                        Frank Wils ITSMMVPGroup

                        Weird. As long as the user has enough right to provision the system (RBA, scopes) there is no restriction on the number of users... I''ve tried, tested and used this many times...

                         

                        Frank

                        Axle-IT

                        • 9. Re: loading template 40/40 retry attempt
                          Rookie

                          Hello all!

                           

                          I am taking over this call for the Mammoet side. I am working with Wesley on this. I have not tried the removal of the applications from the template, but will.

                           

                          However, I wanted to go back to a point about the LANDesk Scheduler service. We do seem to be having a problem with it.

                           

                          The service keeps stopping itself.

                           

                          It was set to Automatic, but it was always stopping itself.

                           

                          I saw the post about setting it to manual as a fix, but even set to manual, it will stop itself.

                           

                          Is this normal, or should this service always be started? If so, then I think this may be the problem.

                           

                          What are your thoughts?

                           

                          While I wait, I will try the removal of the applications from the template and see if that yields any results.

                           

                          Thanks for all of the help so far gents!

                           

                          John

                          • 10. Re: loading template 40/40 retry attempt
                            Frank Wils ITSMMVPGroup

                            John,

                             

                            A scheduler service that stops frequently on its own usually means that there is something wrong with the credentials it uses or that there is a problem with the 2 Com+ components LANDesk uses. Are those also running under Domain credentials? Can they be stopped and started manually without any problems?

                             

                            Also take a look in your Application Event Log. Any errors there?

                             

                            Frank

                            Axle-IT

                            • 11. Re: loading template 40/40 retry attempt
                              Specialist

                              yes John, you do have a problem with your scheduler service.  The stopping that you describe is not normal.  Please see franks advice.

                               

                               

                              Ours seems to stay running once it starts, but it almost never starts automatically when we start the server.  We almost always have to manually start it from the  LANDESK CONFIGURE SERVICES component.  For whatever reason the credentials that we supplied don't seem to stick and when we manually start the service we have to re-enter the password for the service account first.

                               

                              I logged a case with Landesk about a year ago on this and they had me follow a very specific and lengthy set of instructions to rebuild the COM services on the landesk core.  It wasn't much fun.  They might have you go through this.  When I did the service auto-started after a reboot but then later when I rebooted the core it wouldn't start automatically.  I think there is a problem on the Landesk side and not the microsoft side.

                               

                              anyway, good luck

                              • 12. Re: loading template 40/40 retry attempt
                                Rookie

                                OK, yes the Scheduler service is running with Domain credentials. The account password has not been chnaged, nor has the account been modified in anyway.

                                 

                                Just to make sure, I have copied the working password into the password field.

                                 

                                However, after changing this and restarting the services, the same 40/40 timeout occurs when trying to load the template.

                                 

                                I also checked the 2 COM+ addins and they were running under the same Domain account.

                                 

                                On a side note, we have two main templates. One for Win7 and one for WinXP.

                                 

                                The WinXP template loads after the 10-15th timeout sometimes and then fails after 40/40 other times, but the Win7 template will not load at all.

                                 

                                Since the WinXP template does load, does that rule out the Scheduler as the problem?

                                 

                                Or shouldn't I have a problem with the WinXP template also if it isn't caused by the Scheduler?

                                 

                                John

                                • 13. Re: loading template 40/40 retry attempt
                                  Frank Wils ITSMMVPGroup

                                  John,

                                   

                                  Sounds like you have 2 different issues... The scheduler service shouldnt crash and your win7 template should work

                                   

                                  If your XP template does work, I am fairly sure the 2 arent directly related. What do you see in your scheduler log files (in the ldlog share on the server)? And what are the main differences in software packages between the XP and Win7 templates?

                                   

                                  Frank

                                  Axle-IT

                                  1 of 1 people found this helpful
                                  • 14. Re: loading template 40/40 retry attempt
                                    Rookie

                                    Frank, thanks for the reply.

                                     

                                    I have tested removing some of the applications from the Win7 deployment and by doing this the Win7 image is working. I am trying to determine which package is causing the problem, by adding them back in one by one and seeing if they cause any problems.

                                     

                                    I re-entered the password for the domain account that is running the Scheduler service and the COM+ tools nad the service has stayed running ever since.

                                     

                                    I will continue testing the packages and post the conclusion here ASAP.

                                     

                                    Thanks for all of the support!

                                     

                                    John

                                    1 2 Previous Next