1 Reply Latest reply on Feb 2, 2012 5:38 PM by jasond

    OS Deployment - System Configuration - ANY MSI Install Fails

    Rookie

      This OSD only with System configuration to install packages had been working great prior to 9.0 SP2 upgrade. Now no matter how I arrange the list of software to be installed, it fails when installing MSI packages.I dont know that it is an SP2 issue. This is the first time Ive tried provisioning since the upgrade.

       

      I am able to install the suspect MSI package by pushing it out as a scheduled task for that one package.

       

      Any help is greatly appreciated.

       

      Output from the LANDesk Provisioning Agent

       

      action index=7250 type=Create_directory
      SUCCESS
      action index=7251 type=Distribute_software
      SUCCESS
      action index=7252 type=Distribute_software
      SUCCESS
      action index=7253 type=Distribute_software
      SUCCESS
      action index=7254 type=Distribute_software
      SUCCESS
      action index=7255 type=Distribute_software
      FAILED
      error:[80001802H]The action handler output is invalid.

       

       

       

      LANDesk Console - View Provisioning History - For the failed Task.

       

      Execution Status Failed
      Internal Status -2147477502
      External Status 0

       

      Status in the console still shows Active even though it failed miserably at the client.

       

       

       

      Log from the client

       

      C:\Program Files (x86)\LANDesk\LDClient\Data\sdclient_task541.log

       

      Thu, 02 Feb 2012 17:47:24 Execute Msiexec.exe with command Line: "Msiexec.exe"  /passive /norestart /a "C:\Program Files (x86)\LANDesk\LDClient\sdmcache\DistroPackages\_Servers\7zip\7zip_9.2.0\7z920-x32&x64.msi" REBOOT=ReallySuppress
      Thu, 02 Feb 2012 17:47:26 MSI result DB50000
      Thu, 02 Feb 2012 17:47:26 processing of package is complete, result 229965824 (0x0db50000 - code 0)