7 Replies Latest reply on Feb 13, 2012 3:25 PM by zman

    Can't Cancel a Scheduled Task in 9.0, SP3

    Rookie

      I have several scheduled tasks which I canceled, but which seem to continue to be active even though the task status indicates it's not.  The devices in the "Active" category have actually GROWN in number since I hit the "Cancel" option and with one of the cancelled tasks, I tried hitting "Cancel" repeatedly rather than just once.  This actually seemed at first to be producing the desired result of a fully stopped scheduled task, but as the number of Actives approached zero, the number then started going back up again!  Ultimately, the "Cancel" option disappeared.  I can only now "Start" the cancelled tasks even though the one I just mentioned now says ithas 28 "Active" devices.

      Active_Tasks.png

      In one discussion thread here, someone suggested stopping/restarting the LANDesk Scheduler service and another an IISReset.  Well, I did both!  Bounced the LANDeskScheduler service AND did an IISReset.

       

      Result?  N/G.  Cancelled tasks are still active.  This is getting to be like driving a car where the steering wheel is "sort of a suggestion" for which direction to go in.  One frustrated poster from 2009 literally unplugged his core server until he had a resolution (which seemed to be the actions I just took).  I really don't want to go that far if I can avoid it.  Hopefully, someone here has an answer.

       

      Thanks.

       

      --Brad

        • 1. Re: Can't Cancel a Scheduled Task in 9.0, SP3
          zman Master

          Just a thought, wondering if taskqueue is still executing the task. Look at some of the machines that are pending and see if taskqueue.exe is running. You could also delete the targets.

          • 2. Re: Can't Cancel a Scheduled Task in 9.0, SP3
            Rookie

            Thanks, ZMan, I'll check that out.  BTW, I forgot to mention that yesterday, I tried a brute force kill operation on all the PC's stated to be "Active".  The script for the task has the follow remote commands:

             

            REMEXEC0=cmd /c c:\Windows\System32\taskkill.exe /f /IM SDCLIENT.exe
            REMEXEC1=cmd /c c:\Windows\System32\taskkill.exe /f /IM sdistbat.exe
            REMEXEC2=cmd /c c:\Windows\System32\taskkill.exe /f /IM setup.exe
            REMEXEC3=cmd /c c:\Windows\System32\taskkill.exe /f /IM msiexec.exe

             

            I don't see taskqueue.exe running on several of the PC's I've just checked.

             

            --Brad

            • 3. Re: Can't Cancel a Scheduled Task in 9.0, SP3
              Rookie

              P.S.  When I try to delete any device from a Scheduled Task where the targetted devices come from a canned query, I get the following scary warning:

              Scary_Delete_Message.PNG

              Since I have no idea what this means, I've always answered "No" (as in "No, I don't want to shoot myself in the head, thanks very much.").

              • 4. Re: Can't Cancel a Scheduled Task in 9.0, SP3
                zman Master

                Wording on that sucks, it just means that the if the targets were added by a query device/ldap that the entire query will be removed from the scheduled task. It will not delete the query from LANDesk (you can't just remove one device from a scheduled task that was added by a query.). The image does indicate there are deviced queued by taskqueue.  Still wondering how canceling a task affects taskqueued machines.

                1 of 1 people found this helpful
                • 5. Re: Can't Cancel a Scheduled Task in 9.0, SP3
                  Rookie

                  Okay, that's somewhat encouraging.  Since I still haven't found taskqueue.exe running on any of the "Active" PC's in my "Cancelled" task, I'm tempted to just delete all the devices from those tasks.  However...  I don't want to be creating some zombie tasks on the target PC's by doing that.  Any idea what the side effects of removing all the devices from a cancelled task would do?  BTW, I really appreciate all your ideas and feedback on this.

                   

                  --Brad

                  • 6. Re: Can't Cancel a Scheduled Task in 9.0, SP3
                    Rookie

                    Okay, I have now found a number of "Active" PC's with large numbers of taskqueue.exe processes running simultaneously.  LD support says with policy-supported push tasks, it's not enough to delete devices from the task.  They'll just add themselves back in on the next policy sync since their local database says the task is in its local queue.  Their recommendation was to delete the task altogether.  I've done that and will run a LANDesk script support is providing to clean up taskqueue.exe processes on machines where we see a large number of such processes running.  Will let you know if this does the trick.

                     

                    --Brad

                    • 7. Re: Can't Cancel a Scheduled Task in 9.0, SP3
                      zman Master

                      Sounds like a bug, or not well thought out feature.  Be interested in seeing the script they sent. My thoughts are that if the scheduled task is canceled on the core then all locally queued task should also be canceled.