6 Replies Latest reply on Feb 14, 2012 10:40 PM by Alex.Richardson

    Vboot timeout to remote site

    Alex.Richardson SSMMVPGroup

      Hi All,

       

      I have run into an issue using the inbuilt 'Boot to Managed WinPE' action on remote sites with low bandwidth connections as this tries to download the boot.wim from the core sevrer. The download takes so long that this actions times out and the task fails.

       

      I have grabbed the old vboot template from http://community.landesk.com/support/docs/DOC-9980 so I change the download boot.wim step to grab this from the local preferred server which works but when the client reboots to WinPE it is coming up with the OSD virtual X: drive rather than provisioning so my template doesnt continue.

       

      I know in PXE you need to load the correct statrom.0 file to get WinPE into provisioning mode but how can you force this for a vboot action? Does the boot.img have anything to do with this?

       

      Attached is a picture of my template which maps drives based on the preferredserver.dat then does the vboot steps including downloading the boot.wim locally.

       

      Cheers,

      Alex

        • 1. Re: Vboot timeout to remote site
          Alex.Richardson SSMMVPGroup

          Just to add the core is running V9 Sp2 with the OSD, SD and Core MCP's installed

          • 2. Re: Vboot timeout to remote site
            Apprentice

            Modify your action that copies boot.wim so that instead of copying boot.wim, it copies bootmedia.wim (found in the same folder on the core as boot.wim).  Ensure that as its copied down it is renamed from bootmedia.wim to boot.wim.

             

            Boot.wim does not contain all the files needed to start provisioning.  Instead these files are copied down post boot into WinPE.  On the other hand bootmedia.wim (which is designed for use with a bootable usb key or similar) includes everything you need in the image to perform provisioning.

             

            The one thing you'll have to remember is that any NIC drivers you've added to boot.wim in the past you'll also have to add to bootmedia.wim (done using the same applet from the OSD tool).

             

            I used a similar template for exactly the same reason recently and it worked perfectly using bootmedia.wim.

             

            Steve

            1 of 1 people found this helpful
            • 3. Re: Vboot timeout to remote site
              EMiranda Expert

              Try this, you are missing some actions in your template:

               

              Take out the reboot action.

               

              Change it to Wait: Time = 300

               

              Add Pre-OS installation action:

               

              • Remove vboot Partition (1)
                • x:\ldclient\diskinfo.exe
              • command line parameters:
                • fix
              • Remove vboot Partition (2)
                • x:\ldclient\diskinfo.exe
              • command line parameters:
                • remove_vboot_partition

               

               

              you also need to put in there what you want the job to do after all that, like image the computer, ect.

              • 4. Re: Vboot timeout to remote site
                Alex.Richardson SSMMVPGroup

                Steve,

                That makes sense but when you use the inbuild LANDesk boot to WinPE action it uses the boot.wim as you can see the drivers there that are not added to bootmedia.wim so i know it can be done from the boot.wim

                 

                 

                EMiranda,

                So the bootfile.exe will initialte the reboot? And I m seeing the startnet.bat running and removing the vboot automatically so shouldnt need to manual steps for this. The issue seesm to be this batch file is not getting passed the correct boot option to load the ldprovisioning files!

                 

                if not exist WinPE20ProvBootOpt.reg goto EndBootOpt
                reg import WinPE20ProvBootOpt.reg
                :EndBootOpt


                \cba8\GetBootOptions20 > \temp_cln.cmd
                set /a option = %errorlevel%

                @rem option refer to boot option:
                @rem -2 means in provisioning vboot (not in winpe2.0)
                @rem -1 means not in winpe2.0
                @rem 1 means pxemenu
                @rem 2 means managed pxeboot
                @rem 3 means provisioning winpe

                • 5. Re: Vboot timeout to remote sites
                  Apprentice

                  this is true. the correct bits of that script are normally invoked based on the option you choose at the pxe boot selection menu (the f8 menu). since you're not using pxe though this doesn't happen.  obviously the vboot option in the standard reboot action is somehow getting around this but i don't know exactly how its doing it. i just wanted to give you the path of least resistence that is also tried and tested.

                   

                  have you seen the article on here that pre-dates the proper vboot action? it was written by landesk a couple of years ago and has a template attached. i'm on the bb atm so cant easily link to it but just search for vboot template and you'll see it.

                   

                  steve

                  • 6. Re: Vboot timeout to remote sites
                    Alex.Richardson SSMMVPGroup

                    I wish I knew how LD was doing this too then I wouldnt have to add drivers to both WinPE images. The bootfile action does cause a reboot but it still then only loads WinPE without loading and launching provisioining.

                     

                    Looks like using the bootmedia.wim is the easiest solution thanks Steve.