2 Replies Latest reply on Mar 3, 2012 3:37 PM by dmshimself

    Error 1935 when trying to install Crystal Reports Runtime as part of Service Desk 7.5 upgrade

    mwilletts Rookie

      I'm having difficulty upgrading our test system to LDSD 7.5 from 7.4.   I've been following the upgrade document and when it comes to the actual install it fails installing SAP Crytal Reports runtime engine for .NET Framework 4 (64-bit) and I can go no further

      I had uninstalled the old version of Crystal runtime as the document suggest (and rebooted) before attempting the installation.  I have tried installing the CRRuntime_64bit_13_0.msi separately, I have tried installing the full version of Crystal Reports and I have tried installing the 32bit version but each time I get the same error message:

      "Error 1935. An error occured during the installation of assembly component {97F81AF1-0E47-DC99-A01F-c8B3B9A1E18E}. HRESULT: 0x80070005."

      I’ve tried ‘running as administrator’ (even though I’m logged in as a local admin).

      I have tried removing any references to the old version of Crystal in the registry, repairing and reinstalling .NET Framework 4 (and applying any windows updates); still the same result.

       

      The server is running Windows Server Standard 2008 SR2.

      Can anyone help me with this?

       

      Thanks

        • 1. Re: Error 1935 when trying to install Crystal Reports Runtime as part of Service Desk 7.5 upgrade
          karenpeacock SupportEmployee

          Hi

           

          This isn't something that has been reported to us before I don't think.  From doing a bit of searching this seems to indicate a windows installer issue. I found some additional advice on Microsoft answers so you might want to do some further digging on this.

           

          If still no luck, you could raise this with your support provider and we could ask SAP for their assistance.

           

          Best wishes,

          Karen

          • 2. Re: Error 1935 when trying to install Crystal Reports Runtime as part of Service Desk 7.5 upgrade
            ITSMMVPGroup

            I had similar sounding issues when trying to install the full Crystal reports 2008 SP3 as part of a couple of 7.5 upgrades.  So not exactly the same issue as yours but similar and there are heaps of google type results for this. Karen is quite right to point you at logging this as a support call with your local provider to get a more complete answer.

             

            However if you had an environment you were happy to test something out on, you might find the following helps.  I think previous installers (not limited to only the LANDesk ones) may have changed the rights to some key areas.  The following changes them back to some good defaults.  It takes a while to run, but cured this problem for me on both sites where we had problems upgrading.

             

            It uses the opensource setacl from http://sourceforge.net/projects/setacl/files/

             

            setacl.exe -on "HKCR" -ot reg -rec yes -actn setowner -ownr "n:S-1-5-32-544;s:y"
            setacl.exe -on "HKCR" -ot reg -rec yes -actn ace -ace "n:S-1-5-32-544;p:full;s:y" -ace "n:S-1-5-18;p:full;s:y" -ace "n:S-1-5-32-545;p:read;s:y"
            setacl.exe -on "HKLM" -ot reg -rec yes -actn setowner -ownr "n:S-1-5-32-544;s:y"
            setacl.exe -on "HKLM" -ot reg -rec yes -actn ace -ace "n:S-1-5-32-544;p:full;s:y" -ace "n:S-1-5-18;p:full;s:y" -ace "n:S-1-5-32-545;p:read;s:y"