6 Replies Latest reply on Mar 15, 2012 7:41 AM by RichardA

    No further provisioning possible after OS-deployment




      I am having some trouble with provisioning.

      Last week we updated to v9 SP3. Everything works well now

      We configured provisioning templates and deployed a Windows 7 OS with all our specific settings. Everything is really fine.


      But there is still an issue that I don't can solve by myself.

      A 'finished' system (all actions in provisioning template are completed) is up running. The installed LANDesk agent is version with specific settings.

      I made a provisioning template to combine the several install-files for iTunes. When I plan the template as a task and start it for a machine, the task fails after a several minutes and says that the machine ist not reachable or turned off. That only happens when starting a task with a provisioning template. When I start a task where a distribution package should be installed, everything works fine.


      So, the firewall ist turned off, there are no network restrictions and the agent is able to do software deployment - provisioning-tasks NO, package-tasks YES.


      I already tried the 'original' LANDesk agent configuration, but that didn't make it better.

      Another phenomen is that 'old' machines, that haven't been deployed with a provisioning process will start the provisioning agent.


      So, now it's your turn ;-)


      Thanks in advance




        • 2. Re: No further provisioning possible after OS-deployment

          Hi Marcel,


          So, to clarify, you...

          • Create a provisioning task (with a template that just installs some software?)
          • Target a machine that is already provsioned and start the task
          • The targeted machine does nothing
          • Some machines that are not targeted by that task start the provisiong agent?!?


          Something is quite wrong if that is happening, and you may be better served my logging a case with LANDesk support.


          Out of curiosity, those machines that incorrectly start the provisioning agent; do they actually pick up the template and start doing something?

          • 3. Re: No further provisioning possible after OS-deployment

            Hi Richard,


            no, i think you misunderstood me. I'll try to outline it a bit better, sorry for my bad english...


            Weeks ago, we used to work with this environment:


            • Made a reference image
            • Captured the image with LANDesk and imagew2.exe
            • Deployed the image to a new machine and installed additional software via provisioning template, because it's exhausting to start one task after another for every single software package


            After updating to SP3, we setted up Provisioning (the 'real' provisioning)


            • Made a reference image
            • Captured the image with LANDesk and imagex.exe
            • Created several module (for joining domain, install ldagent, install drivers, etc.)
            • Created a 'master' template that includes the image deployment and the modules


            Provisioning works really fine and I don't want to miss it

            After the provisioning progress is finished (OS deployment and modules completed) the local administrator account is logged on.

            If I start a provisioning template with the additional software, the provisioning agent starts and the software is going to be installed.

            If I log off the administrator and login in with a domain account, the management suite says that the machine is turned off.


            That is really bad, because if I want to install a software via provisioning template weeks later, it won't succeed because the domain account is logged on and the management suite shows the machine as turned off


            Hope that is better to understand?

            • 4. Re: No further provisioning possible after OS-deployment

              Can you try this:


              • Schedule the provisioning task as normal
              • Wait for a machine to fail
              • RDP to that machine or access the local console
              • Copy \\<ldcore>\ldlogon\provisioning\windows\ldProvision.exe to C:\ldprovision\
              • Run ldProvision.exe from the local location (do not run it directly from the core)


              Does it then continue the template as normal?


              If it works, this may indicate that the issue is just with the initial push of the provisioning agent. Although provisioning tasks are technically policies, the inital execution of the provisioning agent uses a push-style command (unless this has changed in SP3). I'm not sure if it uses the LANDesk agent to push this command, or windows RPC commands.


              Are you sure that a domain policy isn't enabling the windows firewall and blocking LANDesk from communicating with the machine?

              1 of 1 people found this helpful
              • 5. Re: No further provisioning possible after OS-deployment

                Well, I tried this.


                The provisioning agent started and asked for my credentials.

                After typing my credentials I get the provisioning menu... I think he is waiting for me to chose a template, but the template I previously planned for the client didn't start automatically.


                I am very sure that there isn't such a domain policy, because the point is: all settings on the client have been setted up exactly the same way like the way we did before provisioning.

                Example: we made firewall settings (firewall turned off for domain network) with a task and a reg-file. An OS that has been installed with provisioning got exactly the same task and reg-file...


                All client that have been deployed with imagew2.exe will start the provision agent, all clients that have been deployed with imagex.exe and provisioning won't.


                edit: if there is any issue with the firewall setting, a normal task won't start too... but it does ;-)

                • 6. Re: No further provisioning possible after OS-deployment

                  If the template you previously scheduled for the client doesn't start, even if you manually run the provisioning agent, something is wrong with the core's targeting. In which case I think the local account / domain account difference is misleading. I can't think of any way that the account currently logged into a machine can affect how the core targets things, unless you're targeting a query based on user information.


                  I thought you might have duplicate entries in your device database, and perhaps you're targeting the wrong entry, but that doesn't explain how normal software distribution tasks can run without a problem.


                  Hmm. Does the new image you took with imagex.exe contain the LANDesk agent?