3 Replies Latest reply on Apr 6, 2012 4:33 PM by MrGadget

    Scan For Custom Data Registry Key not Working

    MrGadget Expert

      LD9 SP3


      I followed Doc 1089 to the T and checked on the computer in the ldapl32.ini file to see if the core passed on the registry entry I added in the  core and it was there.

      I run a Full Sync scan on the computer and nothing new shows in my inventory.


      The registry keys I added all have a dword listed or Reg_sz listed in the registry.


      Checked, doublechecked spelling , spaces, commas etc in fact I took a entry that is working and copyed it but put it under a different heading in the inventory and it only shows under the heading it was in originally(I did not delete the original entry only copyed/duplicated).

      The original heading was (Computer) - Custom Data - Landesk.  The new heading (Computer) - Custom data - Nic settings.


      Also checked in Services - Inventory Blocked applications and can't find my entry in there either.


      Any suggestions?

        • 1. Re: Scan For Custom Data Registry Key not Working
          MarXtar ITSMMVPGroup

          Lets try checking to be certain the scanning part of this is working correctly. This is a sequence I followed on my test machine before writing this:


          1. Manually edit the LDAPPL3.INI file located in c:\program files\landesk\ldclient\data
            1. We will do this manually but avoid overwriting it with the central one
          2. Find the existing entry for registry collection:
            1. KEY=HKLM,Software\Microsoft\Internet Explorer,Version,Custom Data - Internet Explorer - Version
          3. Copy this and paste it immediately below but change the 'Internet Explorer' part of the target inventory attribute to 'Fred'
          4. Save the file
          5. Launch the inventory scanner using the following commandline (modify for your directory)
            1. c:\program files\landesk\ldclient\ldiscn32.exe /O=c:\scan.txt /V /F
            2. This should run a full scan, not downloading the central ldappl file, and write it to a text file in the root of C:
          6. Open c:\scan.txt in Notepad
          7. Near the top you should see the registry info being collected similar to the following:
            1. Custom Data - MDAC - Version =2.81.1132.0
              Custom Data - Internet Explorer - Version =6.0.2900.5512
              Custom Data - Fred - Version =6.0.2900.5512
          8. If you have the 'Fred' entry, then this means the scanning is working
          9. Now run the scanner as follows:
            1. "C:\Program Files\LANDesk\LDClient\LDISCN32.EXE" /NTT=YOURCORE:5007 /S="YOURCORE"  /V /F
            2. This should now send a full scan to your core server using the local ldappl3 file
          10. This is unlikely to make it to the database, more likely you will see it has been blocked as unknown data
            1. Configure - Services - Inventory - Unknown ItemsUnknownItems.png
          11. If this has worked how it did for me, then you see what I see in the screenshot


          After this, it should be a case of trying to replicate this for other keys. Remember though that you should only do HKLM keys as HKCU keys are not accessible to the scanner if launched by local scheduler.


          Hope this helps.


          Mark McGinn

          MarXtar Ltd


          LANDesk Silver ESP


          The One-Stop Shop for LANDesk Enhancements

          - Wake-On-WAN - Distributed Wake-On-LAN, Scheduled Power Down, and SWDist Sequencing

          - State Notifier - Real-Time Device & User State Inventory Updating & Alerting

          1 of 1 people found this helpful
          • 2. Re: Scan For Custom Data Registry Key not Working
            ahe Expert

            I've some additional hints...


            Here you can find a additional description too: http://www.droppedpackets.org/systemmanagement/ldms/inventory/extending-inventory-with-unmodeled-data-free-ad-groups/



            Or you can try the tool regtoinv, you can get it from LANDesk support...with this tool you can scan the registry for entries in registry where you want and write it in inventory ...




            • 3. Re: Scan For Custom Data Registry Key not Working
              MrGadget Expert

              Thanks to both of you for your replys. I'm sure had I follwed either one I would have gotten it to work.

              I was so frustrated with this I finally called Landesk Support.


              What fixed it was having the Value after the key path and also adding it on the end of the line.

              Of course this does not follow the 1089 doc as it only shows the value after the Key path.

              My entry that was already  in the ldappl3.template and was supposed to have been working since I put it in (under LD9 SP2) but did not work after copying itdown to another line, did work after I added the value to the end of the line.


              I asked the Tech if there was a change made from LD9 SP2 to SP3 and was told no.