5 Replies Latest reply on Apr 20, 2012 3:59 AM by Frank Wils

    can't get successful SD for Acrobat Reader 10.1.3


      I am following a straightforward process to get Acrobat Reader installed via LDMS 9.0 SD tasks but it isn't yielding results.  I'd like to find someone here who can tell me why.  I suspect it has something to do with the Administrative Installation Point that I am trying to use as the .msi source


      It is like this:


      I have downloaded the Acrobat Reader 10.1.0 MSI file; this is a standalone file

      next I have created the AIP for it so that I could patch it to v 10.1.3.  This worked just fine.

      Now that I have a patched acrobat reader source I have used the adobe customization reader to create a transform file for the install.

      From here I created a LDMS 9.0 SP3 SD task which included the MSI and MST files.


      Now in testing I can see the MSI and MST files come across to the clients but they all fail with 1603 errors.  The Log files I have captured don't really provide any clue as to what is going wrong.



      Again I think it has something to do with the AIP because there are other files and folders in addition to the MSI and MST files.  When I have attempted to include those additions in the SD task the failures will become 16422.


      Has anyone successfully deployed Acrobat Reader from a fully patched AIP via SD?

        • 1. Re: can't get successful SD for Acrobat Reader 10.1.3
          ahe Expert



          you didn't write, on which client OS you tried it...


          On site http://support.microsoft.com/kb/834484/en-us they wrote about your error code 1603, that local system has not enough rights ...



          To hide your MSI problem, you could use the setup.exe file instead of the MSI...



          For this, you've to edit the setup.ini file like this:


          RequireOS=Windows 2000
          CmdLine=/sall /rs
          [Windows 2000]
          [MSI Updater]


          if you want to add patches, you could do it like this:

          CmdLine="/p "[.\Reader9\AdbeRdrUpd932_all_incr.msp];[.\Reader9\AdbeRdrUpd933_all_incr.msp];[.\Reader9\AdbeRdrUpd934_all_incr.msp]" /qb REBOOT="ReallySupress" REINSTALL=ALL"
          ProductName=Adobe Reader 9.3.4 Update
          ProductName=Adobe Reader 9


          But I never start installation from a server, I make a single compressed file (zip or AutoIT-EXE), copy it locally and start (uncompress) it locally.




          • 2. Re: can't get successful SD for Acrobat Reader 10.1.3

            O/S version, right:



            Windows 7 x32bit.


            And I decided to go the MSI route with the administrative installation point because it is easier to maintain than trying to build new distribution packages in Landesk every time an update becomes available.  I figure I just build a single pacakge one time and occassionally apply an Adobe .MSP to the original installation location.

            • 3. Re: can't get successful SD for Acrobat Reader 10.1.3
              Frank Wils ITSMMVPGroup

              How did you define your distribution package, via UNC or HTTP? If UNC, you could try to use a delivery method with a Run from Source option to see if something goes wrong caching the files to the client or not.



              • 4. Re: can't get successful SD for Acrobat Reader 10.1.3

                my distribution package contains no reference to UNC or HTTP.  Whatever the case I'd just assume use UNC because I don't understand how HTTP would benefit me within my environment.  I don't think there is an issue with the cached file because I can see that it comes down and I can manually use it to perform the install when I'm working on that client.



                I have also noted that since applying SP3 I no longer have the ability to specifiy which account is used to perform the installation...I'm not sure where that option went.

                • 5. Re: can't get successful SD for Acrobat Reader 10.1.3
                  Frank Wils ITSMMVPGroup

                  Can you also run it manually on the client under a local system command prompt?