12 Replies Latest reply on Jul 16, 2012 6:58 AM by tdavenport

    CTOS error on Windows 7 OS deployment


      Hello all,


      I am having error of CTOS during Windows 7 OS deployment. The error "[80001701H]The specified user variable does not exist." appeared, and I have no idea why's that. The attached file is the screenshot of the error.


      And I also attached the screenshots of the provisioning templates and public variable, in case I was doing a wrong setting on day 1.


      Plesae help. Thanks.



        • 1. Re: CTOS error on Windows 7 OS deployment
          Frank Wils ITSMMVPGroup

          Do you have the option on to pass the DeviceID in the CTOS action? Try with the option turned off.



          • 2. Re: CTOS error on Windows 7 OS deployment

            I would make sure that you are assigning the correct partitions and check the box to insert the unique id so provisioning can continue.

            • 3. Re: CTOS error on Windows 7 OS deployment
              tdavenport Specialist

              I'm getting the exact same error but not on CTOS. It happens when injecting my unattend.xml script - which is just a file copy command. The target path is correct.

              I'm not sure what it means by 'user variable' since there is no user variable in provisioning (Global, Template, and Action only). Unless its refering to the fact that the template is not public - I'm using a template in 'My Templates'...will get back to you as I troubleshoot.



              • 4. Re: CTOS error on Windows 7 OS deployment
                tdavenport Specialist



                I don't know if this helps but I'll relay what I found.


                1. On the Target Machine of the failed Provisioning task, go to X:\ldprovision and read the log files. I copied them back to my server so I could save them.
                2. You should find the exact error  -  The error shown in the Console and the one shown on the target machine when it fails is not enough information. Read the logs.
                3. There is generally 1 log per action -  or 1 log per type of action. I think that might be a more acurate statement.


                In my case, the Inject Script log stated: "InjectScriptHandler.exe:Could not find variable COMPUTERNAME". It had nothing to do with "User Variable" per se. So I may have accidentally checked 'insert variables into script' when I imported it in the first place. - Although I swear I didn't.


                So, bottom line - there was an error in my action. I changed it and it worked. In your case, CTOS is very generic. The only option for this action is 'insert unique ID'. Try changing that, delete and recreate the action, change the check box, or recreate the template (last resort). Again, you may find your answer in the logs.


                Let me know how you fare. I'm curious. If you have more info, post it. Good luck.

                • 5. Re: CTOS error on Windows 7 OS deployment
                  tdavenport Specialist

                  I've also noticed that you can get this error if you specify an environmental variable in a path without using double %. Since Provisioning identifies variables with single % (ex. %imagepath%, you cannot identify envirnomental variables with single %. When I specified %program files (x86)% in one of my templates, I got a "user variable does not exist" error. Used %%Program Files (x86)%% instead.

                  • 6. Re: CTOS error on Windows 7 OS deployment

                    Thanks Travis! I checked the configtargetOSHandler.log, an error message found "The Client OS is Vista but could not find sysprep file...ConfigargetOSHandler.exe:Could not get provisioning running aafter the fact..."


                    Does it mean something went wrong when the OS was being captured?


                    Attached is the ConfigTargetOSHandler.log file.



                    • 7. Re: CTOS error on Windows 7 OS deployment
                      tdavenport Specialist

                      A couple of questions:


                      1. Is your WinPE image Vista? It should be Win 7.

                      2. Where is your sysprep or unattend file located? You should have it located in C:\Windows\System32\Sysprep or C:\Windows\panther

                         - it should already be in the image or you should be injecting it BEFORE CTOS is injected.

                         - If you choose to inject it, be sure you already have a directory present. My inject Unattend XML is actually just a file copy action.

                         - Here's what mine looks like.



                      3. If you look at the final error in your log, I think this best describes what is happening. "2012-07-04 21:26:57(1684-1656) ConfigTargetOSHandler.exe:Could not get provisioning into the real OS!!"     -  Its looking for unattend.xml and can't find it anywhere. I'm assuming that it needs to insert a line into the unattend.xml in order to get a CTOS agent installed... that's just a guess but that's what it looks like.

                      • 8. Re: CTOS error on Windows 7 OS deployment
                        tdavenport Specialist



                        I just took a second (5th) look at your first screenshot. You may be trying to configure CTOS BEFORE an image is layed down. You're HDD needs to be completely imaged before you can configure CTOS. Notice that my template has CTOS running in the "Post-OS installation" phase. Judging from your screenshot, you're trying to run it in the "Pre-OS installation" phase. It may be somewhere else but the screen shot appears to show that it's running during th the Pre-OS installation phase. Also, I don't know what the secondary partition action is. Is this making changes to the system partition? Here's a full layout of my action list - cut off at the end but you'll get the idea....



                        • 9. Re: CTOS error on Windows 7 OS deployment
                          igs Rookie

                          Thank you so much, Travis! Actually, the issue resolved, and the root cause is I used the wrong unattend.xml file. My case is the Win7 image file is provided by our head office, and they forgot to send us the customized unattend.xml file.


                          But I just got another issue, I have to enter computer name, locale, time and date, etc after CTOS reboot. I assume all this setting can be automated, how can I do it?

                          • 10. Re: CTOS error on Windows 7 OS deployment
                            tdavenport Specialist



                            If you have to enter date / time etc... then your unattend is incomplete or is not being read. How did you build your unattend? Did you use the Windows AIK? An improperly sysprepped image will also exhibit this behaviour. When you run sysprep be sure to use 'generalize' & 'audit'. Don't use OOBE. So to summarize:


                            1. Does your unattend have location, time zone, etc...? - If you don't know, edit it with Windows AIK.

                            2. Where are you injecting the unattend? C:\Windows\System32\Sysprep or C:\Windows\panther?

                            3. How did you sysprep your base machine? -  Be sure to follow the current recommendations on this forum.

                                 a. http://community.landesk.com/support/docs/DOC-23516 -  This is the OSD landing page but it has a good discussion on capturing your image (including sysprep).

                                 b. http://community.landesk.com/support/docs/DOC-23470 - This is the Prov. Landing page and is focuses more on the provisioning toolset than it is on the pre-provisioning set up - use the OSD landing page to focus on the Microsoft side of the image prep.


                            I'm leaning towards an improperly sysprepped image but it could be that you just need to edit your current unattend.xml.

                            1 of 1 people found this helpful
                            • 11. Re: CTOS error on Windows 7 OS deployment
                              igs Rookie

                              Thanks again, Travis! Some prameters on the xml file are missing as well, after the modification with WAIK, the problem solved.

                              • 12. Re: CTOS error on Windows 7 OS deployment
                                tdavenport Specialist

                                Thank you, Igs. Could you mark this discussion as resolved?