6 Replies Latest reply on Aug 30, 2012 12:04 AM by paste88

    winpepds error

    Rookie

      I ceated an OSD Script for capturing my Windows 7 machines.

       

      When i boot into the WinPE Menu everything works great so far. Network drivers are loaded and i get a connection to the core server.

      But after the client gets assigned an IP adress the console shows the following error:

       

      'winpepds' is not recognized as an internal o external command,
      operable program or batch file.
      

       

      After that the console says LANDes Remote Control Service service is starting and the console closes.

      Now I get a window where i can select my OSD Script. After selecting the Script nothing happens. The Script doesn't start.

      I assume this has to do something with the 'winpepds' message mentioned above, or am I wrong?

      Coudn't find much information so far regarding this topip. Please help me out with this.

        • 1. Re: winpepds error
          Frank Wils ITSMMVPGroup

          What version of LANDesk (SP) are you running?

           

          Frank

          • 2. Re: winpepds error
            Rookie

            Hi Frank!

             

            I'm running SP3.

            • 3. Re: winpepds error
              Frank Wils ITSMMVPGroup

              Hi Jens,

               

              In the startnet.cmd it should start this:

               

              CD \ldclient

              winpepds /install

              winpepds /start

               

              Can you verify in your WinPE that the startnet.cmd (in x:\windows\system32) contains these lines and that winpepds actually exists in x:\ldclient

               

              Frank

              • 4. Re: winpepds error
                Rookie

                These lines are in the startnet.cmd.

                But there is no winpepds in x:\ldclient.

                • 5. Re: winpepds error
                  Frank Wils ITSMMVPGroup

                  That's not good... Did you insert a lot of new drivers already in your WinPE? If not, best route to go would be to take the boot.wim file from the LANDesk SP3 Core source files, place it in program files\landesk\managementsuite\landesk\vboot, replacing the file there, and than running osd.upgrade from program files\landesk\managementsuite. When that is finished the boot.wim is stamped with your server information and you can re-deploy your PXE representatives.

                   

                  Alternatively, you can mount the original boot.wim, and copy the file to a mounted boot.wim from the vboot directory. But, who knows what is missing more...

                   

                  Frank

                  • 6. Re: winpepds error
                    Rookie

                    I startet with a new boot.wim from the SP3 and followed the instructions in this article: http://community.landesk.com/support/docs/DOC-24702

                     

                    After running the OSD.upgrade.exe I get an error in the log file:

                    [ ERROR ] C:\Dokumente und Einstellungen\Administrator\Lokale Einstellungen\Temp\imgtmp\new_boot_wim\ldclient\winpepds.exe (Error = 5)

                     

                    Unmount Error: Changes to the Image could not be commited.

                    More Info:

                     

                    Zugriff verweigert (Access denied)

                     

                    08/07/2012 11:16:52 INFO  4984:1     RollingLog : boot.wim config: wim file C:\Dokumente und Einstellungen\Administrator\Lokale Einstellungen\Temp\imgtmp\new_boot_wim unmounted with changes committed

                    08/07/2012 11:16:52 INFO  4984:1     RollingLog : boot.wim config: Removing directory C:\Dokumente und Einstellungen\Administrator\Lokale Einstellungen\Temp\imgtmp\new_boot_wim and contents

                    08/07/2012 11:17:14 INFO  4984:1     RollingLog : OSD Upgrade: System.IO.IOException: Der Zugriff auf den Pfad "C:\Dokumente und Einstellungen\Administrator\Lokale Einstellungen\Temp\imgtmp\new_boot_wim\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup" wurde verweigert. (Access on path "C:\.......\" denied)

                       bei System.IO.Directory.DeleteHelper(String fullPath, String userPath, Boolean recursive)

                       bei System.IO.Directory.Delete(String fullPath, String userPath, Boolean recursive)

                       bei LANDesk.ManagementSuite.OSD.Business.PEImageConfig.BootWim.UnmountWimFile(String path, Boolean commit)

                       bei LANDesk.ManagementSuite.OSD.Business.PEImageConfig.BootWim.UnmountImages()

                       bei LANDesk.ManagementSuite.OSD.Business.PEImageConfig.BootWim.UpgradeImage(String image, Action action)

                       bei LANDesk.ManagementSuite.OSD.Business.PEImageConfig.BootWim.Run()

                       bei OSD.Upgrade.Program.Main(String[] args)

                     

                    Running OSD.upgrade.exe with Admin-Privileges doesn't help.

                    Any ideas?

                     

                     

                    EDIT:

                    I figured out, that Avira AntiVirus recognizes the 'winpepds.exe' as a virus. So if you are using Avira make sure to deactivate it before running the OSD.upgrade.exe.