9 Replies Latest reply on Aug 3, 2012 10:30 AM by jkondas

    No inventory data collected


      Hello Folks,


      I am new to LANDesk, and currently evaluating the LDMS 9.0 SP2 in a simple virtual environment, however it is not a pleasant experience so far. I have been troubleshooting for two days, including a complete reinstall of my test environment.


      After the install, I deployed agents to a variety of operating systems with the first start wizard (Windows 7 Ultimate x86 localized, Windows 7 Ultimate x64 English, Windows Server 2008 R2 SP1 English), and I got stuck, as none of them  report inventory, and do not appear in the All devices node. All of my clients stay in the Pending unmanaged devices node forever.


      The inventory process runs fine on all the clients, but all of the inventory files get into the ldscan\ErrorScan folder on the core server.


      Meanwhile there are several 4100 errors in the Application Event Log:


      Database exception: SCAC81D.SCN, LDInv.dll


      Item cannot be found in the collection corresponding to the requested name or ordinal.

      Insert Table:Processor Column:PROCSERIALNUM, Thread ID: 4680.


      After that, there is always a 4107:


      Successfully connected to the database at 21:12:56, Thread ID: 4536.


      I have tried the following so far:

      - Patch the LANDesk provided SQL 2005 Express to SP4 -> No luck, even after full reinstall of the Core server machine and clients.

      - Omit processor serial number from the inventory. -> Chokes on other attributes, and I did not have the patience to exclude them after a trying a few.

      - Check the size and data type of the attributes in the SQL database, based on the stuff in the inventory scan file. -> Seems to be fine.

      - Connected on the database with sa, and tried to insert the information about the processor manually. -> Worked fine.

      - Moving files from the ErrorScan folder into the ldscan folder. -> Complains about delta inventories, throws the same 4100 for the full inventories. Everything goes back into ErrorScan.

      - Checked the DB Threads and DB Error recovery tries setting, because some KB article recommended it. -> The default value seems to be fine.

      - Searched for fixes to the product, maybe this is a known issue. -> I cannot download SP3, because I do not have a contract... *sigh*


      I am currently out of ideas, and searches don't seem to return anything relevant. I can attach inventory files if needed, but I suppose the problem is with something else.


      Thanks in advance for any thoughts!