6 Replies Latest reply on Sep 21, 2012 8:08 AM by GI3F

    LDSK V9 SP3 HII provisioning FAILED to download the driver.db3 :(

    Rookie

      Hi there,

       

      We have some issue with the HII during provisioning since we patch SP3

       

      Hiiclient.log on WINPE :

       

      source path to download: \\SERVER\PATH\drivers.db3

      dest path for download: c:\Windows\LDDriverStore\drivers.db3

      Failed to download the driver.db3 file - HII will not continue ...

       

      Neither UNC nor HTTP method work at all ...

       

      we try by command line after that fail an X copy from \\SERVER\PATH\drivers.db3 to c:\Windows\LDDriverStore\drivers.db3  ... command line is working ...

       

      anyone have an idea?

        • 1. Re: LDSK V9 SP3 HII provisioning FAILED to download the driver.db3 :(
          Apprentice

          Hi DSI-MICRO,

           

          Did you find a sollution to this issue. I have the same problem.

           

          Regards,

           

          Jan

          • 2. Re: LDSK V9 SP3 HII provisioning FAILED to download the driver.db3 :(
            Tracy Expert

            Did you change/remove your preferred server configuration/credentials for the core server?

             

            -Tracy

            1 of 1 people found this helpful
            • 3. Re: LDSK V9 SP3 HII provisioning FAILED to download the driver.db3 :(
              Apprentice

              Hi Tracy,

               

              The PS was indeed removed and added again, but this did not resolve the problem. The drivers are not located on the core server itsef but on a SAN, this SAN is also used for deploying the images and software. If you connect to the share the DB is there and is accessable. I tested the download via a command line ( HIICLIENT.EXE /UNCPATH=\\server\share with the same result. Without any command line parameters, so with http, it does work. I must bare in mind that I use a redirected virtual directory on my core to point to the SAN to make http download available. The SAN does not have any HTTP capabilities.

               

              Jan

              • 4. Re: LDSK V9 SP3 HII provisioning FAILED to download the driver.db3 :(
                Apprentice

                It might be worth a try, but you could be hitting the issue with the db/core issue where the driver paths are

                incorrectly the wrong way, usally the paths of the files are foldername\drivername, however since the sp3 the issue seemed to be the "\" reversed to "/"

                 

                I had to copy the db3 locally, then use SQLite and run a script

                 

                 

                update inffiles set

                FilePath = replace(FilePath, '/', '\')

                where FilePath like '%/%'

                 

                Save it, rename the old db3 on the core and copy the new "repaired" db3 to the core...

                 

                Just remeber if you update the HII with drivers or just save you have to do this all the time..

                 

                Steve

                • 5. Re: LDSK V9 SP3 HII provisioning FAILED to download the driver.db3 :(
                  Rookie

                  Hi there,

                   

                  Sorry was on holidays,

                   

                  In my case, on provisioning : Neither HTTP or UNC, HIIclient copy the drivers.db3. As Jvhooijdonk drivers are not located on the core server

                   

                  We have already try to change/remove our prefered server... Indeed there is something strange on configuration/credential : we use FQDN

                   

                  HII library credential : I found something about credential witch help me to fix rights issues for the moments ...  http://community.landesk.com/support/message/80334

                  Anonymous access must be granted to be able to build HII library. If there are not access to anonymous HII library credential can't be created ( CF : PreferedServer.jpg )

                  UNC \\SHARESERVERNAME.DOMAINE\PATH\

                  HTTP : http//SHARESERVERNAME.DOMAINE/PATH/

                   

                  delete and recreate Prefered server + test authentification = ok.

                  We only use a Prefered server which is our source and HII library in sametime  but not on CORE !

                  We don't have either any drivers.db3 on the core server.

                   

                   

                  Re: Unauthorized error 401 when configuring HII Driver Repository

                   

                  Steveperks : Is drivers.db3 are necessary on the core server? I just have them on the Prefered Server by the way ...

                  I cheecked on SQL data browser : On Infiles table FilePath seems to be already like  ...\...\

                  by the way we deploy an 7 x 64 bit

                   

                   

                  another information : Os deployed is 7 64bit

                  --------------------

                  OS Major version: 6

                  OS Minor version: 1

                  OS Product type: 1

                  Architecture  is : AMD64

                  source path to download: (try on UNCpath and HTTPpath both don't work try on another deposit = same issue)  

                  dest path for download: c:\Windows\LDDriverStore\drivers.db3

                  Failed to download the driver.db3 file - HII will not continue

                  Failed to get driver files list.

                  ProcessDrivers failed.

                  • 6. Re: LDSK V9 SP3 HII provisioning FAILED to download the driver.db3 :(
                    Rookie

                    Hi there .. I just cheeck my provisioning with HII only task and it's look's like  bugged O_o?

                    No information concerning the HII on my schedule task report  ....  (Post intallation test HII)

                     

                    WINPE : action index=5011 type=HII

                    FAILED

                    error:[80001803H]L'action a échoué. (action failed / error code mean network share isn't ok)

                     

                    CF : HIIOnlyProvisioning .jpg

                     

                    On my main Provisioning template I was cheecking information HII : (UNC or HTTP)

                    action propriety aren't showing anything too...

                     

                    CF : 1MainTemplate.jpg

                     

                    So ? bugg or misconfiguration ?