5 Replies Latest reply on Aug 23, 2012 12:16 PM by Frank Wils

    Script Distribution Package works in Windows XP but ignored in Windows 7

    Rookie

      I have a very simple script to change a registry value.

       

      Set WshShell = CreateObject("WScript.Shell")

      myKey = "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\AutoAdminLogon"

      WshShell.RegWrite myKey,0

       

       

      When I run the script task on a Windows XP machine it runs and the registry value is changed. When I run it on a Windows 7 machine it doesn't do anything, though the console reports that it ran successfully. I think this is some kind of permissions issue with Local System because I've also tried to run another script that sends a message to the currently logged in user and it also works in XP and is ignored in 7.

       

      Notes: Both computers are on the same Domain. I'm using Standard Push as the Delivery Method and I have verified that files are actually downloaded to the cache directory. I've tried running the script manually out the cache directory using pstools and it works as intended. I don't know why it won't run as a task.

       

      Anyone have a clue as to what is going on?

       

      Thanks in advance