5 Replies Latest reply on Sep 10, 2012 8:26 PM by mmalinowski

    How do I cancel a osd WinPE capture executing on a pc




      I have written a OSD WinPE capture script that works well on a Lenovo MT-M4518-G4M running Windows 7 64 bit.


      I then tried the same script on a Lenovo MT-M4223-B17. The difference being, the Lenovo MT-M4223-B17 has an array.

      When the capture runs on the PC, the driver etc load and then I get a message "There is no partition", followed by "Disk 0 is now selected".

      According to the Scheduler in LANDesk, this has completed successfully. But that is not the case.


      How do I stop the pc trying to do a WinPE capture when it reboots?




        • 1. Re: How do I cancel a osd WinPE capture executing on a pc



          I have a pc with and image I am trying to capture. The script worked on a different type (both Win 7) , the difference is this one has Windows 7 installed on an Adaptec array.


          When you boot the pc to be captured, it automatically kicks off the Landesk agent , which inturns starts up WinPE.  I want to cancel this task completely. I have tried disabling the PXE boot on the pc, but that did not help.

          What do I need to do to stop the disk capture from running?




          • 2. Re: How do I cancel a osd WinPE capture executing on a pc

            Further info...As you can see from the log below, LANDesk is under the impression it had successfully completed the capture. But it had not.



            "MTM4223B17-W7","OK",0,0:00:06,4/09/2012 10:29:00 AM,4/09/2012 10:29:06 AM,"<qt/>C:\Program Files (x86)\LANDesk\LDClient\sdclient.exe<qt/> /f /o /p="http://.../landesk/vboot/bootfile.exe""

            "MTM4223B17-W7","OK",0,0:00:06,4/09/2012 10:29:06 AM,4/09/2012 10:29:12 AM,"<qt/>C:\Program Files (x86)\LANDesk\LDClient\sdclient.exe<qt/> /f /o /p="http://.../landesk/vboot/tlibr16.dll""

            "MTM4223B17-W7","OK",0,0:00:06,4/09/2012 10:29:12 AM,4/09/2012 10:29:18 AM,"<qt/>C:\Program Files (x86)\LANDesk\LDClient\sdclient.exe<qt/> /f /o /p="http://.../landesk/vboot/tlibr32.dll""

            "MTM4223B17-W7","OK",0,0:00:06,4/09/2012 10:29:18 AM,4/09/2012 10:29:24 AM,"<qt/>C:\Program Files (x86)\LANDesk\LDClient\sdclient.exe<qt/> /f /o /p="http://.../landesk/vboot/lddefrag.exe""

            "MTM4223B17-W7","OK",0,0:00:06,4/09/2012 10:29:24 AM,4/09/2012 10:29:30 AM,"<qt/>C:\Program Files (x86)\LANDesk\LDClient\sdclient.exe<qt/> /f /o /p="http://.../landesk/vboot/FlushBuffer.exe""

            "MTM4223B17-W7","OK",0,0:00:06,4/09/2012 10:29:30 AM,4/09/2012 10:29:36 AM,"<qt/>C:\Program Files (x86)\LANDesk\LDClient\sdclient.exe<qt/> /f /o /p="http://.../landesk/vboot/cicfgmgr.vxd""

            "MTM4223B17-W7","OK",0,0:00:06,4/09/2012 10:29:36 AM,4/09/2012 10:29:42 AM,"<qt/>C:\Program Files (x86)\LANDesk\LDClient\sdclient.exe<qt/> /f /o /p="http://.../landesk/vboot/cindis.vxd""

            "MTM4223B17-W7","OK",0,0:00:05,4/09/2012 10:29:42 AM,4/09/2012 10:29:47 AM,"<qt/>C:\Program Files (x86)\LANDesk\LDClient\sdclient.exe<qt/> /f /o /p="http://.../landesk/vboot/copyfile.exe""

            "MTM4223B17-W7","OK",0,0:00:09,4/09/2012 10:29:47 AM,4/09/2012 10:29:56 AM,"<qt/>C:\Program Files (x86)\LANDesk\LDClient\sdclient.exe<qt/> /f /o /p="http://.../landesk/vboot/boot.img""

            "MTM4223B17-W7","OK",0,0:00:05,4/09/2012 10:29:57 AM,4/09/2012 10:30:02 AM,"<qt/>C:\Program Files (x86)\LANDesk\LDClient\sdclient.exe<qt/> /f /o /p="http://.../landesk/vboot/ChangeBCD.exe""

            "MTM4223B17-W7","OK",0,0:00:06,4/09/2012 10:30:02 AM,4/09/2012 10:30:08 AM,"<qt/>C:\Program Files (x86)\LANDesk\LDClient\sdclient.exe<qt/> /f /o /p="http://.../landesk/vboot/BCD""

            "MTM4223B17-W7","OK",0,0:00:06,4/09/2012 10:30:08 AM,4/09/2012 10:30:14 AM,"<qt/>C:\Program Files (x86)\LANDesk\LDClient\sdclient.exe<qt/> /f /o /p="http://.../landesk/files/bcdedit.exe""

            "MTM4223B17-W7","OK",0,0:00:01,4/09/2012 10:30:14 AM,4/09/2012 10:30:15 AM,"<qt/>C:\Program Files (x86)\LANDesk\LDClient\ChangeBCD<qt/> <qt/>C:\Program Files (x86)\LANDesk\LDClient\bcdedit.exe<qt/> <qt/>C:\Program Files (x86)\LANDesk\LDClient\BCD<qt/>"

            "MTM4223B17-W7","OK",0,0:01:00,4/09/2012 10:30:15 AM,4/09/2012 10:31:15 AM,"<qt/>C:\Program Files (x86)\LANDesk\LDClient\sdclient.exe<qt/> /f /o /dest="C:\boot.wim" /p="http://.../landesk/vboot/boot.wim""

            "MTM4223B17-W7","OK",0,0:00:00,4/09/2012 10:31:15 AM,4/09/2012 10:31:15 AM,"<qt/>C:\Program Files (x86)\LANDesk\LDClient\copyfile.exe<qt/> <qt/>C:\Program Files (x86)\LANDesk\LDClient\boot.img<qt/> <qt/>C:\Program Files (x86)\LANDesk\LDClient\BCD<qt/> \boot\BCD"

            "MTM4223B17-W7","OK",0,0:00:25,4/09/2012 10:31:15 AM,4/09/2012 10:31:40 AM,"<qt/>C:\Program Files (x86)\LANDesk\LDClient\lddefrag.exe<qt/> <qt/>C:\Program Files (x86)\LANDesk\LDClient\boot.img<qt/>, STATUS"

            "MTM4223B17-W7","OK",0,0:00:09,4/09/2012 10:31:40 AM,4/09/2012 10:31:49 AM,"<qt/>C:\Program Files (x86)\LANDesk\LDClient\FlushBuffer.exe<qt/>, STATUS"

            "MTM4223B17-W7","OK",0,0:00:00,4/09/2012 10:31:49 AM,4/09/2012 10:31:49 AM,"<qt/>C:\Program Files (x86)\LANDesk\LDClient\bootfile.exe<qt/> C:\Program Files (x86)\LANDesk\LDClient\boot.img /keep /bootunsafe, ASYNC"

            "MTM4223B17-W7","OK",0,0:04:20,4/09/2012 10:31:49 AM,4/09/2012 10:36:09 AM,"WINPE, TIMEOUT=1800"

            "MTM4223B17-W7","OK",5,0:00:01,4/09/2012 10:36:09 AM,4/09/2012 10:36:10 AM,"diskpart /s X:\LDClient\rmvol.txt"

            "MTM4223B17-W7","OK",230227968,0:00:15,4/09/2012 10:36:10 AM,4/09/2012 10:36:25 AM,"ldrun drvmap.exe prc\mmadmin 1084E495BF7B6710B891F217A05 I: """\\vlandesk9.prc.local\PRC_Landesk_Files""", STATUS FACILITY=3513"

            "MTM4223B17-W7","OK",230227968,0:00:01,4/09/2012 10:36:25 AM,4/09/2012 10:36:26 AM,"ldrun drvmap.exe prc\mmadmin 1084E495BF7B6710B891F217A05 H: """\\vlandesk9.prc.local\ldmain""", STATUS FACILITY=3513"

            "MTM4223B17-W7","OK",0,0:00:02,4/09/2012 10:36:26 AM,4/09/2012 10:36:28 AM,"ldrun sdclient /f /o /dest="X:\LDClient\assvol.txt" /p="http://.../landesk/files/assvol.txt", STATUS"

            "MTM4223B17-W7","OK",0,0:00:00,4/09/2012 10:36:28 AM,4/09/2012 10:36:28 AM,"ldrun tokreplw X:\LDClient\assvol.txt partition=2"

            "MTM4223B17-W7","OK",2,0:00:11,4/09/2012 10:36:28 AM,4/09/2012 10:36:39 AM,"diskpart /s X:\LDClient\assvol.txt"

            "MTM4223B17-W7","OK",1,0:00:00,4/09/2012 10:36:39 AM,4/09/2012 10:36:39 AM,"cmd /c del /f /q C:\boot.wim"

            "MTM4223B17-W7","OK",17,0:00:02,4/09/2012 10:36:39 AM,4/09/2012 10:36:41 AM,"ldrun H:\osd\IMAGEW~1\imagew.exe /b /uy /d:0 /rb:0 /max:2GB /f:"""i:\OSD_IM~1\MTM4223B17-W7""""

            "MTM4223B17-W7","OK",1073807364,0:00:00,4/09/2012 10:36:41 AM,4/09/2012 10:36:41 AM,"ldrun reboot, timeout=2"

            ; "Job Complete","1 Done","0 Failed","0 Off","0 Unknown"

            • 3. Re: How do I cancel a osd WinPE capture executing on a pc



              The last messages on the console are


              The LANDesk Remote Control service was started successfully.


              Then the cmdbox diissapears and I am left with the blue LANDesk screen and the  Green button( Restart pc or open a cmd window option)




              • 4. Re: How do I cancel a osd WinPE capture executing on a pc

                Is anyone actually monitoring these posts?

                • 5. Re: How do I cancel a osd WinPE capture executing on a pc



                  I evetually went into DiskPart and changed the active disk and consequently the MBR. I was then able to boot in normally.