1 Reply Latest reply on Sep 25, 2012 5:26 AM by Gjstewart

    System Variables not working in Templates???

    Gjstewart Specialist

      Hi I have come across and issue and its quite urgent so if anyone else has a fix i would appeciate it!

       

      To my understanding you can use a SYSTEM variable in a template by simply using

       

      %%Variable%%

       

      All i keep getting is the system variable is not recognised.

       

      The variable is in the right Case - so its not that.

       

      I have a variable on the machine which contains the preferred server and i want to use it in a Map Drive action in my template . Why is this simple task not working!

       

      All details are correct it simply wont see the variable

       

      using

       

      \\%%Variable%%\Share

       

      Any ideas?

        • 1. Re: System Variables not working in Templates???
          Gjstewart Specialist

          In addition i have tried pulling from Database value - which i dont want to do but thought i would test it.. ( because the machine would have to scan again to pick it up.... )

           

          So i have a template variable with correct

           

          Environment.Variable.PREFSERVER

           

          And i call this with %PREF% in the template.

           

          And i get error 53 - which speciies a NETBIOS problem with the path so i tried Servername.FQDN -

           

          then the IP of the server

           

          I dont get environment variable not recognised as its using a LANDesk variable now. .But it still will not work. Error 53.

           

          This is getting silly LANDesk.. How can i use a system variable in my template successfully!