5 Replies Latest reply on Sep 28, 2012 7:15 AM by Jamie Cannon

    WebAccess displaying of query results

    Jamie Cannon ITSMMVPGroup

      Maybe I'm missing something here..so I'm hoping someone will have an answer.

       

      On my Incident form I have the "Attachments" collection added and there is a query that shows the attachment information.  Now, in console I have added 4 columns in a specific order A B C D and everything looks fine.  However, when I view this collection in Web Access the columns show up as B D C A.

       

      The columns are:

       

      A .Attachment.Title

      B. Attachment.CreationDate

      C. Incident.ReferenceNumber

      D. Attachment.CreatedBy.Title

       

      Any thoughts on this?

        • 1. Re: WebAccess displaying of query results
          ITSMMVPGroup

          WebDesk should be using the default query for that object to display the results, so that is work a check (that you have one and not more than one default query of the same name).  There was a bug in webdesk at one point which caused it to display attributes in the order they were added into the query rather than the order they displayed.  IF that is the issue you have to rewrite the query and make sure you drop them on in the order you want them to be dsplayed.

          • 2. Re: WebAccess displaying of query results
            Jamie Cannon ITSMMVPGroup

            Thanks Dave.  I did verify it's the correct default query.  I also thought maybe it was alphabetical and then I did try to add them in the order I wanted them to show.  It was doing fine until I added the Incident.ReferenceNumber.  At that point, it put that first and moved the other over.  Could it be because I pulled in the main object (Incident)?

            • 3. Re: WebAccess displaying of query results
              Stu McNeill Employee

              Hi Jamie,

               

              This is a slight oddity with Web Access that is logged as problem 5212.  The order used will be the order the columns were added to the query.  In the query definition there is an index number set for each column to identify it and this is what is used in Web Access.  However there is another index called Display Index that gets changed when you re-arrange the columns and is what Console uses (and Web should use but doesn't) which is when you can see the inconsitency.

               

              The solution is to create a new query from scratch, add the columns in the order you want them to be displayed in then never re-arrange them.  Oh and contact Support to have your report of the issue added to the problem.

               

              Thanks

              1 of 1 people found this helpful
              • 4. Re: WebAccess displaying of query results
                Jamie Cannon ITSMMVPGroup

                Is there somewhere in the database where I can see what index was appied? 

                • 5. Re: WebAccess displaying of query results
                  Jamie Cannon ITSMMVPGroup

                  I was able to find it in the database and change the index numbers (md_index) was the column.  This fixed it.  I had tried creating it again from scratch but it gave me the same result.  Anyhow, thanks for the info.. that pointed me in the right direction.  Thanks Stu.