5 Replies Latest reply on Oct 12, 2012 3:46 PM by TroyJ

    HII Drivers are not Deployed

    Rookie

      I’m trying to get the HII component of OSD working.  I created the Preferred server and added all the drivers needed.  I modified a working deployment script by checking the “Use Hardware independent imaging (HII)” checkbox.  After PXE booting and running the deploy script, the progress bar shows the image deploys, but the computer does not reboot.  I will force the system off and boot it up and Windows 7 runs through the setup but system manager shows missing drivers.  I have tried using the default http: and UNC to copy driver files.

       

      If I run the deploy again and don’t force the system off after the image has been deployed but try to read the WinPE log at X:\windows\system32\HIIClient.log I can’t because the log was not created or is not in this location.  I’m stuck here.  Any of you have some troubleshooting tips for me?

        • 1. Re: HII Drivers are not Deployed
          Apprentice

          Can you give the Landesk version and Service Pack?, depending on version and service pack the difference is a lot..

           

          Steve

          • 2. Re: HII Drivers are not Deployed
            MarXtar ITSMMVPGroup

            Also, if the image has deployed but the machine doesn't reboot then odds are something failed. What does the console say the result is? Can you right-click the machine in the task and view the log? I assume you are using OSD rather than provisioning at this stage? I'm thinking something is failing before it reaches the HII stage.

             

            Mark McGinn

            MarXtar Ltd

            http://landesk.marxtar.co.uk

            LANDesk Silver ESP

             

            The One-Stop Shop for LANDesk Enhancements

            - Wake-On-WAN - Distributed Wake-On-LAN, Scheduled Power Down, and SWDist Sequencing

            - State Notifier - Real-Time Device & User State Inventory Updating & Alerting

            Update - WoW & State Notifier now integrate for even more functionality

            Update - State Notifier now detects machine and user Idle states

            • 3. Re: HII Drivers are not Deployed
              Rookie

              SteverPerks... I should have included my version. We are on LANDesk 9 SP3. So much of the info I have found is on previous versions...

               

              Mark... I don't understand how to find the log in the Management Console. I am deploying with PXE so I PXE boot the system and select the script in WinPE that I want to run. The system does not have a name on the network yet because the image has just been deployed and the minisetup has not run yet...

              • 4. Re: HII Drivers are not Deployed
                Apprentice

                Hi Troy

                 

                The HII deployment of drivers has changed in SP 3, there is a know issue to do with the db3 file. When the drivers are saved and written to the db3 the path names are reversed so server\driver becomes server/driver "/" is the wrong way and HII will fail everytime...there is a workaround, you have to do this everything you save files....

                 

                Do this, Copy the drivers.db3 locally to a machine, download SQLite database browser.got to Excute SQL

                 

                then open the database and run the following script in SQL String and run.

                 

                update inffiles set

                FilePath = replace(FilePath, '/', '\')

                where FilePath like '%/%'

                 

                then copy back the driver.db3 (rename the one on the core first to a backup)

                 

                Then run a job again. HII should work now..

                 

                Steve

                • 5. Re: HII Drivers are not Deployed
                  Rookie

                  I had some other issues that were preventing a good image deployment.  Once those were take care of the above SQLite fix was what was needed.  Thanks steveperks, you’re a ROCKSTAR!