4 Replies Latest reply on Apr 29, 2008 4:46 AM by zman

    Restarting Deployment for Task in Deployment portal

    Rookie

      Does anyone know how I can restart a task that is marked as processing in the Deployment portal?

       

      I started the task, during downloading the network was lost and the system rebooted. I checked in sdmcache and the distribution set is not complete (pending file download). Now the download wont finish. How can I force the Deployment to continue downloading the files it needs?

       

       

      LanDesk 8.8 (No SP )

       

       

      Windows XP client (SP2)

        • 1. Re: Restarting Deployment for Task in Deployment portal
          Expert

           

          You should not have to do anything at all... it should pick up where it left off. But I have seen a few cases where the client/core got confused and stayed in the state you are seeing... So first remove the parital@@  file from the Cache and try it again... If that does not work remove the entry for the task from the local policy cache on the client...

           

           

          [HKEY_LOCAL_MACHINE\SOFTWARE\INTEL\LANDesk\LDWM\AppHealing\Agent\AMClient\APM\PolicyCache\

           

           

          • 2. Re: Restarting Deployment for Task in Deployment portal
            zman Master

            I think he is running 8.8.

             

             

            From Tracy

             

             

            1. rename or delete C:\Documents and Settings\All Users\Application Data\LANDesk\ManagementSuite\Database\ LDClientDB.db3

             

             

            2. run C:\Program Files\LANDesk\LDClient\clientdbutil.exe /validate

             

             

            3. run C:\Program Files\LANDesk\LDClient\policy.sync.exe

             

             

            4. wait a few minutes (all policies will not show up immediatley)

             

             

            5. check the policy.sync.log. It should indicate downloaded policies

             

             

            6. run policy.client.invoker.exe (any required policies should process). If not,look at the invoker error log. If any errors exist, bounce the invoker service.

            • 3. Re: Restarting Deployment for Task in Deployment portal
              Rookie

              Thanks zman and RickDavie,

               

              I had already tried to delete the partial@@ file but not delete anything from the registry and that had not worked.

               

               

                The registry key indicated by RickDavie does not exist on the client.  In fact No PolicyCache entry at all in the registry. 

               

               

               

              I have followed zman's procedure. The policy.sync.log does show downloaded policies but nothing shows up in the Portal.

               

               

              Running policy.client.invoker.exe does not seem to do anything, checking the log shows 3 new entries:

               

               

                   Tue, 29 Apr 2008 09:19:09 3176: Policy Invoker version 8.80.0.249 was launched
                   Tue, 29 Apr 2008 09:19:09 3176: Windows Platform 2, version 5.1 Service Pack 2
                   Tue, 29 Apr 2008 09:19:09 3176: Could not start ctrl dispatcher (0x00000427, 1063)

              Checking the services on the client, there is no invoker service. Which service do you mean?

              • 4. Re: Restarting Deployment for Task in Deployment portal
                zman Master

                 

                The registry keys only exist pre 8.8. 

                 

                 

                So on your client you indicate that you don't have a LANDesk Policy Invoker service on the client? If this is true then I would reinstall the client.

                 

                 

                1 of 1 people found this helpful