3 Replies Latest reply on May 15, 2013 5:41 AM by jwwtss

    Error when sorting in query

    Apprentice

      I have a query that is designed to search for multiple criteria for an incident.  The search and sorting work fine for all fields except for one.  The field is the incident status title.  When sorting by this field I receiving the following error.

       

      There has been an unexpected error. Click Continue to return to the previous page.

      Invalid column name 'T1_lc_title'.

       

      The field name itself is lc_title so I am not sure why it is appending the T1_ to the field when trying to sort.

       

      Any help is appreciate.

       

      Thanks,

      jake

        • 1. Re: Error when sorting in query
          Rookie

          We get this same error when using status.title and need to use the name field instead but this is not ideal as there is no spaces in the name field so In Progress is InProgress.

          • 2. Re: Error when sorting in query
            Jamie Cannon ITSMMVPGroup

            I had a similar issue with a different column in the past and this was the resolution provided:

             

             

            Invalid column name 'T15_im_parent_guid'.


            Resolution: Advised  to run the update statement on article http://community.landesk.com/support/docs/DOC-26456 to set the tps_culture column in the tps_user table to Null.

            This is the update statement. 


            update tps_user set tps_culture = NULL where tps_culture <> NULL

             

            Version 7.5 SP1 should have addressed this type of issue.  What version are you on?

            • 3. Re: Error when sorting in query
              Apprentice

              Thanks.

               

              Shiny, I'm waiting to hear back from my co-worker to see if this solved the issue. 

               

              Jamie, that was the original response I received from LANDesk support but that did not resolve the issue for our analysts.  The issue doesn't always happen on the administrator role but I have seen it a few times. 

               

              We are running 7.5 SP1.  It is only on one query that we are experiencing the issue and it was an OOTB query.  Even after I tried to recreated the query the error still appeared.