1 2 Previous Next 18 Replies Latest reply on Aug 1, 2013 10:37 AM by Northice

    LD 9.5 Mac Remote Control not working with 10.8.2

    Apprentice

      We are testing out LD 9.5, and we have Mac 10.8.2 clients.

       

      Inside the LANDesk GUI on the client, it shows the LD Remote Control as running, but if I do a netstat, I don't see the computer listening on 9535, and I cannot remote control the computer.

       

      On the client in the system log, I see the following:

      Dec  7 10:25:44 ntidallenmac8.main.ad.rit.edu com.apple.SecurityServer[15]: Succeeded authorizing right 'system.privilege.admin' by client '/Library/Application Support/LANDesk/bin/ldremote' [70] for authorization created by '/Library/Application Support/LANDesk/bin/ldremote' [70] (2,0) Dec  7 10:25:44 ntidallenmac8.main.ad.rit.edu com.apple.SecurityServer[15]: Succeeded authorizing right 'system.privilege.admin' by client '/usr/libexec/security_authtrampoline' [168] for authorization created by '/Library/Application Support/LANDesk/bin/ldremote' [70] (3,0) Dec  7 10:25:44 ntidallenmac8.main.ad.rit.edu authexec[168]: executing /Library/Application Support/LANDesk/bin/ldremotemenu.app/Contents/MacOS/ldremotemenu

      Dec  7 10:25:44 ntidallenmac8.main.ad.rit.edu ldremotemenu[168]: 3891612: (connect_and_check) Untrusted apps are not allowed to connect to or launch Window Server before login.

      Dec  7 10:25:44 ntidallenmac8.main.ad.rit.edu ldremotemenu[168]: kCGErrorFailure: This user is not allowed access to the window system right now.

      Dec  7 10:25:44 ntidallenmac8.main.ad.rit.edu ldremotemenu[168]: _RegisterApplication(), FAILED TO establish the default connection to the WindowServer, _CGSDefaultConnection() is NULL.

      Dec  7 10:25:44 ntidallenmac8.main.ad.rit.edu ldremotemenu[168]: kCGErrorInvalidConnection: CGSGetEventPort: Invalid connection Dec  7 10:25:44 ntidallenmac8.main.ad.rit.edu ldremotemenu[168]: CGSRegisterConnectionNotifyProc called with invalid connection Dec  7 10:25:44 ntidallenmac8.main.ad.rit.edu ldremotemenu[168]: kCGErrorInvalidConnection: CGSGetEventPort: Invalid connection Dec  7 10:25:44 ntidallenmac8.main.ad.rit.edu ldremotemenu[168]: kCGErrorInvalidConnection: CGSSetConnectionProperty: Invalid connection Dec  7 10:25:44 ntidallenmac8.main.ad.rit.edu ldremotemenu[168]: kCGErrorInvalidConnection: Error enabling suspendResume handling Dec  7 10:25:45 ntidallenmac8.main.ad.rit.edu ldremote[70]: 3891612: (connect_and_check) Untrusted apps are not allowed to connect to or launch Window Server before login.

      Dec  7 10:25:45 ntidallenmac8.main.ad.rit.edu ldremote[70]: kCGErrorFailure: This user is not allowed access to the window system right now.

      Dec  7 10:25:45 ntidallenmac8.main.ad.rit.edu ldremote[70]: CGSGetDisplayBounds: Invalid display 0x00000000

       

      Any thoughts?

       

      Thanks

        • 1. Re: LD 9.5 Mac Remote Control not working with 10.8.2
          Northice Expert

          Allen,

           

          9.5 remote control is based on our new HTML 5 technology which uses port 4343 instead of the older port 9535.  Also, based on some of the output messages, I'm wondering if the machine you're trying to remote control has a logged in user or not.  Currently, the remote control service on the Mac only executes within a user session.  If the machine is sitting at a login prompt, you won't be able to remote control it.  This is an item that is in our backlog to work on.

           

          Lastly, we are currently working on a few bug fixes for remote control and hope to have an update to the 9.5 Mac agent made available next week.

           

          Bennett

          • 2. Re: LD 9.5 Mac Remote Control not working with 10.8.2
            Apprentice

            I can confirm that the device is in fact logged in with a user, but logged in or out, does not seem to make any difference.  I also applied the new Mac release, but no change.  Any other information I could provide that might assist in tracking down the problem?  When I put this back to a 9.0 SP3 install/enviornment, I am able to remote control it.

            • 3. Re: LD 9.5 Mac Remote Control not working with 10.8.2
              Frank Wils ITSMMVPGroup

              "Lastly, we are currently working on a few bug fixes for remote control and hope to have an update to the 9.5 Mac agent made available next week."

               

              Was this update ever released? It doesn't seem to be in the 9.5 Sustainable patch information...

               

              Frank

              • 5. Re: LD 9.5 Mac Remote Control not working with 10.8.2
                Alex.Richardson SSMMVPGroup

                Can you confirm if this patch will resolve the RC issues with the 9.5 Mac agent?

                • 6. Re: LD 9.5 Mac Remote Control not working with 10.8.2
                  Rookie

                  RC issue is not resolved with this patch. We have applied this patch last week...

                  • 7. Re: LD 9.5 Mac Remote Control not working with 10.8.2
                    Rookie

                    Is there a new status/info, and bug list for the Mac LD 9.5 agent in regards to OS 10.8.2? I need to update our agent on the new workstations I think (the 'About' window of the 'new' one I was given says 9.0.0 - booooo, and it won't inventory scan) It should say 9.5, yes? (any exact versions in that window to share?) I can control the workstation until I log out....then it freezes my RC window.

                    • 8. Re: LD 9.5 Mac Remote Control not working with 10.8.2
                      Apprentice

                      "Currently, the remote control service on the Mac only executes within a user session.  If the machine is sitting at a login prompt, you won't be able to remote control it.  This is an item that is in our backlog to work on."

                       

                      Is there any work around for this issue?  I have a mac mini (netboot server)  I need to remote into and cannot because its not logged in.. Any patch or workaround that fixes this..  does anyone have a package that will auto logon a user.. I ned to push this as I dont have physical access to the device.  If I would have known this I would have put logme in on it. 

                      • 9. Re: LD 9.5 Mac Remote Control not working with 10.8.2
                        csoto Specialist

                        This will help:

                         

                        http://osxadmin.blogspot.com/2007/04/enable-auto-login-via-command-line.html

                         

                        Note that it employs a clever workaround for the fact that you need an encrypted password stored - create it on a different machine, then deploy the file.  It should work in your situation.  Good luck!

                        • 10. Re: LD 9.5 Mac Remote Control not working with 10.8.2
                          Specialist

                          Any update to this for the SUMMER 2013?

                           

                          I have 10.8.2 clients whose RC option is not available as described above.  I found a document which describes a way to enable HTML remote control on the Mac but I have not gotten it to work because the Doc does not accurately describe how to configure the HTML RC.

                           

                           

                          the HTML REMOTE CONTROL piece called out in this document:

                           

                          http://help.landesk.com/Topic/Index/ENU/LDMS/9.5/Content/Windows/rc_o_html.htm

                           

                          is in fact not accurate as of 7/26/13

                           

                          it states the following sequence is necesssary to configure the HTML settings for RC:

                           

                          "

                          To enable HTML remote control
                          1. Click Tools > Configuration > Agent configuration.
                          2. Double-click the agent configuration you want to modify.
                          3. On the Remote control page, click Configure.
                          4. Select the remote control settings configuration that you want to modify, and then click Edit.
                          5. On the general settings page, select Allow HTML access.
                          6. Click Save and exit the dialogs.
                          7. Redeploy the agent configuration you modified to managed devices.

                          "

                           

                          In a LDMS 9.5 installation with the Mac-2012-1206-9.5.0.635 Patch applied, there are NO RC settings provided in the MAC agent configuration. So line 4 above is not available.  The option is certainly available for WINDOWS agents, but NOT for Mac agents.

                           

                          I'm not sure how to enable this RC support on the Mac if the required settings are not available for configuration.

                           

                           

                           

                          I understand that Apple has updated the os to 10.8.4 as of June 2013; thinking of updating my clients and retrying.

                          • 11. Re: LD 9.5 Mac Remote Control not working with 10.8.2
                            Northice Expert

                            The Mac agent as of 9.0 SP3 only supports HTML RC, therefore there is no checkbox to check.  You should be able to perform a remote control session on 10.8.2.  You can see if 9.5 SP1 helps you, as we made some changes to the certificate process to help with DNS resolution issues some people were seeing in their environment.  It may be worth a shot.  Otherwise, I would open a ticket with support.

                            • 12. Re: LD 9.5 Mac Remote Control not working with 10.8.2
                              Specialist

                              @ Northice,

                               

                              Considering that the instructions I quoted above came under the document titled "LANDesk Management Suite 9.5", I am currious why the the descrepancy and I'd like to ask is there a different document which contains accurate instructions for how to use this product?  If not, is Landesk committing any resources to shoring up deficits within their product documentation?

                               

                              While I should be able to use RC, as you describe, infact I am unable to do so.  I am going to apply some OS updates and see if this feature will work on updated systems.  I can confirm that these machines have no DNS issues as far as I can tell; communication seems good and reliable across the board.

                               

                              I won't be applying SP1 to 9.5 because I am afraid that it will break something else.  I only got 9.5 working last month and was able to test and prove that most of the important things are working.  I am currently rolling out new images for my entire organization and have only a few weeks to complete and certify that work; I don't have any wiggle room to deal with fallout from the SP1 patch.  I am currently working on the macs and noticed the RC didn't work...disappointing, again.

                              • 13. Re: LD 9.5 Mac Remote Control not working with 10.8.2
                                Rookie

                                We are moments from deploying this to our new load of iMacs even though I know it's not going to function. I've always kept Apple Remote Desktop enabled so that I can at least get to my machines and do things manually if I have to. We have a huge inventory, and I'm greatly frustrated that the mac components are such a low priority and investment level. Very unfortunate.

                                Thanks AspenSkier for your comments above. Well said and appreciated.

                                • 14. Re: LD 9.5 Mac Remote Control not working with 10.8.2
                                  Specialist

                                  @Jill,

                                   

                                   

                                  I manually updated a few of our iMacs to 10.8.4 and after running an inventory scan with the landesk agent I am now able to launch the HTLM remote control...read on because it still doesn't work.

                                   

                                  HTML-RC-MAC1084.JPG

                                   

                                  Sadly, when I do this I get yet another login window on the remote machine.  The LDMS 9.5 console passes no credentials to the Mac client for the RC.  It is a somewhat slow proces working in the 9.5 console anyway due to the latency problems with agent status refresh, but now it is worse because once you get a RC session started you have to reauthenticate to get it to go.

                                   

                                  So once I get through the authentication process I am staring at the Landesk RC but the window contents are blank.  That is right; I can't see anything on the remote computer.

                                   

                                   

                                  on another note, since you likely have more experience with the macs than I do, would you kindly have a look at this post that has remain unanswered:

                                   

                                  http://community.landesk.com/support/message/92562#92562

                                  1 2 Previous Next