4 Replies Latest reply on Feb 27, 2013 5:43 PM by trevorbrosnan

    Error 2869 Windows Server 2008 - All previous help did not work

    Rookie

      I am trying to install the LanDesk 7.3 on a test enviroment windows server 2008 r2 in preparation of an upgrade but I am getting the Error 2869 just before it finishes its install. I have tried the following as highlighted in the forums:

      Have Application, File and WebServer Roles installed with all options
      IIS 6 Compatability installed with roles
      Checked the Touchpaper Software reg key is in the Wow6432Node sub folder
      Installed as administrator (command prompt and rightclick)
      Logged on as a local domain
      ran the aspnet_regiis -i command

      But I still recieve the 2869 error


      I have looked through the forums (and tried every suggestion) and I cant find anything to aid me in my progress. I have tried install all parts of LanDesk and mostly only the Application Server. On each unsucessful install I have removed the touchpaper Services (by the sc command and manually) and even on occasion I have removed the roles and readded them. Am I missing any other dependencies besides the Roles?

       

       

      landesk.PNG

        • 1. Re: Error 2869 Windows Server 2008 - All previous help did not work
          dmshimself ITSMMVPGroup

          I share your pain :-(  We have found that once you have got one of these errors, it is best to go back to a snapshot prior to doing any part of the LDSD  installation.  In my own mind something is left lying around by the installer which will give you trouble later on, so it's best to not work around it.  So for example we had an installation which exhibited this issue, worked round it and then found with a later version upgrade the installer for the more up to date version got into an even worse state.  Don't work round it now, but try and get a clean install.

           

          The steps I'd add if I were doing this are ..

           

          1. Add some more roles before the base install - the enclosed picture shows the one I have used for some time.

          2. Allow web.config to be updated by the installer

          %windir%\system32\inetsrv\appcmd.exe unlock config -section:system.webServer/handlers

          3. Don't just run as an administrator.  Do this as the actual local computer administrator account.  I've had an install fail with a user that was part of the local machine administrator group, but which worked when using the actual administrator account.  Go figure!

          4. Don't do a right hand click run as.  Login as the local administrator, switch your path to the installation  folder and run that way

          5. Run the pre-requisites for 7.3 FIRST one at time via the MSI files. So 64 bit crystalreports 10.5, ditto CrystalReports11 runtime, ditto dotnetfx35, WSE 2 SP3, vsharp.  Do a snapshot before each one and restore back to that if any fail.  Don't try and fix it up.

          6. After the .NET install ALWAYS reboot, even if you are not invited too.

          7. Only when all the pre-reqs are in and a final snapshot done would I attempt to run the setup file.  In fact if you have all the pre-reqs in, you can run the .MSI itself

           

          I'd also get yourself up to at least 732.  I'm not sure if that is actually supported at the moment, but 732 is heaps better than 7.3.  Ideally also get yourself up to 75SP1 at some point soon.

          • 2. Re: Error 2869 Windows Server 2008 - All previous help did not work
            John Stuart-Robson Employee

            Hello,

             

            Just adding to what Mr Dms has added. I seem to recall that if you did not have the IIS 6 comparability pack installed as part of the IIS role you would get this error.  Certainly with the 7.3 releases.  Try installing this as part of your IIS role as well.

             

            Thanks

            1 of 1 people found this helpful
            • 3. Re: Error 2869 Windows Server 2008 - All previous help did not work
              Rookie

              Thank you so much for the Replies will keep ye updated on the progress, I have a snapshot done of the clean state so will try all these suggestions

              • 4. Re: Error 2869 Windows Server 2008 - All previous help did not work
                Rookie

                Did as follows and it works now, one additional thing was to include the touchpaper software key which I previously had done and now I can install on Server 2008 Thanks for the help