5 Replies Latest reply on Apr 13, 2014 8:58 PM by LANDave

    System/Profile Migration

    Rookie

      I'm trying to add profile migration to my master prvovisioning template that I have been using for months and already works pretty much flawlessly. I have tried using the new Profile Capture action in 9.5 but it fails every time. I have also tried using the templates from here http://community.landesk.com/support/docs/DOC-9459.I have included these templates in my master template and the profile capture works fine and then when it gets to the map image tool section of my master template it fails saying that a variable does not exist. This is a variable that I defined in the public variables long ago and if I remove the profile capture and run my master template alone without making any other changes it works fine. I also get the variable does not exist error if I leave the restore template included in the master template and run it. It errors on the very frist step of the restore profile. I can run the restore on its own without making any changes to the variables and it works fine.

       

      Basically I can run each of the templates individually and they work exactly as expected, but when I include them together it seems to cause predefined public variables to no longer work. I haven't seen this mentioned, so I don't know if this is a common issue or not. I would like to run this as one big task rather than have to run three separate tasks.

        • 1. Re: System/Profile Migration
          Alex.Richardson SSMMVPGroup

          Did you check that the profile migration templates dont have any template variables created that are the same name as your public variables?

           

          Template variables will override public ones.

          • 2. Re: System/Profile Migration
            Rookie

            I did check the variables and I didn't see any that were named the same and I also went through and made sure to put %% around system variables like Program Files that were built into the other templates. The actual point it is failing after the profile capture is mapping to my image tool and I even took out the variable I had for that task and added the direct path to the tool and it still failed. I have a task to map to my image share before mapping to the image tool and it works fine.

             

            The other situation when I run only the main task with the profile restore, it fails when trying to download one of the files included in the restore template. I was acutally wrong that this failure was a system variable issue, its actually a "failure to download the specified file" error.

            • 3. Re: System/Profile Migration
              SupportEmployee

              Check to make sure that the unc path you are saving to or restoring from is setup in the preferred server configuration. There is not need in 9.5 to map the path to the image files as this is done automatically for you now.

              • 4. Re: System/Profile Migration
                Rookie

                We only have one core which is our preferred server and we've been using it this way for provisioning for about 8 months working pretty much perfectly. I know things changed with the 9.5 upgrade, but I can't seem to get them to work properly. I've tried using the new way to capture the profile and it fails, I have taken out the map to image share task and it fails without it so I put it back. The old way of doing things still works somewhat, it just doesn't seem to work when including the capture and restore templates into my master provisioning template. When I downloaded the capture and restore templates from the document I linked to above, it did bring several other templates in with it that I didn't include in the master, but they were already included in the capture and restore templates, so I don't think I needed them in the main template. I think it would really screw things up if I did include them.

                 

                I've attached the XML code for my provisioning template if anyone would like to look at it. Maybe you will see what I'm overlooking or can find some things I could try changing up. Like I stated, individually each template runs flawlessly and does exactly what I need them to, but when I include the capture and restore templates things go haywire.

                • 5. Re: System/Profile Migration
                  LANDave SupportEmployee

                  Jwilliams,

                   

                  Did you ever get this working?

                   

                  If so, what was the answer?