5 Replies Latest reply on Sep 23, 2013 12:42 AM by synsa

    PROBLEM - PowerShell Distribution Package with LDMS 9.5

    Rookie

      We've recently upgraded from LDMS 9.0SP3 to 9.5, and I am having an issue with a PowerShell Distribution Package.

       

      This PowerShell script worked fine under 9.0SP3 and ran successfully on approximately 300 Windows 7 workstations.  Today, however, it is not working properly.

       

      LANDesk marks the scheduled tasks as "successful", but the script is not running successfully.

       

      There seems to be an odd issue associated with the execution policy...  If I set the package to run as the "current user's account" I'll see the PowerShell window pop up briefly, and the script will run correctly.  if I set the package to run as the "localsystem account" I'll get a brief message in the taskbar that indicates a process is trying to get my attention, but it always disappears before I can do anything with it - and the script does not run correctly.

       

      Additionally - I tried "set-executionpolicy bypass" to make sure that signing wasn't the issue (even though the script is signed)...  And after trying to run the scheduled task my execution policy is set to "restricted".  This is not something that I've got set anywhere in my script.  The scheduled task appears to be changing it to restricted for some reason.

       

      Again - this script used to work fine.

       

      Any suggestions?

        • 1. Re: PROBLEM - PowerShell Distribution Package with LDMS 9.5
          Frank Wils ITSMMVPGroup

          Can you post the logs from the ldclient\data map regarding this task?

           

          Frank

          • 2. Re: PROBLEM - PowerShell Distribution Package with LDMS 9.5
            Rookie

            Frank,

             

            I'm out of the office for a couple days and don't have access to those logs right now.

            I'll post them when I'm back in the office on Thursday.

             

            Thanks,

            Chris

            • 3. Re: PROBLEM - PowerShell Distribution Package with LDMS 9.5
              Rookie

              Back in the office today, and I've got additional information...

               

              I've been able to get the script to deploy and run.  I had to push an ExecutionPolicy "bypass" GPO to make it run (which I didn't need to do before).  So it's now generating output the way it's supposed to - which is certainly an improvement.  But I'm still getting a pop-up when it runs, which is not desirable.

               

              This is what pops up in the taskbar when I  deploy this script.

              _2013-03-21_07-54-17.png

               

              It doesn't hang around long.  I haven't actually been able to click through it to see what it's complaining about.  But it pops up just long enough to generate a pile of calls to our helpdesk with people wondering what's going on.

               

              I've attached the log from the task, as well as the PowerShell script that I'm trying to deploy.

               

              You'll see some complaints in the log that Get-ChildItem doesn't have access to some subfolders...  And I could probably fix that just by adding another "-ErrorAction SilentlyContinue" or two...  But, since it was working correctly, I never felt the need to do so.

               

              The header in that script is accurate - the last time it was modified was back in October of 2012.  At that time, I was able to run the script just fine without pushing a GPO to set the execution policy - as you can see, the script is signed.  The script also used to run completely silent - no pop-ups of any kind on the client machines.

               

              So, something has obviously changed in LDMS 9.5  I now need to push a GPO to set the execution policy just to make this script run.  And it's now generating a quick pop-up and scaring my users.

              • 4. Re: PROBLEM - PowerShell Distribution Package with LDMS 9.5
                Rookie

                Still having issues with Powershell scripts through LANDesk 9.5

                 

                They no longer run silently.  I'm still getting Powershell pop-ups that scare end-users.

                 

                Any suggestions?

                • 5. Re: PROBLEM - PowerShell Distribution Package with LDMS 9.5
                  synsa Specialist

                  I think the interactive services is a new feature from Windows VISTA forward and not specifically related to LDMS 9.5.  From memory we just disabled the interactive services, service.  It was causing pop-ups for VPN, scripts, and all other kinds of things we attempt to do in the background.  Pretty sure we didn't have any issues after turning it off and all the benefits of not annoying anyone.

                   

                  EDIT: I thought the last post said AUG not APR.  If this is no longer an issue then hopefully this post helps someone else.