10 Replies Latest reply on Apr 18, 2013 2:50 PM by Mariusz.Maniak

    "add note" notification mail failure

    Mariusz.Maniak Expert

      Hi,

       

      I would like to inform assignee when user has added a note, and user when note was added by assignee.

      In process (default full incident) in Add Note there are two reminders, one for assignee, second for user, booth filled as on pictrue (example for assignee).


       

      When a note was added there is a new entry on reminder list is generated with Is Active = true, after a minute or two "Is active" goes to false.

      And thats all. On "Message Recipient List" nothing isn't created, and no email has been sent. Event logs on servers - no errors, only information from MailOutbound: Logging OnContinue with user : System Url: http://localhost/LanDesk2.Framework

       

      But when incident is logged, message to user was sent properly.

      Why note messages fails?

        • 1. Re: "add note" notification mail failure
          elizabethcombrink Expert

          Mariusz - can you see the message you are expecting to be sent in the tps_user_message table?

           

           

          select

          * from

          tps_user_message

           

          if you can, then a reminder has been created (and the fact that the Is Active flag gets unticked suggests that it is)

          then idenity in the tps_user_message_recipient table who the recipients are

          • 2. Re: "add note" notification mail failure
            Mariusz.Maniak Expert

            In tps_user_message are only messages sent to enduser when incident was created, in tps_user_message_recipient - recipients these messages. Nothing about "add note" messages.

            I also tried to check logfiles:

            So in tps.config:

            <add key="TraceLevel_Authentication" value="All" />

            <add key="TraceLevel_BackgroundProcessing" value="All" />

            <add key="TraceLevel_LifecycleProcessing" value="All" />

             

            And what I get is:

             

            LifecycleProcessing

            Begin Lifecycle Action at 2013-04-17 13:31:46.470

            Class Type: IncidentManagement.Incident

            Primary Key: 2e65b6c4-e80d-45ac-aec0-cbadefa32858

            Original Lifecycle: Full Incident

            Original Status: W realizacji

            Business Function: AddNote

            Parameter1:

            Parameter2:

            SUCCEEDED

             

            LifecycleProcessing

            Lifecycle Step at 2013-04-17 13:31:46.470

            Class Type: IncidentManagement.Incident

            Primary Key: 2e65b6c4-e80d-45ac-aec0-cbadefa32858

            Step Type: Action

            Action: Dodaj notatkę

            Is Automatic?: False

            SUCCEEDED

             

            LifecycleProcessing

            Lifecycle Step at 2013-04-17 13:31:46.485

            Class Type: IncidentManagement.Incident

            Primary Key: 2e65b6c4-e80d-45ac-aec0-cbadefa32858

            Step Type: PostCondition

            Condition: Note created by Assigned User?

            SUCCEEDED

             

            LifecycleProcessing

            Lifecycle Step at 2013-04-17 13:31:46.485

            Class Type: IncidentManagement.Incident

            Primary Key: 2e65b6c4-e80d-45ac-aec0-cbadefa32858

            Step Type: Action

            Action: Add Reminder

            Is Automatic?: True

                Value: SendDate = 03/09/2008 15:53:01

                Value: IsActive = True

                Value: NotifySupplier = False

                Value: Subject = Incydent o numerze {Id} zostało uaktualniony

                Value: Group = Incident/CurrentAssignment/Group

                Value: Body = Użytkownik: {Notes/CreationUser} dodał notatkę o treści:<br />

            {Notes/Text} <br />

             

            <a href="http://LanDeskProd.WebAccess/wd/object/open.rails?class_name=IncidentManagement.Incident&key={Guid}">Link do incydentu </a>

             

             

                Value: NotifyAssignee = True

                Value: Subject = Incydent o numerze {Id} zostało uaktualniony

                Value: NotifySupplier = False

                Value: IsActive = True

                Value: Group = Incident/CurrentAssignment/Group

                Value: NotifyAssignee = True

                Value: Body = Użytkownik: {Notes/CreationUser} dodał notatkę o treści:<br />

            {Notes/Text} <br />

             

            <a href="http://LanDeskProd.WebAccess/wd/object/open.rails?class_name=IncidentManagement.Incident&key={Guid}">Link do incydentu </a>

             

             

                Value: User = Incident/CurrentAssignment/User

                Value: SendDate = 03/09/2008 15:53:01

            SUCCEEDED

             

            LifecycleProcessing

            Lifecycle Step at 2013-04-17 13:31:46.485

            Class Type: IncidentManagement.Incident

            Primary Key: 2e65b6c4-e80d-45ac-aec0-cbadefa32858

            Step Type: Status

            New Status: W realizacji

            SUCCEEDED

             

            LifecycleProcessing

            Lifecycle Action at 2013-04-17 13:31:46.485

            Class Type: IncidentManagement.Incident

            Primary Key: 2e65b6c4-e80d-45ac-aec0-cbadefa32858

            Final Lifecycle: Full Incident

            Final Status: W realizacji

            Business Function: AddNote

            Parameter1:

            Parameter2:

            SUCCEEDED

            • 3. Re: "add note" notification mail failure
              elizabethcombrink Expert

              and the group you are sending to does have analysts which are set to receive group messages?

              It certainly looks like it is creating the reminder, but then it should be in your tps_user_message_table.

              Are your background processes running?  (Is that not what creates the reminder?)

              • 4. Re: "add note" notification mail failure
                Expert

                I do things a bit differently.  I use an add reminder in Process for each e-mail.  It gives me the option to format the e-mails differently.  I always make the e-mails different so their targeted better to the audience, more info and pretty for end users and bare bones short for analyst.  I check to see who added the note.  If the assigned analyst added the note, no need to notify them, otherwise an e-mail goes to that person.  If not assigned to an analyst then it goes to the assigned group. 

                 

                Does your incident have a CurrentAssiged/User?  If not it went exactly where it should.  In 7.5 I am having issues with CurrentAssignment where it is blank so make sure you really have a value there.

                • 5. Re: "add note" notification mail failure
                  Mariusz.Maniak Expert

                  Background service is running, but how to check if group is recieving group messages? (i just removed all users from group, and added again to be sure about "recieve group messages" was checked)

                   

                  But even if in reminder window user was set directly (just choosen from drop down list) mail wasn't sent.

                  • 6. Re: "add note" notification mail failure
                    elizabethcombrink Expert

                    in administration, open up the tree and select the support group, and expand the analysts in the group

                    Right click on each analyst, and select modify user group. There should be a tick box on there that says receive group messages

                    • 7. Re: "add note" notification mail failure
                      Mariusz.Maniak Expert

                      Users checked, all support groups can recieve messages, but now I'm checking if emails aren't sent to empty addresses:

                      when I'm looking at incident - Current assigned analyst is filled, but current assigned group, current assignment user and current assignment group are empty. So I need to check where to send my notifications...

                       

                       

                       

                      Macro: "$current user$" works fine, but values prepared by placeholders or calculation fails...

                      "add note" part of my process  - see image, it is part of default "reach incident"

                       

                      Message was edited by: Mariusz Maniak

                      • 8. Re: "add note" notification mail failure
                        Mariusz.Maniak Expert

                        csimpson:

                        Take a look why my "CurrentAssignment" is blank...

                        http://community.landesk.com/support/message/89257#89257

                         

                        Did You solved this problem?

                        • 9. Re: "add note" notification mail failure
                          Expert

                          My problem is that I have two process generated assignments before hitting "In Progress".  One assigns all incidents to a group.  The second will sometimes add the current user.  In SQL I can see the serial numbers are correct but the time that the records was written is exactly the same, even to the third decimal place (although the 3 decimal places are always 000).  Support is looking into this as a potential bug.

                           

                          In SQL I see two records one with just a group assignment and the other with a group and currentuser.  My incidents show both records in the assignments tab but the wrong one is being used by the incident because it does not show the currentuser that was assigned.  Funny thing is that anything printed shows the correct currentuser, I use the serial number so it's correct.  Now if I do a manual assignment after all of the above, then the correct currentuser and group will show up.  It would appear that 7.5 changed to the time/date and not the serial number because this was not an issue in 7.4.  Well, I should say I don't think so.  My boss thinks that he saw the same thing in 7.4 but in my old age I just don't remember.

                          • 10. Re: "add note" notification mail failure
                            Mariusz.Maniak Expert

                            Problem solved.

                             

                            Remainders tried to send emails to empty addresses. It was because I changed "add assignment" action from optional one in "in progress" status to separate one. As result of this change "current assignment user" and "current assignment group" attributes were empty, only "Current assigned analyst" "current assigned group" were filled in. After change "add assignment" back to optional action - mails are working ok. I lost possibility to inform analyst about incident assigned to him, but note has higher priority on my list