8 Replies Latest reply on May 20, 2013 9:22 AM by jdaugherty

    LANDesk Management Suite Console

    Apprentice

      I have installed the Managenment Suite (9.50.0.530) Console on my desktop and when I try to login it says:

       

      [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied. Invalid connection string attribute.

       

      It works fine when I log in on the server. I have tried Google, searching these forums, and searching the rest of the LANDesk site for documentation. Does anyone have any suggestions for me, or a link to some documentation?

       

      Thank you

       

      Joshua Daugherty

      IT Dept

      Hillsdale Community Health Center

      [email protected]

        • 1. Re: LANDesk Management Suite Console
          mrspike SSMMVPGroup

          One of these two things will usually solve the issue:

           

          1)  Ensure your console is at the same patch level as your core... meaning, install all of the same post 9.5 patches to your console system

           

           

          2)  Create shortcut to the console on your desktop, now RIGHT click on it, choose "Run as Different User" and now enter in the credentials you use to also log into the LANDesk login box.     Now when the LANDesk login box opens, log in in this format:   your_domain\your_log_in_name

          1 of 1 people found this helpful
          • 2. Re: LANDesk Management Suite Console
            Apprentice

            Thank you for the suggestions. The shortcut suggestion did not work. I have two patches on my core. I installed one of them on my workstation, the other will not install. It gives me an error saying this update requires a LANDesk Software version 9.5 core or console (which it has). I am going to start digging for information on that,

             

            Thank you

             

            Joshua

            • 3. Re: LANDesk Management Suite Console
              Apprentice

              Here is my current situation: I have installed the LANDesk Management Suite Remote Console on my laptop. My core server has the following two patches: LD95-CP_AEM-2012-1127 & LD95-CP_BASE-2012-1127. I installed the BASE patch on my Laptop with no issues. When I attempt to install the AEM patch I get an error saying this update requires a LANDesk Software version 9.5 core or console.

               

              Any thoughts, comments, stabs in the dark would be appreciated.

               

              Joshua

              • 4. Re: LANDesk Management Suite Console
                mrspike SSMMVPGroup

                If you look in folder of the patch where the setup.exe is located, is there a file called console.inf?

                 

                If not, the patch is not meant for console systems.

                • 5. Re: LANDesk Management Suite Console
                  Asraf Radzi Apprentice

                  Have you try to resolve based on below link?

                   

                  http://community.landesk.com/support/docs/DOC-1105

                  • 6. Re: LANDesk Management Suite Console
                    Apprentice

                    The console.inf file is not there. Thank you, that is one variable eliminated.

                    • 7. Re: LANDesk Management Suite Console
                      Apprentice

                      Asraf, In the link referenced it begins by looking at the string at

                      HKLM\Software\LANDesk\ManagementSuite\Core\Connections\Local. I do not even have HKLM\Software\LANDesk. Under HKCU I can get as far as \Software\LANDesk\ManagementSuite\Core.

                      • 8. Re: LANDesk Management Suite Console
                        Apprentice

                        I found the answer by combining information from several places. Part was from Doc 1105

                        http://community.landesk.com/support/docs/DOC-1105 (Thank you Asrif)

                         

                        The rest was from

                        http://community.landesk.com/support/thread/14790

                         

                        The SQL Server port was found to be non-standard by going to the registry: HKLM\Software\Microsoft\Microsoft SQL Server\LDMSDATA\MSSQLServer\SuperSocketNetLib\TCP.

                         

                        Then Windows Firewall was configured to allow the non-standard port to accept incoming traffic.

                         

                        If anyone else has this problem, there are potentially many causes. The two links here cover all of them that plagued me. Make sure you start with the list Yuh posted in thread 14790. I pasted it below.

                         

                        "Good day!

                         

                        I have taken a look at document 1105 for my initial troubleshooting steps but I haven't had success in getting past the "connecting to database" step upon login.  It would fail with the following message:

                         

                        [DBNETLIB][ConnectionOpen (Connect()).] SQL Server does not exist or access denied.  Invalid connection string attribute.

                         

                        The following items have been done on the CoreServer:

                        1.  Added the registry entry (the keys did not exist) HKLM\Software\LANDesk\ManagementSuite\Core\Connections\Local.  String == ServerName & Value == FQDN.

                        2.  The SQL Server port was found to be non-standard by going to the registry: HKLM\Software\Microsoft\Microsoft SQL Server\LDMSDATA\MSSQLServer\SuperSocketNetLib\TCP.

                        3.  I have verified in SQL 2005 that named pipes & TCP/IP is enabled.  I also verified that the IP address exists under the enabled TCP/IP properties as well as the proper port number found in #2.

                        4.  Windows Firewall has allowed the non-standard port to accept incoming traffic.

                         

                        The following items have been done on the workstation where the Remote Console is located:

                        1.  Create a system DSN with the non-standard port.  Connection succeeds when you do a test.

                        2.  I am able to PING the server (FQDN & IP Address) and TELNET into the server using the non-standard port.

                        3.  Enabled TCP/IP & Named Pipes in c:\Windows\System32\cliconfg.exe

                        4.  Rebooted the workstation.

                         

                        Notes:

                        1.  Regardless of whether the firewall is turned on/off, I am still unable to make a connection to the database.

                         

                        Any leads would be greatly appreciated.

                         

                        HY"