3 Replies Latest reply on May 24, 2013 10:59 AM by sdstu03

    Provisioning Template Tasks run as System user


      We recently updated LDMS from 9.0 to 9.5


      As part of that transition, we migrated all of our provisioning templates that install software on new machines to the new core.

      We found, however, that these tasks (mostly Execute File tasks) now seem to always run as the System user, but in 9.0, these ran as the current user logged into the machine. This mean we could actually see the software installing silently, but if there was an error and a exe hung up, we would be able to fix them easily. Now we don't see any feedback for the app, our only option is to kill the process and let the rest of the template finish.


      Is there anyway get back to having these tasks run as the current user? Since this is run during provisioning of a new computer, the local admin is logged in and permisisons are not an issue. We also don't ever run provisioning on deployed machines with active endusers.


      We have tried various RunAsUser commands and tools with varying success, but we would prefer not to pass around passwords and need to prepend every task with another executable


      Has anyone else seen this issue? Anyway arround it? Any settings we can tweak to change the user tasks execute as?

        • 1. Re: Provisioning Template Tasks run as System user
          Frank Wils ITSMMVPGroup



          This is the new way of 9.5, no easy way around it. You could try the startasuser.exe in the LDClient map. That doesn't need any passwords or anything and just kicks off the command after as the logged in user, i.e.:


          c:\program files (x86)\LANDesk\LDclient\startasuser.exe notepad.exe



          • 2. Re: Provisioning Template Tasks run as System user
            jary.busato Apprentice

            Did you try "startasuser.exe" in LDCLIENT folder?





            1 of 1 people found this helpful
            • 3. Re: Provisioning Template Tasks run as System user

              To both Frank and Jary,


              We’d tried using startasuser, and we’ve been trying again this week, but each time has produced more issues.


              For instance, some of our tasks are custom status windows, utilities, etc. that we use for development. As an example, we have a custom full screen ‘Maintenance in Progress’ window that we want to appear if we are doing in-place re-imaging and don’t want any user to try to use the computer during system configuration. Under 9.0, we ran that exe as the first task, this message appeared, and provisioning continued. If we try to run that using startasuser, then the message usually appears, but landesk waits for startasuser to exit, and startasuser doesn’t exit until that message is closed.


              I say ‘usually’ because we’ve also had issues with placement of startasuser tasks relative to placements of reboots during provisioning. We’re still trying different orders of tasks, but it seems that if we try to use startasuser during the first boot into windows, it fails to display. But if we add a reboot before the startasuser task, the program will be visible.


              We’re going to continue trying to get these to work, but we may end up giving up on some of the little things that we had working under 9.0. We’ll also have to deal with minimal feedback (the result code) to fix problems that kill the deployment, whereas we used to be able to see any visible errors from software installers.


              Thank you both for your assistance